Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN











Search Auto Parts

Engine Troubleshooting


(30907 posts in 5964 threads)
AMSOIL Corporate Website



Sign up here!

  First page Previous page 1 2 3 4 5 6 7 8 9 ... 100 Next page Last page
    Subject Views Replies Last Post
Post with replies   Root post 2001 Mazda protege pleaseeeee helpppp 565 3 Jan 23, 2017, 2:45 PM
(Hammer Time)
Hot thread - Post has replies   Root post Cold Start rough for 5s after changing fuel filter 779 15 Jan 23, 2017, 12:32 PM
(k_bo)
Post with replies   Root post 2006 Ford Escape Engine Wont Run 672 3 Jan 18, 2017, 3:22 PM
(Hammer Time)
Post with replies   Root post 47 cj2a 69camero.edelbrock 1400 carb help please! 520 4 Jan 18, 2017, 1:20 PM
(kev2)
Hot thread - Post has replies   Root post 92 c1500 no fuel no spark no start 657 14 Jan 11, 2017, 2:50 PM
(tracymrhd)
Hot thread - Post has replies Root post runs lean after cleaning injectors 824 23 Jan 11, 2017, 1:27 PM
(mikewax)
Post with replies   Root post cooling system 559 3 Jan 10, 2017, 7:03 PM
(Hammer Time)
Hot thread - Post has replies   Root post Rough Idle 2013 Savana 628 6 Jan 10, 2017, 3:29 PM
(rryan)
Post with replies Root post Chocked muffler 531 1 Jan 7, 2017, 9:21 PM
(Hammer Time)
Hot thread - Post has replies   Root post 2008 Mercedes B200 Noise 604 9 Jan 7, 2017, 4:40 PM
(Hammer Time)
Post with replies   Root post jeep liberty 2006 170,00miles 387 2 Jan 5, 2017, 11:03 AM
(nickwarner)
Post with replies   Root post 2002 Ford Mustang GT - Cylinder wont fire 464 2 Jan 3, 2017, 4:20 AM
(Hammer Time)
Post with replies   Root post 2005 Dodge Neon SX 2.0 Engine smell. 435 1 Dec 30, 2016, 12:13 PM
(Tom Greenleaf)
Post with replies   Root post nightmare of leaking injectors 460 4 Dec 28, 2016, 6:21 PM
(mikewax)
Hot thread - Post has replies   Root post 2000 Durango 4.7l 4wd won't start 684 9 Dec 23, 2016, 4:37 PM
(Discretesignals)
Post with replies   Root post Van wouldn't start but when connected to jumper cables it tried to start without KEY in ignition 425 1 Dec 22, 2016, 12:27 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 2003 Mitsubishi Outlander - Very Low MPG 878 10 Dec 19, 2016, 7:22 AM
(Hammer Time)
Hot thread - Post has replies   Root post 99 mercury tracer 2.0L Split Port torque specs 741 6 Dec 15, 2016, 5:33 PM
(Nihel)
Post with replies   Root post 2000 Mercury Truck Mountaineer 4WD 4.0L EFI SOHC 6cyl 432 2 Dec 15, 2016, 2:50 PM
(Hammer Time)
Hot thread - Post has replies   Root post chk engine-low coolant temp after radiator replace 07explorer 578 8 Dec 15, 2016, 10:50 AM
(Discretesignals)
Post with replies   Root post Problem starting truck 580 1 Dec 10, 2016, 11:07 AM
(Hammer Time)
Post with replies   Root post 1993 HONDA DEL SOL 1.5L SOHC 4CYL 315 1 Dec 7, 2016, 7:02 PM
(Hammer Time)
Hot thread - Post has replies   Root post cold start idle 774 11 Dec 6, 2016, 1:48 PM
(chas)
Post with replies Root post spark plug issue 385 2 Dec 3, 2016, 10:33 PM
(nt)
Post with replies   Root post 07 Mazda 3 boost of power without turbo 499 2 Dec 1, 2016, 8:39 AM
(Discretesignals)
Post with replies   Root post Engine Troubleshoot - Please Help! 727 4 Dec 1, 2016, 6:52 AM
(kev2)
Post with replies   Root post LDV Convoy, 2.5 Di, starter motor issues 741 2 Nov 30, 2016, 3:50 AM
(Tom Greenleaf)
Post with replies   Root post crank no start 734 5 Nov 28, 2016, 6:25 PM
(Discretesignals)
Hot thread - Post has replies   Root post Squeaky Auxiliary Drive Belt - Need Some Help Please! (WITH VIDEO) 767 22 Nov 25, 2016, 5:55 AM
(Tom Greenleaf)
Post with replies   Root post 90 chevy astro van 4.3 307000mi 503 1 Nov 23, 2016, 5:10 AM
(Hammer Time)
Hot thread - Post has replies Root post 92 silverado 1500 4.3 123k miles 761 17 Nov 22, 2016, 5:45 PM
(Hammer Time)
Post with replies   Root post mystery car problem 853 2 Nov 22, 2016, 5:33 AM
(Discretesignals)
Post with replies This thread is locked   Root post 2005 Ford Escape timing/ignition issue *with video 544 5 Nov 19, 2016, 12:36 PM
(Discretesignals)
Post with replies   Root post 1979 Ford control boxes help 477 3 Nov 19, 2016, 11:54 AM
(Discretesignals)
Hot thread - Post has replies   Root post Re: 77 Trans Am rough idle and engine pulsation 854 6 Nov 17, 2016, 10:13 AM
(Pureatx)
Post with replies   Root post Hyundai i20 1.4l No Acceleration 528 2 Nov 16, 2016, 6:34 AM
(kev2)
Hot thread - Post has replies   Root post Vw polo classic Engine Temperature Problem 943 5 Nov 14, 2016, 6:16 AM
(Tom Greenleaf)
Post with replies   Root post 1996 F-350 7.5L gas engine won't accelerate. Idles good. No check engine light 687 1 Nov 6, 2016, 12:57 PM
(kev2)
Hot thread - Post has replies   Root post oil capacity - 1981 Toyota Corolla 657 10 Oct 28, 2016, 4:22 PM
(Hammer Time)
Hot thread - Post has replies This thread is locked   Root post 2005 Ford Escape timing/ignition issue *with video 1360 21 Oct 28, 2016, 2:29 PM
(Hammer Time)
Post with replies   Root post motor idles up & down up & down 1979 MARK V LINCOLN 584 1 Oct 23, 2016, 10:56 PM
(Tom Greenleaf)
Post with replies   Root post BMW 328i (2000) Where does the throttle cable connect to the throttle body? 417 1 Oct 22, 2016, 2:17 PM
(Discretesignals)
Post with replies   Root post cadillac check engine light won't go out after new vacuum pump 649 4 Oct 21, 2016, 11:59 AM
(kev2)
Post with replies   Root post If I do not flush the coolant periodically, what will happen? 500 4 Oct 16, 2016, 11:05 PM
(Tom Greenleaf)
Post with replies   Root post Car jumpleads connected wrong way!! 488 2 Oct 15, 2016, 12:13 PM
(kev2)
Post with replies   Root post battery, alternator and starter working good? car struggles to start 576 3 Oct 14, 2016, 10:17 AM
(Tom Greenleaf)
Post with replies   Root post 15PSI cylinder pressure vs 150. Is it fixable? 494 3 Oct 12, 2016, 4:10 PM
(Discretesignals)
Post with replies   Root post Vibrations and potential loss of power - Citroen C1 2006 953 1 Oct 11, 2016, 4:46 AM
(Discretesignals)
Hot thread - Post has replies Root post 2007 Chrysler Pacifica 4.0L engine replacement 640 12 Oct 9, 2016, 12:03 PM
(07Pacifica)
Hot thread - Post has replies   Root post Bad starter motor??? 503 5 Oct 6, 2016, 12:06 PM
(Tom Greenleaf)
Post with replies   Root post Car jerks/hard kick when accelerates 448 4 Oct 5, 2016, 1:16 PM
(kev2)
Post with replies Root post Truck not going above 40km/h on small hills? 548 1 Sep 29, 2016, 4:25 PM
(kev2)
Hot thread - Post has replies   Root post '06 chevy malibu shuts off while driving 1279 7 Sep 29, 2016, 4:45 AM
(Discretesignals)
Post with replies   Root post Metal on metal sound near crank shaft 673 4 Sep 26, 2016, 8:47 AM
(Tom Greenleaf)
Post with replies   Root post Turbo pipe blown and brown substance sprayed on engine 578 2 Sep 25, 2016, 7:51 AM
(Discretesignals)
Hot thread - Post has replies   Root post ?? PVC .. 548 5 Sep 24, 2016, 2:36 PM
(nondriver)
Hot thread - Post has replies   Root post 2005 T&C missfire 3.3l 937 18 Sep 19, 2016, 10:58 AM
(Hammer Time)
Hot thread - Post has replies   Root post Frustrated and at the end of my rope 538 9 Sep 17, 2016, 12:23 PM
(kev2)
Hot thread - Post has replies This thread is locked   Root post Thermostat housing leaking 584 5 Sep 17, 2016, 4:58 AM
(Hammer Time)
Post with replies   Root post Cylinder misfire 611 2 Sep 16, 2016, 8:28 PM
(Tom Greenleaf)
  First page Previous page 1 2 3 4 5 6 7 8 9 ... 100 Next page Last page


LEGEND
Hot thread = Hot thread
Post with replies = Post with replies
Thread locked = The thread is locked
Root post = First post in thread


FORUM RULES
You cannot start new threads
You cannot post replies
 


Feed Button




Search for (options) Privacy Sitemap