Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN







Engine Troubleshooting


(28522 posts in 5591 threads)
AMSOIL Corporate Website



Sign up here!

  First page Previous page 1 2 3 4 5 6 7 8 9 ... 94 Next page Last page
    Subject Views Replies Last Post
Post This thread is locked   Root post FORUM RULES ==== READ BEFORE POSTING 4007 0 Jul 31, 2012, 5:16 PM
Post with replies This thread is locked   Root post Car Acronyms used commonly 4244 3 Mar 26, 2012, 4:01 PM
(way2old)
Hot thread - Post has replies   Root post Camaro No Start 288 23 Apr 30, 2016, 2:22 PM
(HarmonIV)
Post with replies   Root post idle stop solenoid 49 1 Apr 29, 2016, 1:10 PM
(Discretesignals)
Post with replies   Root post 2003 Oldsmobile Truck Bravada AWD 4.2L SFI DOHC 6cyl 38 1 Apr 29, 2016, 1:10 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post leaking oil from all 4 exhaust ports 80 7 Apr 26, 2016, 10:14 PM
(Tom Greenleaf)
Post with replies   Root post Ford KA 1999 - Engine turns down after driving a while and going slow 44 1 Apr 24, 2016, 11:13 AM
(Tom Greenleaf)
Post with replies   Root post 1996 Acura TL 2.5 overheats - Should I scrap it? 37 3 Apr 23, 2016, 2:04 PM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Camry Will Not Start 109 5 Apr 22, 2016, 2:29 AM
(Tom Greenleaf)
Post with replies   Root post Ford Explorer engine troubles 686 1 Apr 20, 2016, 6:40 PM
(Discretesignals)
Post with replies   Root post Falcon AU III - Possible blown head gasket or welsh plug 42 2 Apr 19, 2016, 4:28 AM
(Tom Greenleaf)
Post with replies   Root post Timing adjustment 1998 Nissan Altima 45 1 Apr 18, 2016, 2:17 AM
(Hammer Time)
Post with replies   Root post Ford escort ZX2 52 3 Apr 17, 2016, 12:44 PM
(Tom Greenleaf)
Post with replies   Root post VW 2.0 Carburator Engine - Bad cold idle and now vacuum reading 87 4 Apr 15, 2016, 11:57 PM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Toyota Tercel 95 1.3L Carburetor problem 49 5 Apr 15, 2016, 7:55 AM
(Tom Greenleaf)
Post with replies   Root post Engine runs better with vehicle heater on 68 1 Apr 10, 2016, 8:14 AM
(Hammer Time)
Post with replies   Root post Pontiac Bonneville SE 1998 - Intake Manifold Issues 71 2 Apr 7, 2016, 6:58 PM
(Discretesignals)
Hot thread - Post has replies   Root post running rough 06 expedition 284 19 Apr 7, 2016, 6:54 PM
(Discretesignals)
Post with replies   Root post 1996 k1500 engine wont start 100 3 Apr 4, 2016, 2:04 AM
(Hammer Time)
Post with replies   Root post Misfire, gas in oil 125 2 Mar 27, 2016, 8:02 AM
(kev2)
Post with replies   Root post 2001 Honda Civic won't start after Fuel Pump Repair 102 3 Mar 26, 2016, 8:16 AM
(Hammer Time)
Post with replies This thread is locked   Root post pcm? 66 1 Mar 23, 2016, 6:26 PM
(Hammer Time)
Post with replies   Root post 2004 chevy express van 5.3L idle speed 90 1 Mar 20, 2016, 2:12 PM
(kev2)
Post with replies   Root post How do I not cross thread spark plugs? 11413 7 Mar 18, 2016, 4:17 AM
(Discretesignals)
Post with replies   Root post 2002 ford ranger 3.0 misfire 10601 2 Mar 16, 2016, 6:14 PM
(Discretesignals)
Hot thread - Post has replies   Root post 2001 Toyota Celica replaced fuel pump now no start 146 7 Mar 12, 2016, 6:28 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post oil puddle, car cranks but won't turn over 142 5 Mar 10, 2016, 4:09 AM
(mcathie1)
Post with replies   Root post coolant pump leak 61 1 Mar 9, 2016, 7:14 AM
(Tom Greenleaf)
Hot thread - Post has replies Root post Please help! 115 6 Mar 8, 2016, 10:40 AM
(Hammer Time)
Hot thread - Post has replies This thread is locked   Root post Misfire Conundrum... 210 16 Mar 7, 2016, 11:28 PM
(Tom Greenleaf)
Post with replies Root post 1993 Ford Escort Wagon starts to jerk and shudder at 50mph 94 1 Mar 5, 2016, 3:13 PM
(Hammer Time)
Post with replies   Root post Overheating Nissan Turbo 92 2 Mar 3, 2016, 10:40 AM
(Hammer Time)
Post with replies   Root post Electric fans not turning on; odometer not functioning 118 4 Mar 1, 2016, 8:11 PM
(Tom Greenleaf)
Post with replies   Root post 05 Optima stalls, starts back up, no power on acceleration 95 1 Feb 28, 2016, 4:24 PM
(Hammer Time)
Post with replies   Root post 1996 Lancer Engine stutters when accelerating 109 1 Feb 26, 2016, 5:41 AM
(Tom Greenleaf)
Hot thread - Post has replies This thread is locked   Root post ENGINE MISS FIRES 182 7 Feb 26, 2016, 2:58 AM
(Hammer Time)
Post with replies   Root post car has white/gray smoke and high idle 158 4 Feb 23, 2016, 7:50 PM
(taylorh)
Post with replies   Root post 91 F150 engine ignition system failure 213 5 Feb 22, 2016, 7:30 PM
(Discretesignals)
Post with replies   Root post Turbo Diesel Engine Power Surging 135 1 Feb 14, 2016, 10:52 PM
(nickwarner)
Post with replies   Root post 2000 Mazda 626 cranks but wont start 165 6 Feb 13, 2016, 1:09 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Coolant only leaks when driving 107 5 Feb 10, 2016, 1:59 PM
(Hammer Time)
Post with replies   Root post Coolant in my oil - 1996 Cummins C 8.3 - 210 hp 132 1 Feb 9, 2016, 2:50 AM
(nickwarner)
Post with replies   Root post drl 102 2 Feb 7, 2016, 6:10 PM
(eyob07)
Post with replies   Root post 1998 chevy truck won't start 105 1 Feb 7, 2016, 1:15 PM
(Discretesignals)
Post with replies   Root post where are the spark plugs hiding 81 1 Feb 6, 2016, 10:53 PM
(Tom Greenleaf)
Post with replies   Root post SMAX Zetec 2.0 TDCi 2010 Plate - Why will my car struggle to start 1 time in 50 without obvious reason? (see video) 94 1 Feb 4, 2016, 6:26 PM
(Discretesignals)
Post with replies   Root post Is my engine burning too much oil? 136 4 Feb 4, 2016, 10:41 AM
(Hammer Time)
Post with replies   Root post 1998 Chevrolet Suburban LT 103 1 Feb 4, 2016, 10:12 AM
(Hammer Time)
Post with replies   Root post gas coming back out vent hole on oilfiller tube 107 1 Feb 3, 2016, 7:56 AM
(Discretesignals)
Hot thread - Post has replies This thread is locked   Root post 1988 mazda rx7 starter problems 3409 18 Feb 2, 2016, 2:07 PM
(Hammer Time)
Post with replies   Root post Citroen C15 1,9D bad start 95 3 Jan 31, 2016, 12:15 PM
(Tom Greenleaf)
Hot thread - Post has replies This thread is locked   Root post 99 Pontiac Grand Am - won't start 132 9 Jan 31, 2016, 11:29 AM
(Discretesignals)
Post with replies   Root post 2003 VW Passat 122 4 Jan 31, 2016, 8:15 AM
(Discretesignals)
Post with replies   Root post Cylinder not pulling its weight 129 4 Jan 30, 2016, 3:01 PM
(KD5NRH)
Post with replies   Root post Nissan Pathfinder 2003 LE Oil Leak 106 4 Jan 29, 2016, 10:30 AM
(Tom Greenleaf)
Post with replies   Root post Need help with Chrysler Pt Cruiser 08 106 3 Jan 27, 2016, 11:32 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 1999 Toyota Corolla engine dies when accelerator pressed 443 13 Jan 26, 2016, 4:28 AM
(Discretesignals)
Hot thread - Post has replies   Root post 2002 suzuki 2.7 xl7 4x4, upstream o2 misbehaving 215 8 Jan 25, 2016, 7:26 AM
(kev2)
Post with replies   Root post 1996 Toyota Camry open circuit to fuel pump 149 3 Jan 24, 2016, 11:44 AM
(physix101)
Post with replies   Root post no start when extreme cold 132 3 Jan 19, 2016, 7:25 PM
(Discretesignals)
Hot thread - Post has replies This thread is locked   Root post 2002 Ford Tuurus - starts, then won't start weeks later? 415 16 Jan 17, 2016, 11:42 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 2008 Mariner V6 AWD error code P0446 214 8 Jan 16, 2016, 6:55 AM
(Tom Greenleaf)
  First page Previous page 1 2 3 4 5 6 7 8 9 ... 94 Next page Last page


LEGEND
Hot thread = Hot thread
Post with replies = Post with replies
Single post = Single post
Thread locked = The thread is locked
Root post = First post in thread


FORUM RULES
You cannot start new threads
You cannot post replies
 






Latest Forum Post

so i have a 98 lumina 3.1 .. recently i was driving down the road and it stalle...


1986 Itasca Phasar (Same as Winnebago Lesharo or Renault Trafic 2L Turbo Diesel ...


1972 Ford F750. I have no power assist. All vacuum lines to the booster seem OK....


I have been trying to figure this out since last October and have had no luck. ...


SO I have a squealing noise coming from somewhere underneath the hood in my van,...


92 Ford F150. 5.0. I purchased vehicle and AC did not work, tried charging and ...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics