Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN







Search Auto Parts

Engine Troubleshooting


(30027 posts in 5801 threads)
AMSOIL Corporate Website



Sign up here!

  First page Previous page 1 2 3 4 5 6 7 8 9 ... 97 Next page Last page
    Subject Views Replies Last Post
Post with replies   Root post Toyota Misfire And White Smoke On Cold Starting 281 4 Feb 28, 2017, 1:43 AM
(sa2017)
Hot thread - Post has replies   Root post 350 tbi won't idle or drive 332 13 Feb 27, 2017, 6:52 PM
(Hammer Time)
Hot thread - Post has replies Root post 1990 F-250 Engine Dies while Driving 274 9 Feb 24, 2017, 2:51 PM
(Tom Greenleaf)
Post with replies   Root post Hard to start,runs rough at high speed. 201 3 Feb 20, 2017, 9:02 AM
(kev2)
Hot thread - Post has replies   Root post dies at cold start up unless throttle applied 212 5 Feb 19, 2017, 8:08 AM
(kev2)
Hot thread - Post has replies   Root post Antifreeeze in crankcase 488 20 Feb 18, 2017, 7:52 PM
(dmartin)
Hot thread - Post has replies   Root post At my wits end -Codes P1130 P1150 P1131 P1151 401 17 Feb 15, 2017, 3:46 PM
(Hammer Time)
Hot thread - Post has replies Root post Intermittent rev surge with intermittent fault codes 469 10 Feb 14, 2017, 1:20 PM
(JakeSublime)
Hot thread - Post has replies   Root post no start 583 33 Feb 11, 2017, 3:51 PM
(dadrobb)
Hot thread - Post has replies   Root post 2002 civic no start 451 21 Feb 11, 2017, 7:19 AM
(dr.donut)
Post with replies Root post 1990 Ford F-250 351W, NO timing Advance 227 3 Feb 9, 2017, 1:35 PM
(Hammer Time)
Post with replies   Root post 03 5.3 loss of power, not always, intermediate 204 2 Feb 9, 2017, 8:50 AM
(kev2)
Hot thread - Post has replies   Root post car stalls and dies when ever you stop 228 5 Feb 7, 2017, 8:13 AM
(Hammer Time)
Hot thread - Post has replies   Root post crank no start 242 5 Feb 6, 2017, 5:25 AM
(Discretesignals)
Hot thread - Post has replies   Root post 2003 Buick Century engine knocking 194 6 Feb 1, 2017, 4:19 PM
(wrightpaint)
Hot thread - Post has replies This thread is locked   Root post 1990 Chevrolet C1500 won't start when cold 691 40 Jan 28, 2017, 12:07 AM
(Tom Greenleaf)
Post with replies   Root post ignition lock cylindee 216 6 Jan 26, 2017, 7:21 PM
(Hammer Time)
Post with replies   Root post 2001 Mazda protege pleaseeeee helpppp 203 3 Jan 23, 2017, 2:45 PM
(Hammer Time)
Hot thread - Post has replies   Root post Cold Start rough for 5s after changing fuel filter 428 15 Jan 23, 2017, 12:32 PM
(k_bo)
Post with replies   Root post 2006 Ford Escape Engine Wont Run 236 3 Jan 18, 2017, 3:22 PM
(Hammer Time)
Post with replies   Root post 47 cj2a 69camero.edelbrock 1400 carb help please! 185 4 Jan 18, 2017, 1:20 PM
(kev2)
Hot thread - Post has replies   Root post 92 c1500 no fuel no spark no start 280 14 Jan 11, 2017, 2:50 PM
(tracymrhd)
Hot thread - Post has replies Root post runs lean after cleaning injectors 429 23 Jan 11, 2017, 1:27 PM
(mikewax)
Post with replies   Root post cooling system 212 3 Jan 10, 2017, 7:03 PM
(Hammer Time)
Hot thread - Post has replies   Root post Rough Idle 2013 Savana 250 6 Jan 10, 2017, 3:29 PM
(rryan)
Post with replies Root post Chocked muffler 191 1 Jan 7, 2017, 9:21 PM
(Hammer Time)
Hot thread - Post has replies   Root post 2008 Mercedes B200 Noise 246 9 Jan 7, 2017, 4:40 PM
(Hammer Time)
Post with replies   Root post jeep liberty 2006 170,00miles 146 2 Jan 5, 2017, 11:03 AM
(nickwarner)
Post with replies   Root post 2002 Ford Mustang GT - Cylinder wont fire 173 2 Jan 3, 2017, 4:20 AM
(Hammer Time)
Post with replies   Root post 2005 Dodge Neon SX 2.0 Engine smell. 164 1 Dec 30, 2016, 12:13 PM
(Tom Greenleaf)
Post with replies   Root post nightmare of leaking injectors 193 4 Dec 28, 2016, 6:21 PM
(mikewax)
Hot thread - Post has replies   Root post 2000 Durango 4.7l 4wd won't start 289 9 Dec 23, 2016, 4:37 PM
(Discretesignals)
Post with replies   Root post Van wouldn't start but when connected to jumper cables it tried to start without KEY in ignition 177 1 Dec 22, 2016, 12:27 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 2003 Mitsubishi Outlander - Very Low MPG 320 10 Dec 19, 2016, 7:22 AM
(Hammer Time)
Hot thread - Post has replies   Root post 99 mercury tracer 2.0L Split Port torque specs 241 6 Dec 15, 2016, 5:33 PM
(Nihel)
Post with replies   Root post 2000 Mercury Truck Mountaineer 4WD 4.0L EFI SOHC 6cyl 162 2 Dec 15, 2016, 2:50 PM
(Hammer Time)
Hot thread - Post has replies   Root post chk engine-low coolant temp after radiator replace 07explorer 269 8 Dec 15, 2016, 10:50 AM
(Discretesignals)
Post with replies   Root post Problem starting truck 231 1 Dec 10, 2016, 11:07 AM
(Hammer Time)
Post with replies   Root post 1993 HONDA DEL SOL 1.5L SOHC 4CYL 131 1 Dec 7, 2016, 7:02 PM
(Hammer Time)
Hot thread - Post has replies   Root post cold start idle 357 11 Dec 6, 2016, 1:48 PM
(chas)
Post with replies Root post spark plug issue 171 2 Dec 3, 2016, 10:33 PM
(nt)
Post with replies   Root post 07 Mazda 3 boost of power without turbo 205 2 Dec 1, 2016, 8:39 AM
(Discretesignals)
Post with replies   Root post Engine Troubleshoot - Please Help! 322 4 Dec 1, 2016, 6:52 AM
(kev2)
Post with replies   Root post LDV Convoy, 2.5 Di, starter motor issues 260 2 Nov 30, 2016, 3:50 AM
(Tom Greenleaf)
Post with replies   Root post crank no start 283 5 Nov 28, 2016, 6:25 PM
(Discretesignals)
Hot thread - Post has replies   Root post Squeaky Auxiliary Drive Belt - Need Some Help Please! (WITH VIDEO) 361 22 Nov 25, 2016, 5:55 AM
(Tom Greenleaf)
Post with replies   Root post 90 chevy astro van 4.3 307000mi 184 1 Nov 23, 2016, 5:10 AM
(Hammer Time)
Hot thread - Post has replies Root post 92 silverado 1500 4.3 123k miles 371 17 Nov 22, 2016, 5:45 PM
(Hammer Time)
Post with replies   Root post mystery car problem 304 2 Nov 22, 2016, 5:33 AM
(Discretesignals)
Post with replies This thread is locked   Root post 2005 Ford Escape timing/ignition issue *with video 294 5 Nov 19, 2016, 12:36 PM
(Discretesignals)
Post with replies   Root post 1979 Ford control boxes help 195 3 Nov 19, 2016, 11:54 AM
(Discretesignals)
Hot thread - Post has replies   Root post Re: 77 Trans Am rough idle and engine pulsation 483 6 Nov 17, 2016, 10:13 AM
(Pureatx)
Post with replies   Root post Hyundai i20 1.4l No Acceleration 190 2 Nov 16, 2016, 6:34 AM
(kev2)
Hot thread - Post has replies   Root post Vw polo classic Engine Temperature Problem 293 5 Nov 14, 2016, 6:16 AM
(Tom Greenleaf)
Post with replies   Root post 1996 F-350 7.5L gas engine won't accelerate. Idles good. No check engine light 200 1 Nov 6, 2016, 12:57 PM
(kev2)
Hot thread - Post has replies   Root post oil capacity - 1981 Toyota Corolla 255 10 Oct 28, 2016, 4:22 PM
(Hammer Time)
Hot thread - Post has replies This thread is locked   Root post 2005 Ford Escape timing/ignition issue *with video 375 21 Oct 28, 2016, 2:29 PM
(Hammer Time)
Post with replies   Root post motor idles up & down up & down 1979 MARK V LINCOLN 214 1 Oct 23, 2016, 10:56 PM
(Tom Greenleaf)
Post with replies   Root post BMW 328i (2000) Where does the throttle cable connect to the throttle body? 174 1 Oct 22, 2016, 2:17 PM
(Discretesignals)
Post with replies   Root post cadillac check engine light won't go out after new vacuum pump 284 4 Oct 21, 2016, 11:59 AM
(kev2)
  First page Previous page 1 2 3 4 5 6 7 8 9 ... 97 Next page Last page


LEGEND
Hot thread = Hot thread
Post with replies = Post with replies
Thread locked = The thread is locked
Root post = First post in thread


FORUM RULES
You cannot start new threads
You cannot post replies
 


Feed Button




Search for (options) Privacy Sitemap

shopify
site analytics