Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN











Search Auto Parts

Engine Troubleshooting


(30798 posts in 5939 threads)
AMSOIL Corporate Website



Sign up here!

  First page Previous page 1 ... 3 4 5 6 7 8 9 10 11 ... 99 Next page Last page
    Subject Views Replies Last Post
Post with replies   Root post VW 2.0 Carburator Engine - Bad cold idle and now vacuum reading 738 4 Apr 15, 2016, 11:57 PM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Toyota Tercel 95 1.3L Carburetor problem 597 5 Apr 15, 2016, 7:55 AM
(Tom Greenleaf)
Post   Root post Engine runs better with vehicle heater on 534 0 Apr 10, 2016, 8:14 AM
Post with replies   Root post Pontiac Bonneville SE 1998 - Intake Manifold Issues 484 2 Apr 7, 2016, 6:58 PM
(Discretesignals)
Hot thread - Post has replies   Root post running rough 06 expedition 886 19 Apr 7, 2016, 6:54 PM
(Discretesignals)
Post with replies   Root post 1996 k1500 engine wont start 585 3 Apr 4, 2016, 2:04 AM
(Hammer Time)
Post with replies   Root post 2001 Honda Civic won't start after Fuel Pump Repair 637 3 Mar 26, 2016, 8:16 AM
(Hammer Time)
Post with replies This thread is locked   Root post pcm? 436 1 Mar 23, 2016, 6:26 PM
(Hammer Time)
Post with replies   Root post 2004 chevy express van 5.3L idle speed 494 1 Mar 20, 2016, 2:12 PM
(kev2)
Post with replies   Root post How do I not cross thread spark plugs? 12058 7 Mar 18, 2016, 4:17 AM
(Discretesignals)
Post with replies   Root post 2002 ford ranger 3.0 misfire 11097 2 Mar 16, 2016, 6:14 PM
(Discretesignals)
Hot thread - Post has replies   Root post 2001 Toyota Celica replaced fuel pump now no start 738 7 Mar 12, 2016, 6:28 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post oil puddle, car cranks but won't turn over 686 5 Mar 10, 2016, 4:09 AM
(mcathie1)
Post with replies   Root post coolant pump leak 456 1 Mar 9, 2016, 7:14 AM
(Tom Greenleaf)
Hot thread - Post has replies Root post Please help! 506 6 Mar 8, 2016, 10:40 AM
(Hammer Time)
Hot thread - Post has replies This thread is locked   Root post Misfire Conundrum... 722 16 Mar 7, 2016, 11:28 PM
(Tom Greenleaf)
Post with replies Root post 1993 Ford Escort Wagon starts to jerk and shudder at 50mph 503 1 Mar 5, 2016, 3:13 PM
(Hammer Time)
Post with replies   Root post Overheating Nissan Turbo 559 2 Mar 3, 2016, 10:40 AM
(Hammer Time)
Post with replies   Root post Electric fans not turning on; odometer not functioning 542 4 Mar 1, 2016, 8:11 PM
(Tom Greenleaf)
Post with replies   Root post 05 Optima stalls, starts back up, no power on acceleration 525 1 Feb 28, 2016, 4:24 PM
(Hammer Time)
Post with replies   Root post 1996 Lancer Engine stutters when accelerating 480 1 Feb 26, 2016, 5:41 AM
(Tom Greenleaf)
Hot thread - Post has replies This thread is locked   Root post ENGINE MISS FIRES 804 7 Feb 26, 2016, 2:58 AM
(Hammer Time)
Post with replies   Root post car has white/gray smoke and high idle 591 4 Feb 23, 2016, 7:50 PM
(taylorh)
Post with replies   Root post 91 F150 engine ignition system failure 931 5 Feb 22, 2016, 7:30 PM
(Discretesignals)
Post with replies   Root post Turbo Diesel Engine Power Surging 537 1 Feb 14, 2016, 10:52 PM
(nickwarner)
Post with replies   Root post 2000 Mazda 626 cranks but wont start 935 6 Feb 13, 2016, 1:09 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Coolant only leaks when driving 612 5 Feb 10, 2016, 1:59 PM
(Hammer Time)
Post with replies   Root post Coolant in my oil - 1996 Cummins C 8.3 - 210 hp 592 1 Feb 9, 2016, 2:50 AM
(nickwarner)
Post with replies   Root post drl 599 2 Feb 7, 2016, 6:10 PM
(eyob07)
Post with replies   Root post 1998 chevy truck won't start 604 1 Feb 7, 2016, 1:15 PM
(Discretesignals)
Post with replies   Root post where are the spark plugs hiding 548 1 Feb 6, 2016, 10:53 PM
(Tom Greenleaf)
Post with replies   Root post SMAX Zetec 2.0 TDCi 2010 Plate - Why will my car struggle to start 1 time in 50 without obvious reason? (see video) 512 1 Feb 4, 2016, 6:26 PM
(Discretesignals)
Post with replies   Root post Is my engine burning too much oil? 577 4 Feb 4, 2016, 10:41 AM
(Hammer Time)
Post with replies   Root post 1998 Chevrolet Suburban LT 431 1 Feb 4, 2016, 10:12 AM
(Hammer Time)
Post with replies   Root post gas coming back out vent hole on oilfiller tube 466 1 Feb 3, 2016, 7:56 AM
(Discretesignals)
Hot thread - Post has replies This thread is locked   Root post 1988 mazda rx7 starter problems 4524 18 Feb 2, 2016, 2:07 PM
(Hammer Time)
Post with replies   Root post Citroen C15 1,9D bad start 562 3 Jan 31, 2016, 12:15 PM
(Tom Greenleaf)
Hot thread - Post has replies This thread is locked   Root post 99 Pontiac Grand Am - won't start 732 9 Jan 31, 2016, 11:29 AM
(Discretesignals)
Post with replies   Root post 2003 VW Passat 614 4 Jan 31, 2016, 8:15 AM
(Discretesignals)
Post with replies   Root post Cylinder not pulling its weight 586 4 Jan 30, 2016, 3:01 PM
(KD5NRH)
Post with replies   Root post Nissan Pathfinder 2003 LE Oil Leak 838 4 Jan 29, 2016, 10:30 AM
(Tom Greenleaf)
Post with replies   Root post Need help with Chrysler Pt Cruiser 08 434 3 Jan 27, 2016, 11:32 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 1999 Toyota Corolla engine dies when accelerator pressed 1455 13 Jan 26, 2016, 4:28 AM
(Discretesignals)
Hot thread - Post has replies   Root post 2002 suzuki 2.7 xl7 4x4, upstream o2 misbehaving 672 8 Jan 25, 2016, 7:26 AM
(kev2)
Post with replies   Root post 1996 Toyota Camry open circuit to fuel pump 603 3 Jan 24, 2016, 11:44 AM
(physix101)
Post with replies   Root post no start when extreme cold 516 3 Jan 19, 2016, 7:25 PM
(Discretesignals)
Hot thread - Post has replies This thread is locked   Root post 2002 Ford Tuurus - starts, then won't start weeks later? 853 16 Jan 17, 2016, 11:42 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 2008 Mariner V6 AWD error code P0446 674 8 Jan 16, 2016, 6:55 AM
(Tom Greenleaf)
Post with replies   Root post no power 718 2 Jan 16, 2016, 5:55 AM
(Discretesignals)
Post with replies   Root post Corsa loses power 470 1 Jan 15, 2016, 12:37 PM
(Tom Greenleaf)
Post with replies   Root post Suzuki Forenza issues 538 1 Jan 14, 2016, 2:41 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Oil Leak on 2000 Chevrolet Metro LSi 1311 19 Jan 10, 2016, 9:02 PM
(Tom Greenleaf)
Hot thread - Post has replies This thread is locked   Root post 1997 Chevy 1500 4.3 V6 won't start, backfires, code p300 925 22 Dec 30, 2015, 12:07 PM
(Hammer Time)
Post with replies   Root post heat comes and stops 474 1 Dec 30, 2015, 9:02 AM
(Discretesignals)
Post with replies   Root post 2004 Volvo s40 sometimes appears to be flooded 676 4 Dec 28, 2015, 9:04 AM
(Discretesignals)
Post with replies   Root post rubber pipe disconnected near front passenger wheel 511 2 Dec 28, 2015, 4:51 AM
(Tom Greenleaf)
Post with replies   Root post Xterra studders when starting then idles up or shuts off 713 4 Dec 26, 2015, 11:22 AM
(kev2)
Post with replies   Root post WHICH ENGINE CAN WORK WITH NISSAN VANETTE BUS 531 1 Dec 25, 2015, 10:04 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 04' Cadilac SRX 3.6 missfire codes p0300 and p0304 help. 767 10 Dec 22, 2015, 1:23 PM
(kev2)
Post with replies This thread is locked   Root post 92 Dakota 3.9 engine noise after throttle release(video) 454 1 Dec 21, 2015, 12:29 PM
(Discretesignals)
  First page Previous page 1 ... 3 4 5 6 7 8 9 10 11 ... 99 Next page Last page


LEGEND
Hot thread = Hot thread
Post with replies = Post with replies
Single post = Single post
Thread locked = The thread is locked
Root post = First post in thread


FORUM RULES
You cannot start new threads
You cannot post replies
 


Feed Button




Search for (options) Privacy Sitemap