Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN







Automotive Wiring and Electrical


(19377 posts in 4415 threads)
AMSOIL Corporate Website



Sign up here!

  First page Previous page 1 2 3 4 5 6 7 8 9 ... 74 Next page Last page
    Subject Views Replies Last Post
Post This thread is locked   Root post FORUM RULES ==== READ BEFORE POSTING 2530 0 Jul 31, 2012, 8:20 PM
Hot thread - Post has replies   Root post 92 Chevy Lumina Z34 113 19 Apr 27, 2015, 9:44 AM
(Hammer Time)
Post with replies   Root post Still have dtc code p0403 after changing parts. 52 3 Apr 24, 2015, 9:03 PM
(Hammer Time)
Post with replies   Root post Ignition Switch or Ignition Lock Cylinder 44 1 Apr 23, 2015, 10:58 PM
(Discretesignals)
Post with replies   Root post Car radio and clock issue hyundai 69 1 Apr 22, 2015, 8:03 PM
(Discretesignals)
Hot thread - Post has replies   Root post 1997 Chevy Truck Rear Turn Signal issues 140 9 Apr 22, 2015, 2:10 PM
(Hammer Time)
Post with replies Root post POWER WINDOWS PROBLEM>>fuse keeps blowing,drivers side wont come up! HELP!!! 58 2 Apr 22, 2015, 1:54 PM
(Discretesignals)
Post with replies   Root post Remote Entry System not Working 52 2 Apr 21, 2015, 8:02 AM
(poochokid)
Post with replies   Root post Can shaft position sensor 53 1 Apr 20, 2015, 8:27 PM
(Discretesignals)
Hot thread - Post has replies   Root post 1996 Mercury Villager GS Blower not working 124 12 Apr 17, 2015, 4:58 PM
(Hammer Time)
Post with replies   Root post 1989 Ford E-150 5.0 EFI cargo. Water temp & oil pressure (only) peg to high side when a/c switch turned on. 66 3 Apr 16, 2015, 6:21 PM
(Tom Greenleaf)
Post with replies   Root post CCFL LIGHT CONFUSION 64 1 Apr 16, 2015, 7:27 AM
(Discretesignals)
Hot thread - Post has replies   Root post 87 Ford f150, right side turn signals dont work while headlights are on. 82 5 Apr 14, 2015, 10:31 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 1998 accord suddenly shuts off 102 9 Apr 12, 2015, 12:29 AM
(Double J)
Post with replies   Root post Possible electrical issue? 74 1 Apr 9, 2015, 3:43 PM
(Tom Greenleaf)
Hot thread - Post has replies This thread is locked Root post '92 Isusu/Rodeo 4x4 3.1LV6: fuel pump fuse blown 156 12 Apr 7, 2015, 7:10 PM
(Hammer Time)
Post with replies   Root post Jeep Tail Light Wiring - Help!!!!! 64 1 Apr 7, 2015, 12:35 PM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 01 Plymouth Neon Cranks but does not start 86 5 Apr 5, 2015, 2:00 PM
(Discretesignals)
Post with replies   Root post Speedometer isn't working and tried everything PLEASE HELP 78 1 Apr 1, 2015, 9:52 PM
(Discretesignals)
Hot thread - Post has replies   Root post Weird battery problem 163 8 Mar 25, 2015, 10:47 PM
(Tom Greenleaf)
Post with replies   Root post adding auxiliary power to a conversion van 113 4 Mar 22, 2015, 2:29 PM
(Tom Greenleaf)
Post with replies   Root post 2003 Ford F250 Super Duty Dome Light/Reverse Light Issue 64 1 Mar 21, 2015, 6:48 PM
(Hammer Time)
Post with replies   Root post car not starting 88 1 Mar 17, 2015, 4:14 PM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 1996 Mercury Villager GS Blower not working 106 9 Mar 15, 2015, 9:28 PM
(Hammer Time)
Post with replies   Root post starters 109 3 Mar 14, 2015, 7:33 PM
(Tom Greenleaf)
Post with replies This thread is locked   Root post Cluster problems-2003 Dodge SX2.0(Neon) 68 1 Mar 13, 2015, 2:43 PM
(Tom Greenleaf)
Post with replies   Root post remove/disconnect car Alarm Toyota Previa 1992 92 1 Mar 12, 2015, 7:29 PM
(Hammer Time)
Post with replies This thread is locked   Root post 2001 ford rangerger 4 litre 4x4 76 1 Mar 10, 2015, 6:11 PM
(Hammer Time)
Hot thread - Post has replies Root post 2001 Town Car, No Crank, No Start... 167 7 Mar 10, 2015, 1:23 AM
(Tom Greenleaf)
Post with replies   Root post 1996 nissan pickup wont start, good battery 87 2 Mar 8, 2015, 4:14 PM
(Tom Greenleaf)
Post with replies   Root post No spark 112 4 Mar 8, 2015, 1:27 PM
(Hammer Time)
Hot thread - Post has replies   Root post 1998 Honda Accord EX driver's lacks power 96 5 Mar 7, 2015, 4:11 PM
(Discretesignals)
Post with replies   Root post Subaru issue 109 3 Mar 1, 2015, 10:19 PM
(Discretesignals)
Post with replies   Root post 2007 Yukon battery/starting issues 94 1 Mar 1, 2015, 1:04 AM
(Tom Greenleaf)
Post with replies   Root post 1999 ford ranger egr wiring 117 2 Feb 26, 2015, 7:32 AM
(Discretesignals)
Hot thread - Post has replies   Root post 2001 ranger no spark 204 24 Feb 23, 2015, 12:05 AM
(Rngrndsfxn)
Post with replies   Root post electrical problems 132 1 Feb 22, 2015, 9:47 PM
(Discretesignals)
Hot thread - Post has replies   Root post 2004 Chrysler Sebring GTC, 2.7l engine - no crank - no start 291 14 Feb 19, 2015, 7:34 AM
(Discretesignals)
Hot thread - Post has replies Root post 2004 Buick Lesabre 3.8 L (Starter & Charging issues)? 214 11 Feb 16, 2015, 4:17 PM
(nickwarner)
Post with replies   Root post 1990 Chevy K2500 Silverado CODE 42 121 1 Feb 14, 2015, 7:35 PM
(Discretesignals)
Post with replies This thread is locked   Root post TAIL LIGHTS DON'T WORK 130 2 Feb 14, 2015, 6:35 PM
(Discretesignals)
Post with replies   Root post TAIL LIGHTS DON'T WORK 138 1 Feb 14, 2015, 12:00 PM
(Discretesignals)
Post with replies   Root post 03 Stratus RT 3.0L (mitsu)- Dies after removing spark plug wire 111 3 Feb 14, 2015, 1:18 AM
(Discretesignals)
Hot thread - Post has replies   Root post '99 dodge 5.9L magnum electric location 221 17 Feb 8, 2015, 5:41 PM
(Discretesignals)
Post with replies   Root post tachometer inquiry 99 2 Feb 8, 2015, 5:41 PM
(Hammer Time)
Post with replies   Root post 2008 Chevy Cobalt Lock Issues 100 1 Feb 8, 2015, 6:26 AM
(Tom Greenleaf)
Post with replies   Root post Chevy S10 tail lights 94 1 Feb 6, 2015, 6:27 PM
(Hammer Time)
Post with replies   Root post Fuel Pump and PCM on 2008 Pontiac Porrent 122 2 Feb 6, 2015, 2:33 PM
(Discretesignals)
Hot thread - Post has replies   Root post 2000 mustang light flicker on and off 353 20 Feb 1, 2015, 3:23 PM
(Tom Greenleaf)
Post with replies   Root post 1996 Camry SV40, does't start just after stopping. 155 3 Jan 31, 2015, 5:49 PM
(Tom Greenleaf)
Post with replies   Root post head light 115 1 Jan 28, 2015, 4:54 PM
(Tom Greenleaf)
Hot thread - Post has replies This thread is locked   Root post Troubleshooting Starter Solenoid - Old School 300 14 Jan 27, 2015, 10:04 AM
(Hammer Time)
Hot thread - Post has replies   Root post 1993 Pontiac Grand Prix -- chronic electrical problems; worth fixing? 312 13 Jan 26, 2015, 7:37 PM
(Tom Greenleaf)
Post with replies   Root post 87 gmc won't hold a charge 125 1 Jan 25, 2015, 6:59 PM
(Tom Greenleaf)
Post with replies   Root post homemade heater blower motor set up 135 3 Jan 20, 2015, 6:35 PM
(Hammer Time)
Post with replies   Root post Battery Issues 172 1 Jan 15, 2015, 1:23 PM
(Tom Greenleaf)
Post with replies   Root post wireing problem 2005 chev cavalier 4 door 231 5 Jan 14, 2015, 7:35 AM
(Discretesignals)
Post with replies   Root post 2012 Journey Elec. Problem 110 1 Jan 13, 2015, 3:22 PM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 90's Chevy Astro - Writer Needs Advice for Fiction Story 146 5 Jan 13, 2015, 7:29 AM
(Discretesignals)
Post Root post 1994 S10 4x4 Blazer - How to connect 4x4 and Cruse Control 141 0 Jan 10, 2015, 9:00 PM
Post with replies This thread is locked   Root post 2002 Chevy Tahoe On Star system. Why did I cut those wires? 125 1 Jan 10, 2015, 5:55 PM
(Hammer Time)
  First page Previous page 1 2 3 4 5 6 7 8 9 ... 74 Next page Last page


LEGEND
Hot thread = Hot thread
Post with replies = Post with replies
Single post = Single post
Thread locked = The thread is locked
Root post = First post in thread


FORUM RULES
You cannot start new threads
You cannot post replies
 






Latest Forum Post

Hi Guys, I have an 85 Trans-Am i just bought, It has a wicked rusty and oily V...


Bought this bike new, has run fine for years but now giving me a starting proble...


Hi my name is Cisco, I have a 92 Chevy Lumina Z34 3.4 motor that wont start. I ...


Hi so my 2006 chevy uplander 102,000 miles trans slips. Not all the time and onl...


My friend has a 1958 Zephyr Mark II car which has a terrible flat spot on accele...


I have a 2009 GMC Acadia. For the third time in the last 18 months and the fourt...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics