Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN







Automotive Wiring and Electrical


(19792 posts in 4490 threads)
AMSOIL Corporate Website



Sign up here!

  First page Previous page 1 2 3 4 5 6 7 8 9 ... 75 Next page Last page
    Subject Views Replies Last Post
Post This thread is locked   Root post FORUM RULES ==== READ BEFORE POSTING 2767 0 Jul 31, 2012, 8:20 PM
Post with replies Root post 2008 E350 no crank 53 4 Aug 28, 2015, 2:00 PM
(mardan)
Post with replies   Root post 2008 Impala noise from AC/Heater 59 2 Aug 27, 2015, 7:57 AM
(2wonder)
Post with replies   Root post 2008 chevrolet avalanche LTZ 143 7 Aug 26, 2015, 6:52 PM
(Hammer Time)
Post with replies   Root post 2015 Ford Fiesta mystery wires 74 3 Aug 23, 2015, 6:15 AM
(Tom Greenleaf)
Post with replies   Root post 99 jeep grand cherokee wont start 184 6 Aug 22, 2015, 6:20 PM
(Discretesignals)
Post with replies   Root post 1-GEAR SHIFT LOCKS (No Gear Indicator Light/No Parking Light Appearing) 50 1 Aug 22, 2015, 4:22 PM
(Tom Greenleaf)
Post with replies   Root post Electrical problems from removing aftermarket gauge 87 3 Aug 21, 2015, 7:44 AM
(Tom Greenleaf)
Post with replies   Root post 1999 GMC Safari Back Hatch Window Won't Open 45 1 Aug 20, 2015, 10:36 AM
(Tom Greenleaf)
Post with replies   Root post 1998 jeep Cherokee injectors won't fire 278 9 Aug 18, 2015, 6:34 PM
(Theprofessional23)
Post with replies   Root post 01 dodge stratus 3.0l coupe issues 79 5 Aug 18, 2015, 8:44 AM
(Tom Greenleaf)
Post with replies Root post 2003 FORD EXPEDITION 4.6l electrical issue, 367 3 Aug 17, 2015, 6:24 PM
(Double J)
Post with replies   Root post 2004 Nissan Sentra--No signal to injector 135 9 Aug 17, 2015, 12:53 PM
(Speedy)
Post with replies   Root post 96 Jeep Cheeroke AC, windshield wipers, and cigarette lighter all went out 42 1 Aug 16, 2015, 5:20 AM
(Tom Greenleaf)
Post with replies   Root post 1995 chevy z71 pick up starter won't engage 82 1 Aug 14, 2015, 2:17 AM
(Tom Greenleaf)
Post with replies   Root post Coolant Temperature Sensor Help! : ). 66 2 Aug 11, 2015, 8:50 PM
(Discretesignals)
Hot thread - Post has replies   Root post 1994 Ford Taurus Electrical Mess 264 10 Aug 10, 2015, 7:39 AM
(Tom Greenleaf)
Post with replies   Root post 91 S10 - Engine Wiring Harness Removal 173 3 Aug 9, 2015, 3:15 AM
(tb01)
Post with replies   Root post fuel injectors fuse 89 1 Aug 7, 2015, 9:56 PM
(Discretesignals)
Hot thread - Post has replies   Root post dash goes haywire 315 22 Aug 5, 2015, 5:55 AM
(Tom Greenleaf)
Post with replies   Root post 2006 Renault laguna dasboard and tail lights out. 60 1 Aug 4, 2015, 7:19 AM
(Tom Greenleaf)
Post with replies   Root post 2001 Ford Windstar won't start. 54 2 Aug 3, 2015, 8:07 PM
(FordGuy297)
Post with replies   Root post Oil sensor not reading oil correctly 66 2 Aug 3, 2015, 1:53 PM
(Discretesignals)
Post with replies   Root post Steering problem 67 1 Aug 2, 2015, 2:11 PM
(Discretesignals)
Hot thread - Post has replies   Root post 05 Scion Xb Tail light 111 9 Aug 2, 2015, 11:54 AM
(Discretesignals)
Post with replies   Root post 2009 Jetta Blower + Lighter not working 70 3 Jul 30, 2015, 11:43 AM
(Hammer Time)
Post with replies   Root post 2000 Chevy Tracker 4 cylinder 250000mi 90 4 Jul 29, 2015, 12:38 PM
(NeverGiveUp)
Post with replies   Root post 1994 Toyota Tercel DX Lights Mod, High Beam Problem 70 1 Jul 27, 2015, 8:27 PM
(Discretesignals)
Post with replies   Root post Unable to locate short in Honda 80 1 Jul 22, 2015, 2:20 PM
(Tom Greenleaf)
Post with replies   Root post Electrical short somewhere? 147 3 Jul 21, 2015, 3:08 AM
(Tom Greenleaf)
Post with replies   Root post Radiator fan won't turn on 105 3 Jul 18, 2015, 7:05 AM
(Tom Greenleaf)
Post with replies   Root post 07 dodge charger shuts off while idling 255 10 Jul 15, 2015, 11:33 AM
(Tom Greenleaf)
Hot thread - Post has replies Root post Dashboard Display Lights Not Working on a 2000 Olds Silhouette 181 11 Jul 15, 2015, 6:22 AM
(Tom Greenleaf)
Post   Root post 09 Routan instrument cluster, acc., Etc. Not working 81 0 Jul 13, 2015, 8:52 PM
Post with replies   Root post my 1990 ford Taurus won't start 110 2 Jul 12, 2015, 2:38 PM
(Discretesignals)
Post with replies   Root post Sable 97 does not start 218 10 Jul 10, 2015, 12:55 PM
(oddgca)
Post with replies   Root post K-9 MUNDIAL-SSX Car Alarm remote stop working 102 1 Jul 8, 2015, 12:09 AM
(Tom Greenleaf)
Post with replies   Root post 1991 Dodge Shadow America ignition woes 134 4 Jul 6, 2015, 9:39 PM
(mooseantlers)
Post with replies   Root post 93 Tracker won't start/no dash lights except briefly sometimes 115 3 Jul 6, 2015, 7:48 AM
(Tom Greenleaf)
Post with replies   Root post 1978 van instrument cluster fuse vs 15 amp breaker fuse 584 5 Jul 4, 2015, 1:15 PM
(Tom Greenleaf)
Post with replies   Root post Help Wiring and install LED Lights in my personal vehicle 119 1 Jul 3, 2015, 3:41 PM
(Tom Greenleaf)
Post with replies   Root post ignition key lost/stolen tiburon 2003 v6 106 1 Jul 2, 2015, 10:49 AM
(Hammer Time)
Hot thread - Post has replies   Root post 2003 ford escape not turning over 150 7 Jul 2, 2015, 9:53 AM
(rick79)
Post with replies   Root post Headlights & Tailights will not work after engine repair 150 2 Jun 30, 2015, 7:35 AM
(Discretesignals)
Post with replies This thread is locked   Root post 06 Buick Rainier - No power to Blower Resistor 126 3 Jun 29, 2015, 7:16 AM
(Discretesignals)
Post with replies   Root post 04 Ford Mustang Turn Signals 144 5 Jun 28, 2015, 7:17 PM
(Hammer Time)
Post with replies   Root post Car is stuck in Acc position and I need to put battery back on 129 2 Jun 24, 2015, 6:22 PM
(Discretesignals)
Hot thread - Post has replies   Root post 2003 Explorer Sporttrac - Electrical/Starting Issue 186 11 Jun 23, 2015, 8:01 PM
(Discretesignals)
Post with replies   Root post Windshield wipers turn on, but will not shut off unless vehicle is turned off. Any Suggestions? 142 3 Jun 22, 2015, 9:00 AM
(Tom Greenleaf)
Post with replies   Root post Electric Windows 120 1 Jun 18, 2015, 4:55 PM
(Tom Greenleaf)
Post with replies   Root post Right Blinker Off - Bulb replaced issue continues 151 3 Jun 18, 2015, 4:57 AM
(Hammer Time)
Post with replies This thread is locked   Root post 1990 BUICK REGAL WONT START NOW 2004 12 Jun 16, 2015, 9:19 PM
(Discretesignals)
Post with replies   Root post vios check engine light foult code po135 135 1 Jun 15, 2015, 6:59 AM
(Discretesignals)
Post with replies This thread is locked   Root post 2000 grand am not charging 143 3 Jun 10, 2015, 9:25 PM
(Discretesignals)
Post with replies   Root post BIKE ELECTRICAL WIRING HELP 145 2 Jun 5, 2015, 10:26 AM
(warezaholic)
Post with replies Root post Tail lights remain on when car is off 146 1 Jun 3, 2015, 5:22 PM
(Tom Greenleaf)
Post with replies   Root post 2002 Isuzu Rodeo will not turnover only headlights and dashlights work 170 3 Jun 2, 2015, 7:50 PM
(Discretesignals)
Post with replies   Root post wiper fault on citroen c2 vtr 116 1 Jun 1, 2015, 8:00 PM
(Discretesignals)
Hot thread - Post has replies   Root post Electric pass door window/lock no longer work after remove driver door 187 7 May 29, 2015, 10:15 PM
(Discretesignals)
Hot thread - Post has replies Root post Right Tail Assembly, Horn and 12v car lighter all stopped working 215 12 May 26, 2015, 10:03 PM
(Discretesignals)
Hot thread - Post has replies   Root post smoking alternator 198 8 May 26, 2015, 9:27 PM
(Hammer Time)
  First page Previous page 1 2 3 4 5 6 7 8 9 ... 75 Next page Last page


LEGEND
Hot thread = Hot thread
Post with replies = Post with replies
Single post = Single post
Thread locked = The thread is locked
Root post = First post in thread


FORUM RULES
You cannot start new threads
You cannot post replies
 






Latest Forum Post

I have an 07 Durango that I recently purchased. It has about 130000 miles and h...


I have a 1991 chevy s-10, 4.3 motor that we can't get gas to spray out of the th...


I was driving the 1998 Volvo S70 at 40 mph. After crossing a railroad track the ...


I recently bought a 2002 dodge ram 1500 5.9 SLT and it run great. Everything in ...


2008 E350SD, 5.4 auto 275K. Engine won't crank, no flashing anti-theft. Bypassed...


Hi guys. I have a peugeot 307 hdi 2.0 90. I was driving home the other day and t...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics