Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN











Search Auto Parts

Engine Troubleshooting


(30930 posts in 5971 threads)
AMSOIL Corporate Website



Sign up here!

  First page Previous page 1 ... 4 5 6 7 8 9 10 11 12 ... 100 Next page Last page
    Subject Views Replies Last Post
Post with replies   Root post drl 672 2 Feb 7, 2016, 6:10 PM
(eyob07)
Post with replies   Root post 1998 chevy truck won't start 665 1 Feb 7, 2016, 1:15 PM
(Discretesignals)
Post with replies   Root post where are the spark plugs hiding 603 1 Feb 6, 2016, 10:53 PM
(Tom Greenleaf)
Post with replies   Root post SMAX Zetec 2.0 TDCi 2010 Plate - Why will my car struggle to start 1 time in 50 without obvious reason? (see video) 565 1 Feb 4, 2016, 6:26 PM
(Discretesignals)
Post with replies   Root post Is my engine burning too much oil? 634 4 Feb 4, 2016, 10:41 AM
(Hammer Time)
Post with replies   Root post 1998 Chevrolet Suburban LT 475 1 Feb 4, 2016, 10:12 AM
(Hammer Time)
Post with replies   Root post gas coming back out vent hole on oilfiller tube 524 1 Feb 3, 2016, 7:56 AM
(Discretesignals)
Hot thread - Post has replies This thread is locked   Root post 1988 mazda rx7 starter problems 4669 18 Feb 2, 2016, 2:07 PM
(Hammer Time)
Post with replies   Root post Citroen C15 1,9D bad start 605 3 Jan 31, 2016, 12:15 PM
(Tom Greenleaf)
Hot thread - Post has replies This thread is locked   Root post 99 Pontiac Grand Am - won't start 817 9 Jan 31, 2016, 11:29 AM
(Discretesignals)
Post with replies   Root post 2003 VW Passat 680 4 Jan 31, 2016, 8:15 AM
(Discretesignals)
Post with replies   Root post Cylinder not pulling its weight 650 4 Jan 30, 2016, 3:01 PM
(KD5NRH)
Post with replies   Root post Nissan Pathfinder 2003 LE Oil Leak 926 4 Jan 29, 2016, 10:30 AM
(Tom Greenleaf)
Post with replies   Root post Need help with Chrysler Pt Cruiser 08 471 3 Jan 27, 2016, 11:32 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 1999 Toyota Corolla engine dies when accelerator pressed 1545 13 Jan 26, 2016, 4:28 AM
(Discretesignals)
Hot thread - Post has replies   Root post 2002 suzuki 2.7 xl7 4x4, upstream o2 misbehaving 727 8 Jan 25, 2016, 7:26 AM
(kev2)
Post with replies   Root post 1996 Toyota Camry open circuit to fuel pump 663 3 Jan 24, 2016, 11:44 AM
(physix101)
Post with replies   Root post no start when extreme cold 552 3 Jan 19, 2016, 7:25 PM
(Discretesignals)
Hot thread - Post has replies This thread is locked   Root post 2002 Ford Tuurus - starts, then won't start weeks later? 922 16 Jan 17, 2016, 11:42 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 2008 Mariner V6 AWD error code P0446 718 8 Jan 16, 2016, 6:55 AM
(Tom Greenleaf)
Post with replies   Root post no power 774 2 Jan 16, 2016, 5:55 AM
(Discretesignals)
Post with replies   Root post Corsa loses power 525 1 Jan 15, 2016, 12:37 PM
(Tom Greenleaf)
Post with replies   Root post Suzuki Forenza issues 583 1 Jan 14, 2016, 2:41 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Oil Leak on 2000 Chevrolet Metro LSi 1404 19 Jan 10, 2016, 9:02 PM
(Tom Greenleaf)
Hot thread - Post has replies This thread is locked   Root post 1997 Chevy 1500 4.3 V6 won't start, backfires, code p300 1018 22 Dec 30, 2015, 12:07 PM
(Hammer Time)
Post with replies   Root post heat comes and stops 521 1 Dec 30, 2015, 9:02 AM
(Discretesignals)
Post with replies   Root post 2004 Volvo s40 sometimes appears to be flooded 748 4 Dec 28, 2015, 9:04 AM
(Discretesignals)
Post with replies   Root post rubber pipe disconnected near front passenger wheel 561 2 Dec 28, 2015, 4:51 AM
(Tom Greenleaf)
Post with replies   Root post Xterra studders when starting then idles up or shuts off 757 4 Dec 26, 2015, 11:22 AM
(kev2)
Post with replies   Root post WHICH ENGINE CAN WORK WITH NISSAN VANETTE BUS 617 1 Dec 25, 2015, 10:04 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 04' Cadilac SRX 3.6 missfire codes p0300 and p0304 help. 835 10 Dec 22, 2015, 1:23 PM
(kev2)
Post with replies This thread is locked   Root post 92 Dakota 3.9 engine noise after throttle release(video) 520 1 Dec 21, 2015, 12:29 PM
(Discretesignals)
Hot thread - Post has replies Root post Broken Crankshaft 923 7 Dec 21, 2015, 8:06 AM
(kev2)
Post with replies   Root post 2008 accord 3.5 engine help 504 1 Dec 20, 2015, 11:51 PM
(whisperer)
Hot thread - Post has replies This thread is locked   Root post 2003 dodge ram 5.7 hemi will start but dies if dont give gas and white smoke out muffler after it dies 1263 21 Dec 19, 2015, 4:21 PM
(Hammer Time)
Hot thread - Post has replies   Root post Lost on this... power loss and misfiring 792 6 Dec 18, 2015, 7:52 PM
(Nodd)
Hot thread - Post has replies   Root post Starting problem 847 9 Dec 18, 2015, 4:28 PM
(Nevino)
Post with replies   Root post 1992 Cadillac Sedan Deville Oxygen Sensors 773 7 Dec 18, 2015, 10:02 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Need help, mopar 901 12 Dec 18, 2015, 5:31 AM
(Discretesignals)
Hot thread - Post has replies   Root post 2000 Honda Accord Dying after start 1041 16 Dec 16, 2015, 4:52 PM
(Hammer Time)
Post with replies   Root post 93 gmc sonoma temp gauge malfunctioning 758 2 Dec 12, 2015, 1:26 PM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 98 mercury sable U engine. Spraying coolant out of engine on driver side. 1108 21 Dec 7, 2015, 3:14 AM
(Hammer Time)
Post with replies This thread is locked   Root post Epc error 1556 reason! 598 1 Dec 4, 2015, 5:38 AM
(Discretesignals)
Hot thread - Post has replies   Root post 05 optima 615 7 Nov 29, 2015, 4:38 PM
(Alan mills)
Hot thread - Post has replies   Root post blower motor 842 11 Nov 28, 2015, 7:47 PM
(eyob07)
Hot thread - Post has replies   Root post 2002 suzuki 2.7 xl7 4x4, stalling when coming to stop 1262 20 Nov 28, 2015, 9:59 AM
(puke)
Hot thread - Post has replies   Root post 2003 Malibu 3.1 hard start. No engine codes. 904 8 Nov 25, 2015, 4:08 PM
(Brandonburton1301)
Hot thread - Post has replies   Root post brake noise 587 6 Nov 24, 2015, 7:07 PM
(eyob07)
Hot thread - Post has replies   Root post 1985 4Runner idles fine but stalls when I touch gas pedal 1055 23 Nov 24, 2015, 4:03 AM
(Tom Greenleaf)
Post with replies   Root post 03 Santa Fe - Engine Revs then RPM goes up and down 533 1 Nov 24, 2015, 2:44 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 2005 Chevy Malibu Maxx chugging 934 13 Nov 21, 2015, 11:55 AM
(BUrrgarys)
Hot thread - Post has replies This thread is locked   Root post crank no start 929 13 Nov 16, 2015, 6:58 PM
(Discretesignals)
Hot thread - Post has replies   Root post oil pump removal 2005 buick rendezvous 3.4 1351 10 Nov 16, 2015, 10:16 AM
(Hammer Time)
Post with replies   Root post ect 624 2 Nov 13, 2015, 12:49 PM
(eyob07)
Hot thread - Post has replies Root post My 1975 Plymouth Duster dies when letting off the gas and slowing down 658 7 Nov 13, 2015, 11:59 AM
(Mz23b)
Post with replies   Root post misfire on cyclinder 2 529 1 Nov 13, 2015, 3:03 AM
(Hammer Time)
Post with replies   Root post cranks too long 1073 9 Nov 10, 2015, 9:39 PM
(Tom Greenleaf)
Post with replies   Root post 2000 Mercury Sable Duratec 3.0L running really rough HELP 719 1 Nov 10, 2015, 6:32 PM
(Discretesignals)
Post with replies   Root post 2005 kia rio help 581 1 Nov 10, 2015, 12:06 AM
(Tom Greenleaf)
Hot thread - Post has replies This thread is locked   Root post 1989 5.0 H/o in a 88 Tbird automatic ! Spark jumping ISSUE ! 728 9 Nov 9, 2015, 11:42 PM
(Tom Greenleaf)
  First page Previous page 1 ... 4 5 6 7 8 9 10 11 12 ... 100 Next page Last page


LEGEND
Hot thread = Hot thread
Post with replies = Post with replies
Thread locked = The thread is locked
Root post = First post in thread


FORUM RULES
You cannot start new threads
You cannot post replies
 


Feed Button




Search for (options) Privacy Sitemap