Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN







Engine and Car Noises


(4865 posts in 1022 threads)
AMSOIL Corporate Website



Sign up here!

  First page Previous page 1 2 3 4 5 6 7 8 9 ... 18 Next page Last page
    Subject Views Replies Last Post
Post This thread is locked   Root post FORUM RULES ==== READ BEFORE POSTING 1125 0 Jul 31, 2012, 8:23 PM
Post with replies   Root post 1995 Feroza Hard knocking sound when accelerating 63 2 Mar 1, 2015, 2:01 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Belt Squeal or Harmonic Balancer noise 80 10 Mar 1, 2015, 1:28 AM
(Tom Greenleaf)
Post with replies   Root post Puzzling wheel noise 63 4 Feb 27, 2015, 3:55 PM
(OldNick)
Post with replies This thread is locked   Root post [2004 Infiniti G35] Changed belts, now they squeak 64 4 Feb 27, 2015, 1:26 PM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 2001 Mazda Tribute Engine Clicking 143 9 Feb 25, 2015, 2:28 PM
(Double J)
Hot thread - Post has replies   Root post Engine noise. Waterpump? 254 17 Feb 22, 2015, 9:16 PM
(Double J)
Post with replies   Root post 2004 Infiniti G35 Noise 93 7 Feb 21, 2015, 12:56 PM
(Discretesignals)
Post with replies Root post 89 s10 with a5.7 350 blowing oil and when I accelerate it falls on its face 95 4 Feb 20, 2015, 1:29 PM
(nickwarner)
Post with replies   Root post 2001 Nissan Xterra won't start/leaks 52 3 Feb 15, 2015, 8:19 PM
(Discretesignals)
Hot thread - Post has replies   Root post Engine noise . What is it? 134 9 Feb 13, 2015, 4:12 AM
(Tom Greenleaf)
Post with replies Root post Honda CRV - oil pump shaken itself apart? 95 5 Feb 12, 2015, 4:31 PM
(Discretesignals)
Post with replies   Root post 2002 Chrycler T+C 3.3L Broken Plastic Hose 62 2 Feb 9, 2015, 12:15 AM
(Tom Greenleaf)
Post with replies   Root post Constant sound in the front after mounting the kerb 59 3 Feb 7, 2015, 9:45 PM
(rolandseq)
Post with replies   Root post roaring and smell problem.. 72 3 Feb 6, 2015, 3:10 PM
(Discretesignals)
Post with replies   Root post 2005 Chevrolet Impala - please help identify this noise 57 1 Feb 4, 2015, 5:52 PM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Squeeling noise and intermittent radio 118 5 Jan 25, 2015, 11:50 AM
(Discretesignals)
Post with replies   Root post Mazda3 Skyactiv 2013 weird metal/scraping noises 91 4 Jan 24, 2015, 12:03 AM
(Tom Greenleaf)
Post with replies Root post Engine noise 95 3 Jan 21, 2015, 4:12 PM
(Hammer Time)
Hot thread - Post has replies   Root post Dodge Neon acts very weird when not moving 127 6 Jan 18, 2015, 3:10 PM
(dodgeNeon)
Hot thread - Post has replies   Root post funny whirling noises 182 6 Jan 2, 2015, 2:55 AM
(Bumkin)
Hot thread - Post has replies   Root post 2000 3.8L Mustang Cold start knocking sound 190 12 Jan 1, 2015, 10:26 AM
(Shane Lowery)
Post with replies   Root post Strange start up whirring.. 76 1 Dec 30, 2014, 8:23 PM
(Hammer Time)
Post with replies Root post Vacuum/Suction Noise 85 1 Dec 24, 2014, 7:02 PM
(Discretesignals)
Hot thread - Post has replies   Root post Please Help 189 10 Dec 16, 2014, 1:20 PM
(Tom Greenleaf)
Post with replies   Root post 2002 toyota 4runner 886 3 Dec 10, 2014, 4:04 PM
(Tom Greenleaf)
Post with replies   Root post Explosion-like sounds while starting the car. What to do? (Nissan Tsuru) 433 4 Nov 30, 2014, 6:08 PM
(Discretesignals)
Hot thread - Post has replies   Root post Loud ticking noise in 2.2 Ecotec 1521 30 Nov 22, 2014, 3:35 PM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Need help with wheel bearing info 189 6 Nov 21, 2014, 11:08 PM
(Discretesignals)
Hot thread - Post has replies   Root post Starting motor/solenoid replacement 231 12 Nov 21, 2014, 12:50 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Serpentine belt problems! 237 6 Nov 20, 2014, 10:47 PM
(Egas)
Hot thread - Post has replies   Root post @004 Mazda 6 making a whining noise 372 8 Nov 18, 2014, 4:51 PM
(Tom Greenleaf)
Post with replies   Root post pontiac grand prix 3.8L ticking knocking noise when cold 306 3 Nov 14, 2014, 7:32 PM
(Discretesignals)
Post with replies   Root post 2007 Dodge Ram 1500 pulsating grinding in gas pedal/steering wheel 197 4 Nov 14, 2014, 5:06 AM
(Tom Greenleaf)
Post with replies Root post what is that noise: hyundai accent 2007 se 210 4 Nov 9, 2014, 2:29 PM
(Hammer Time)
Post with replies   Root post Focus 2002 engine low rumble on idle 277 3 Nov 5, 2014, 6:26 PM
(Discretesignals)
Post with replies This thread is locked   Root post 1996 Subaru Legacy Outback (humming/vrooming noise) 266 1 Oct 26, 2014, 3:21 AM
(Tom Greenleaf)
Post with replies This thread is locked Root post 1987 Chevy Caprice LS brougham Sedan 5.0LV8, ENGINE HESITATION 332 5 Oct 26, 2014, 1:20 AM
(Tom Greenleaf)
Post with replies   Root post 1998 VW Jetta 3 makes clicking noise 210 4 Oct 23, 2014, 6:54 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Car squeaking, not brakes! 442 15 Oct 19, 2014, 1:28 PM
(Tom Greenleaf)
Post with replies   Root post 1999 Honda Civic Issues 259 4 Oct 17, 2014, 12:57 PM
(Tom Greenleaf)
Post with replies   Root post 2008 1.4 auto v.corsa 66k rumbling sound as accelerator initially is pushed, then normal sound after 165 1 Oct 7, 2014, 7:29 AM
(Tom Greenleaf)
Post with replies   Root post Nissan Sunny 2011 clicking noise from engine when hot and at low rpm 226 1 Oct 6, 2014, 1:14 PM
(Tom Greenleaf)
Post with replies   Root post "Clanking" noise in wheel? 254 1 Sep 29, 2014, 6:22 PM
(Hammer Time)
Post with replies   Root post 2008 Chevy Malibu LTZ V6 105k makes noise when turning left 157 1 Sep 20, 2014, 7:57 AM
(Tom Greenleaf)
Post with replies This thread is locked   Root post 2006 Uplander w/heavy clunk in rear passenger 2497 8 Sep 16, 2014, 9:23 PM
(Hammer Time)
Post with replies   Root post NOISE 164 1 Sep 16, 2014, 4:22 PM
(Tom Greenleaf)
Post with replies   Root post 02 chevy trailblazer knocking 211 3 Sep 15, 2014, 9:38 PM
(Hammer Time)
Post with replies   Root post 2010 Toyota Rav4 - Clicking noise from cam cover 1926 2 Sep 4, 2014, 8:19 AM
(Discretesignals)
Hot thread - Post has replies   Root post 99 ford explorer squeaking/chirping sound 426 5 Aug 27, 2014, 6:04 PM
(Discretesignals)
Post with replies   Root post 1990 Buick Park Ave. Electra - Noise coming from somewhere on the belt system? 259 2 Aug 25, 2014, 6:36 PM
(Discretesignals)
Hot thread - Post has replies   Root post 2004 Toyota Corolla making loud noises when stopped 313 5 Aug 25, 2014, 9:16 AM
(GC)
Post with replies   Root post Shuddering/vibrating noise 278 4 Aug 24, 2014, 1:49 PM
(Tom Greenleaf)
Post with replies   Root post 2007 Honda Odyssey EX-L Engine Noise 256 2 Aug 24, 2014, 9:04 AM
(Hammer Time)
Post with replies   Root post Damaged caused by high exhaust backpressure 276 4 Aug 14, 2014, 12:24 AM
(nickwarner)
Hot thread - Post has replies   Root post CAM Sensor Parts Q 483 23 Aug 12, 2014, 11:55 AM
(Tom Greenleaf)
Post Root post BUICK VERANO/EXCELLENCE GT OIL LEAKS IN 10K KM, 2 REPAIRINGs IN 2 MONTHS BUT OIL KEEPs RUNNING 144 0 Aug 11, 2014, 9:47 AM
Post with replies   Root post Squeal in reverse 218 2 Aug 8, 2014, 7:37 AM
(Discretesignals)
Post with replies   Root post 2005 suburban whine/squeak at low speeds (goes away when turning off ac) 380 4 Aug 6, 2014, 9:37 AM
(Hammer Time)
Post with replies   Root post 1999 Pontiac Grand Am GT HO 275 4 Aug 5, 2014, 4:35 PM
(dchris33)
Post with replies   Root post 1996 toyota weird noise 217 1 Aug 1, 2014, 11:42 AM
(Hammer Time)
  First page Previous page 1 2 3 4 5 6 7 8 9 ... 18 Next page Last page


LEGEND
Hot thread = Hot thread
Post with replies = Post with replies
Single post = Single post
Thread locked = The thread is locked
Root post = First post in thread


FORUM RULES
You cannot start new threads
You cannot post replies
 






Latest Forum Post

Hi I have a 1990 Chevy s10 4.3. With 135000 miles. I have a couple issues. First...


 2006 Subaru TriBeCa 107000 Hi. While driving home last night I had an i...


can I put the axels from a 1986 chevy c2500 4wd w a standard transmition on a 19...


2011 GMC Acadia starts on a dime every time EXCEPT when I turn it off to get gas...


1991 GMC K1500 5.7. Engine runs fine til it warms up then when you apply brakes...


Hi guys. this thing was parked inside during zero temps. My prestone tester le...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics