Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN







Transmission Problems


(8932 posts in 2066 threads)
AMSOIL Corporate Website



Sign up here!

  First page Previous page 1 2 3 4 5 6 7 8 9 ... 35 Next page Last page
    Subject Views Replies Last Post
Post This thread is locked   Root post FORUM RULES === READ BEFORE POSTING 1939 0 Jul 31, 2012, 8:19 PM
Post with replies   Root post 07 Altima SE, 3.5, Need Clutch disc or kit? Where can I find? 28 2 Aug 2, 2015, 3:51 PM
(Discretesignals)
Hot thread - Post has replies   Root post 2005 Jeep hard shifting 124 6 Jul 25, 2015, 2:55 AM
(Tom Greenleaf)
Post with replies   Root post Switched to reverse while driving forward 95 4 Jul 24, 2015, 6:25 PM
(gsferraro)
Post with replies   Root post 98 Blazer Won't Shift Gears 82 4 Jul 23, 2015, 9:22 AM
(Tom Greenleaf)
Hot thread - Post has replies This thread is locked   Root post Delayed engagement in 45RFE 162 15 Jul 20, 2015, 9:04 AM
(Hammer Time)
Hot thread - Post has replies   Root post Transmission switches to lower gear on it's own! 587 37 Jul 14, 2015, 8:51 PM
(gsferraro)
Hot thread - Post has replies   Root post Went through 3 throwout bearings in 1 month/ 2003 Dodge Ram 2500 121 11 Jul 14, 2015, 1:35 PM
(Tom Greenleaf)
Post Root post 700r4 transmission swap 53 0 Jul 11, 2015, 12:49 PM
Post with replies   Root post 2000 chevy s10 4wd want shift 130 6 Jul 10, 2015, 2:57 PM
(countryboy4life)
Post with replies   Root post No Foward gears 94 3 Jul 9, 2015, 9:28 PM
(gsferraro)
Post with replies   Root post 4l60e no 2-3 upshift on wot or almost wot 155 7 Jul 9, 2015, 9:08 PM
(gsferraro)
Post with replies Root post 2007 Ram high reving and hard shift down 195 9 Jun 28, 2015, 9:50 PM
(Discretesignals)
Hot thread - Post has replies   Root post 2008 Ford Escape - Automatic 4 Cylinder - Gear Slipping - Gear 2 and 4 Incorrect Ratio - Nearly 200,000 miles. Worth repairing? 113 6 Jun 24, 2015, 6:41 AM
(gsferraro)
Post with replies   Root post 2007 Hyundai Elantra Transmission 141 4 Jun 18, 2015, 10:51 PM
(frankw3)
Hot thread - Post has replies   Root post Saturn TAAT transmission. 143 9 Jun 12, 2015, 10:49 AM
(gsferraro)
Hot thread - Post has replies   Root post '98 tracker difficulty with shifting into gears and grinding noise on occ. when attempting reverse 177 9 Jun 11, 2015, 6:07 PM
(ljparsel)
Hot thread - Post has replies   Root post Need help identifying transmission 127 5 Jun 10, 2015, 11:16 AM
(junkychucky)
Post with replies   Root post hydroluic clutch 88 1 Jun 10, 2015, 7:37 AM
(Discretesignals)
Post with replies   Root post transmission leaking 125 1 Jun 5, 2015, 11:41 AM
(Tom Greenleaf)
Post with replies   Root post 06 Chev Avalanche Torque lock-up not working 199 9 May 28, 2015, 8:54 PM
(gsferraro)
Post with replies This thread is locked   Root post 06 Chev Avalanche Vibration when Accelerating 200,000km 87 1 May 28, 2015, 11:00 AM
(Discretesignals)
Post with replies   Root post shifts so hard into first that it stalls car out? 113 3 May 26, 2015, 6:33 PM
(gsferraro)
Hot thread - Post has replies   Root post 95 JEEP GRAND CHEROKEE REVVING 313 16 May 17, 2015, 9:40 AM
(gsferraro)
Post with replies   Root post What's this broken part in a 1995 Cavalier? 140 1 May 7, 2015, 8:03 PM
(Discretesignals)
Post with replies   Root post Is it bad 196 3 Apr 29, 2015, 12:19 PM
(gsferraro)
Hot thread - Post has replies   Root post 2006 chevy uplander 102,000 miles trans slips 256 13 Apr 28, 2015, 7:38 PM
(petet1234)
Post with replies This thread is locked   Root post Transmission problem 1992 GMC C3500 2213 8 Apr 25, 2015, 1:47 AM
(Double J)
Post with replies   Root post Nissan P0745 250 4 Apr 23, 2015, 7:12 AM
(gsferraro)
Post with replies   Root post 95 Geo Tracker eats clutch cables? 156 3 Apr 22, 2015, 5:23 PM
(Tom Greenleaf)
Post with replies   Root post Auto transmission clunk when downshifting from 4th to 3rd 195 4 Apr 15, 2015, 7:57 AM
(Bilbo007)
Hot thread - Post has replies   Root post Transmission Problem? 1999 Mitsubishi Pajero (Shogun) 167 7 Apr 15, 2015, 7:44 AM
(gsferraro)
Hot thread - Post has replies   Root post Dumping transmission fluid out of vent 271 8 Apr 14, 2015, 11:14 PM
(Panelbeater)
Post with replies   Root post 2000 4l60e hard 1-2 shift even after valve body replacement 142 1 Apr 13, 2015, 7:00 PM
(gsferraro)
Post with replies This thread is locked   Root post Works, with workarounds... 139 1 Apr 12, 2015, 12:39 PM
(Hammer Time)
Post with replies This thread is locked Root post RESOLVED: On a mission to find a trans 332 8 Apr 12, 2015, 3:33 AM
(Tom Greenleaf)
Post with replies   Root post Suzuki swift: gearbox does not work properly 184 4 Apr 6, 2015, 7:39 PM
(Discretesignals)
Hot thread - Post has replies   Root post roaring noise 209 5 Mar 31, 2015, 9:30 PM
(eyob07)
Post with replies   Root post 1990 e4od trans no r 3 2 1 recent rebuid need best way to diagnosis 129 1 Mar 31, 2015, 6:16 PM
(Hammer Time)
Hot thread - Post has replies   Root post Oil is Leaking After CV Axle & Seal replacement 286 11 Mar 22, 2015, 10:11 AM
(spins06)
Hot thread - Post has replies   Root post 2000 Blazer weird shifting issue 310 17 Mar 21, 2015, 12:01 AM
(synnyzter)
Hot thread - Post has replies This thread is locked   Root post neutral safety switch replacement 244 8 Mar 17, 2015, 9:01 PM
(Discretesignals)
Hot thread - Post has replies   Root post Mazda 6 Code PO753 458 13 Mar 17, 2015, 8:34 PM
(gsferraro)
Hot thread - Post has replies   Root post Noticeably hard downshift on automatic transmission 207 5 Mar 17, 2015, 12:06 PM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Transfer Case or Transmission problem??? 520 25 Mar 14, 2015, 8:36 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Manual Transmission problems 265 7 Mar 13, 2015, 12:38 PM
(03RangerEdge)
Hot thread - Post has replies   Root post '99 Tahoe 4L60E trans P1870 code 277 13 Mar 10, 2015, 8:06 PM
(gsferraro)
Post with replies   Root post Trans swap 228 2 Mar 1, 2015, 5:34 PM
(nickwarner)
Hot thread - Post has replies   Root post 2006 nissian pathfinder 268 8 Feb 28, 2015, 2:51 PM
(Tom Greenleaf)
Post with replies   Root post Best way to approach clutch job on a Hyundai Tiburon? 188 2 Feb 28, 2015, 12:50 PM
(Hammer Time)
Post with replies   Root post saturn tranny shifting 306 7 Feb 26, 2015, 8:13 PM
(gsferraro)
Hot thread - Post has replies   Root post 1999 Nissan Altima, 4 cyl, automatic... No D3 222 7 Feb 22, 2015, 11:33 AM
(gsferraro)
Post with replies   Root post 1996 Camry SV40 clutch automatically re-engages. 157 1 Feb 20, 2015, 4:06 PM
(Hammer Time)
Hot thread - Post has replies This thread is locked   Root post 1989 toy P/U 22RE , 5 spd 468 7 Feb 17, 2015, 10:59 AM
(Tom Greenleaf)
Post with replies   Root post 2000 Saturn Sc1 wont reverse. Sensor or transmission? 194 1 Feb 16, 2015, 5:57 AM
(gsferraro)
Hot thread - Post has replies   Root post 02 chevy venture 180,000 267 11 Feb 14, 2015, 7:12 PM
(Discretesignals)
Post with replies Root post Transmission problems in cold 235 4 Feb 13, 2015, 2:44 PM
(gsferraro)
Hot thread - Post has replies   Root post 2006 Lincoln zephyr 338 14 Feb 12, 2015, 6:02 PM
(gsferraro)
Post with replies   Root post Transmission problem Clio 2006 190 2 Feb 11, 2015, 7:24 PM
(Discretesignals)
Hot thread - Post has replies   Root post New clutch and gear box 267 9 Feb 11, 2015, 7:06 PM
(Discretesignals)
Post with replies   Root post 99 olds aurora 4.0 237 2 Feb 10, 2015, 5:30 PM
(gsferraro)
  First page Previous page 1 2 3 4 5 6 7 8 9 ... 35 Next page Last page


LEGEND
Hot thread = Hot thread
Post with replies = Post with replies
Single post = Single post
Thread locked = The thread is locked
Root post = First post in thread


FORUM RULES
You cannot start new threads
You cannot post replies
 






Latest Forum Post

I have a 2007 Altima SE, 3.5. We have looked locally and online for a clutch dis...


2008 chevy uplander, 3.9 engine. One evening we notice air was not blowing cold....


98 Dodge Dakota ext cab. Haven't purchased yet, looking at tomorrow. If frame is...


2000 toyota tundra, 4.7L . Steering is very hard, as if pump is out. Replaced pu...


Hi I have 97 Chevy suburban K 1500 5.7. Didn't notice any pre symptoms before...


Also on the same ford I need to know if anyone knows what will make it run hot ...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics