Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN











Search Auto Parts

Engine Troubleshooting


(31272 posts in 6037 threads)
AMSOIL Corporate Website



Sign up here!

  First page Previous page 1 ... 5 6 7 8 9 10 11 12 13 ... 101 Next page Last page
    Subject Views Replies Last Post
Hot thread - Post has replies This thread is locked   Root post ENGINE MISS FIRES 1156 7 Feb 26, 2016, 2:58 AM
(Hammer Time)
Post with replies   Root post car has white/gray smoke and high idle 769 4 Feb 23, 2016, 7:50 PM
(taylorh)
Post with replies   Root post 91 F150 engine ignition system failure 1173 5 Feb 22, 2016, 7:30 PM
(Discretesignals)
Post with replies   Root post Turbo Diesel Engine Power Surging 818 1 Feb 14, 2016, 10:52 PM
(nickwarner)
Post with replies   Root post 2000 Mazda 626 cranks but wont start 1358 6 Feb 13, 2016, 1:09 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Coolant only leaks when driving 835 5 Feb 10, 2016, 1:59 PM
(Hammer Time)
Post with replies   Root post Coolant in my oil - 1996 Cummins C 8.3 - 210 hp 788 1 Feb 9, 2016, 2:50 AM
(nickwarner)
Post with replies   Root post drl 809 2 Feb 7, 2016, 6:10 PM
(eyob07)
Post with replies   Root post 1998 chevy truck won't start 786 1 Feb 7, 2016, 1:15 PM
(Discretesignals)
Post with replies   Root post where are the spark plugs hiding 706 1 Feb 6, 2016, 10:53 PM
(Tom Greenleaf)
Post with replies   Root post SMAX Zetec 2.0 TDCi 2010 Plate - Why will my car struggle to start 1 time in 50 without obvious reason? (see video) 692 1 Feb 4, 2016, 6:26 PM
(Discretesignals)
Post with replies   Root post Is my engine burning too much oil? 761 4 Feb 4, 2016, 10:41 AM
(Hammer Time)
Post with replies   Root post 1998 Chevrolet Suburban LT 575 1 Feb 4, 2016, 10:12 AM
(Hammer Time)
Post with replies   Root post gas coming back out vent hole on oilfiller tube 645 1 Feb 3, 2016, 7:56 AM
(Discretesignals)
Hot thread - Post has replies This thread is locked   Root post 1988 mazda rx7 starter problems 4911 18 Feb 2, 2016, 2:07 PM
(Hammer Time)
Post with replies   Root post Citroen C15 1,9D bad start 720 3 Jan 31, 2016, 12:15 PM
(Tom Greenleaf)
Hot thread - Post has replies This thread is locked   Root post 99 Pontiac Grand Am - won't start 1035 9 Jan 31, 2016, 11:29 AM
(Discretesignals)
Post with replies   Root post 2003 VW Passat 790 4 Jan 31, 2016, 8:15 AM
(Discretesignals)
Post with replies   Root post Cylinder not pulling its weight 790 4 Jan 30, 2016, 3:01 PM
(KD5NRH)
Post with replies   Root post Nissan Pathfinder 2003 LE Oil Leak 1047 4 Jan 29, 2016, 10:30 AM
(Tom Greenleaf)
Post with replies   Root post Need help with Chrysler Pt Cruiser 08 570 3 Jan 27, 2016, 11:32 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 1999 Toyota Corolla engine dies when accelerator pressed 1699 13 Jan 26, 2016, 4:28 AM
(Discretesignals)
Hot thread - Post has replies   Root post 2002 suzuki 2.7 xl7 4x4, upstream o2 misbehaving 842 8 Jan 25, 2016, 7:26 AM
(kev2)
Post with replies   Root post 1996 Toyota Camry open circuit to fuel pump 819 3 Jan 24, 2016, 11:44 AM
(physix101)
Post with replies   Root post no start when extreme cold 663 3 Jan 19, 2016, 7:25 PM
(Discretesignals)
Hot thread - Post has replies This thread is locked   Root post 2002 Ford Tuurus - starts, then won't start weeks later? 1079 16 Jan 17, 2016, 11:42 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 2008 Mariner V6 AWD error code P0446 834 8 Jan 16, 2016, 6:55 AM
(Tom Greenleaf)
Post with replies   Root post no power 936 2 Jan 16, 2016, 5:55 AM
(Discretesignals)
Post with replies   Root post Corsa loses power 642 1 Jan 15, 2016, 12:37 PM
(Tom Greenleaf)
Post with replies   Root post Suzuki Forenza issues 702 1 Jan 14, 2016, 2:41 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Oil Leak on 2000 Chevrolet Metro LSi 1718 19 Jan 10, 2016, 9:02 PM
(Tom Greenleaf)
Hot thread - Post has replies This thread is locked   Root post 1997 Chevy 1500 4.3 V6 won't start, backfires, code p300 1276 22 Dec 30, 2015, 12:07 PM
(Hammer Time)
Post with replies   Root post heat comes and stops 638 1 Dec 30, 2015, 9:02 AM
(Discretesignals)
Post with replies   Root post 2004 Volvo s40 sometimes appears to be flooded 920 4 Dec 28, 2015, 9:04 AM
(Discretesignals)
Post with replies   Root post rubber pipe disconnected near front passenger wheel 671 2 Dec 28, 2015, 4:51 AM
(Tom Greenleaf)
Post with replies   Root post Xterra studders when starting then idles up or shuts off 879 4 Dec 26, 2015, 11:22 AM
(kev2)
Post with replies   Root post WHICH ENGINE CAN WORK WITH NISSAN VANETTE BUS 741 1 Dec 25, 2015, 10:04 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 04' Cadilac SRX 3.6 missfire codes p0300 and p0304 help. 979 10 Dec 22, 2015, 1:23 PM
(kev2)
Post with replies This thread is locked   Root post 92 Dakota 3.9 engine noise after throttle release(video) 623 1 Dec 21, 2015, 12:29 PM
(Discretesignals)
Hot thread - Post has replies Root post Broken Crankshaft 1061 7 Dec 21, 2015, 8:06 AM
(kev2)
Post with replies   Root post 2008 accord 3.5 engine help 622 1 Dec 20, 2015, 11:51 PM
(whisperer)
Hot thread - Post has replies This thread is locked   Root post 2003 dodge ram 5.7 hemi will start but dies if dont give gas and white smoke out muffler after it dies 1398 21 Dec 19, 2015, 4:21 PM
(Hammer Time)
Hot thread - Post has replies   Root post Lost on this... power loss and misfiring 902 6 Dec 18, 2015, 7:52 PM
(Nodd)
Hot thread - Post has replies   Root post Starting problem 996 9 Dec 18, 2015, 4:28 PM
(Nevino)
Post with replies   Root post 1992 Cadillac Sedan Deville Oxygen Sensors 946 7 Dec 18, 2015, 10:02 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Need help, mopar 1046 12 Dec 18, 2015, 5:31 AM
(Discretesignals)
Hot thread - Post has replies   Root post 2000 Honda Accord Dying after start 1284 16 Dec 16, 2015, 4:52 PM
(Hammer Time)
Post with replies   Root post 93 gmc sonoma temp gauge malfunctioning 914 2 Dec 12, 2015, 1:26 PM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 98 mercury sable U engine. Spraying coolant out of engine on driver side. 1345 21 Dec 7, 2015, 3:14 AM
(Hammer Time)
Post with replies This thread is locked   Root post Epc error 1556 reason! 696 1 Dec 4, 2015, 5:38 AM
(Discretesignals)
Hot thread - Post has replies   Root post 05 optima 732 7 Nov 29, 2015, 4:38 PM
(Alan mills)
Hot thread - Post has replies   Root post blower motor 993 11 Nov 28, 2015, 7:47 PM
(eyob07)
Hot thread - Post has replies   Root post 2002 suzuki 2.7 xl7 4x4, stalling when coming to stop 1541 20 Nov 28, 2015, 9:59 AM
(puke)
Hot thread - Post has replies   Root post 2003 Malibu 3.1 hard start. No engine codes. 1118 8 Nov 25, 2015, 4:08 PM
(Brandonburton1301)
Hot thread - Post has replies   Root post brake noise 669 6 Nov 24, 2015, 7:07 PM
(eyob07)
Hot thread - Post has replies   Root post 1985 4Runner idles fine but stalls when I touch gas pedal 1216 23 Nov 24, 2015, 4:03 AM
(Tom Greenleaf)
Post with replies   Root post 03 Santa Fe - Engine Revs then RPM goes up and down 653 1 Nov 24, 2015, 2:44 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 2005 Chevy Malibu Maxx chugging 1161 13 Nov 21, 2015, 11:55 AM
(BUrrgarys)
Hot thread - Post has replies This thread is locked   Root post crank no start 1064 13 Nov 16, 2015, 6:58 PM
(Discretesignals)
Hot thread - Post has replies   Root post oil pump removal 2005 buick rendezvous 3.4 1786 10 Nov 16, 2015, 10:16 AM
(Hammer Time)
  First page Previous page 1 ... 5 6 7 8 9 10 11 12 13 ... 101 Next page Last page


LEGEND
Hot thread = Hot thread
Post with replies = Post with replies
Thread locked = The thread is locked
Root post = First post in thread


FORUM RULES
You cannot start new threads
You cannot post replies
 


Feed Button




Search for (options) Privacy Sitemap