Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN











Search Auto Parts

Car Stereo Repair Advice


(2096 posts in 652 threads)
AMSOIL Corporate Website



Sign up here!

  First page Previous page 1 2 3 4 5 6 7 8 9 10 11 Next page Last page
    Subject Views Replies Last Post
Post with replies   Root post my radio and rain not good 1351 1 Jan 17, 2010, 7:53 PM
(nickwarner)
Post with replies   Root post Some days the radio works, other days radio is off while speakers pops 1078 1 Jan 15, 2010, 8:41 PM
(Sidom)
Post with replies   Root post stero wont turn on 1545 1 Dec 26, 2009, 2:06 PM
(Sidom)
Post with replies   Root post 1997 toyota previa stereo water damage 1880 1 Dec 25, 2009, 5:01 PM
(Sidom)
Post with replies   Root post My radio hates my Burnt cds 1088 4 Dec 13, 2009, 5:35 PM
(steve01832)
Post with replies   Root post 2006 Gmc Radio 1298 3 Dec 4, 2009, 8:07 PM
(Sidom)
Post with replies   Root post Odd behavior from GM CD Changer 1737 2 Nov 21, 2009, 1:18 PM
(dixie4run)
Post with replies Root post Amp keeps shutting off 1945 5 Nov 20, 2009, 6:43 PM
(Loren Champlain Sr)
Post with replies This thread is locked   Root post Please read so we can help you 3580 1 Nov 14, 2009, 10:39 AM
(Tom Greenleaf)
Post with replies   Root post BMW 316i Stereo Code 2575 3 Nov 10, 2009, 2:49 PM
(Hammer Time)
Post with replies   Root post Radio seems to function but no sound 2179 3 Oct 30, 2009, 6:27 PM
(Loren Champlain Sr)
Post with replies Root post FM donot work 1331 4 Oct 25, 2009, 12:23 PM
(Loren Champlain Sr)
Post with replies   Root post CAR CD PLAYER PROBLEMS!!!! 2282 1 Oct 4, 2009, 9:41 AM
(bruceglaser)
Post with replies   Root post Sound cuts out whilst driving- works fine early in the 2075 1 Oct 2, 2009, 6:53 AM
(thecarkeeper)
Post with replies   Root post Car stereo making ticking sound help plz 5149 5 Sep 13, 2009, 12:34 PM
(wayne28307)
Post with replies   Root post 2006 Kia Rio Radio 4320 3 Sep 5, 2009, 4:44 AM
(clipentertainment)
Post with replies   Root post car antenna 1169 1 Sep 5, 2009, 1:37 AM
(Hammer Time)
Post with replies Root post New ignition in 94 Accord causes stereo to lose power. 1476 4 Sep 4, 2009, 2:07 PM
(Sidom)
Post with replies   Root post Strange problem with wiring new CD Player 1915 1 Aug 31, 2009, 2:18 PM
(Sidom)
Post with replies Root post GM 1355 1 Aug 27, 2009, 9:09 PM
(Hammer Time)
Post Moved   Root post Moved: Weird speedometer thing - - Aug 26, 2009, 7:36 AM
Post   Root post Radio readout not working 1899 0 Aug 26, 2009, 7:31 AM
Post This thread is locked Root post FM Radio 1326 0 Aug 23, 2009, 5:33 AM
Post   Root post 2005 Pontiac G6 cd changer error 3210 0 Aug 22, 2009, 6:52 AM
Post with replies   Root post car radio short 2123 1 Aug 17, 2009, 12:52 PM
(Loren Champlain Sr)
Post with replies   Root post cd player 1520 1 Aug 16, 2009, 10:27 AM
(Guest)
Post This thread is locked Root post Radio will play CD for about 20 seconds and then says error-02 1161 0 Aug 16, 2009, 10:23 AM
Post with replies   Root post 1995 VW jetta gl 1119 1 Aug 16, 2009, 7:17 AM
(Sidom)
Post with replies   Root post tuner knob not working 1007 2 Aug 15, 2009, 12:11 PM
(korben)
Post   Root post 1997 bmw 328i radio swap 1174 0 Aug 12, 2009, 1:10 AM
Post with replies Root post 2003 Silverado AM Radio Noise 1242 1 Aug 12, 2009, 12:11 AM
(Hammer Time)
Post   Root post The radio seems to work; the speakers do not? 1482 0 Aug 11, 2009, 1:01 PM
Post with replies   Root post 1998 Dodge Ram 2500 Speakers go in and out 3926 4 Aug 5, 2009, 9:06 PM
(Hammer Time)
Post with replies   Root post FRONT SPEAKER PROBLEMS 1669 3 Aug 5, 2009, 9:05 PM
(Hammer Time)
Post with replies Root post Car Audio Volume Problem 8991 5 Aug 5, 2009, 1:43 PM
(Loren Champlain Sr)
Post   Root post 1999 BMW Radio Issues 1225 0 Jul 30, 2009, 10:49 AM
Post with replies   Root post cd player 2686 4 Jul 26, 2009, 12:18 PM
(Loren Champlain Sr)
Post with replies   Root post Re: 95 Civic Radio/Tape Deck Problems 2065 1 Jul 25, 2009, 4:10 AM
(Guest)
Post   Root post 2005 Honda Accord Aux Installation 1906 0 Jul 24, 2009, 11:54 PM
Post   Root post blaupunkt max volume issue 1049 0 Jul 17, 2009, 4:57 PM
Post with replies   Root post 2004 T. Corolla, All speakers stopped working at once 2408 1 Jul 14, 2009, 10:06 AM
(Hammer Time)
Post with replies   Root post How do you remove a knob? 1219 1 Jul 13, 2009, 10:33 AM
(Loren Champlain Sr)
Post Moved Root post Moved: 2000 Pontiac Sunfire 5 spd. std.escessive gas use (pollution hoses) - - Jul 9, 2009, 7:34 AM
Post   Root post radio jumps from radio to cd constantly help! 1211 0 Jul 6, 2009, 3:15 PM
Post with replies Root post Ambient Heat Problem 1160 1 Jul 6, 2009, 12:49 PM
(Loren Champlain Sr)
Post with replies   Root post stereo works, but no sound from speakers 6353 4 Jul 5, 2009, 7:25 AM
(Sidom)
Post with replies Root post Can a short within a 2005 Ford Focus radio be reparied? 1248 1 Jul 2, 2009, 1:43 PM
(Hammer Time)
Post   Root post i dont want to burn another stereo... 994 0 Jul 2, 2009, 1:23 AM
Hot thread - Post has replies   Root post 01 Dodge Ram 1500 Stero Wiring Problems... 4425 13 Jun 30, 2009, 11:15 AM
(Hammer Time)
Post with replies   Root post one speaker out 1182 2 Jun 30, 2009, 10:06 AM
(Guest)
Post with replies   Root post need pinout for cd changer din plug on Sanyo FXCD 500 2834 4 Jun 27, 2009, 5:19 PM
(Guest)
Post This thread is locked   Root post Sony Stereo Blown 1582 0 Jun 20, 2009, 6:27 AM
Hot thread - Post has replies   Root post radio wont work after battery died!!! 3115 5 Jun 15, 2009, 2:21 PM
(Hammer Time)
Post with replies   Root post speaker don't work 2644 3 Jun 14, 2009, 1:13 PM
(Sidom)
Post with replies Root post AUX port in 03 Fort Taurus LX 1567 2 Jun 11, 2009, 1:52 AM
(Hammer Time)
Post with replies Root post Stuck CD in 6 Disc changer 11934 5 Jun 10, 2009, 11:06 AM
(Guest)
Post   Root post RADIO TROUBLE 1281 0 Jun 3, 2009, 9:54 AM
Post with replies   Root post replacing door speakers in a 1991 Grand Prix 1395 2 Jun 1, 2009, 4:17 AM
(doc1958)
Post with replies Root post Radio is on but it has no sound 2664 1 May 18, 2009, 5:21 PM
(Loren Champlain Sr)
Post   Root post nissan maxima bose sterio, no sound good display 3013 0 May 13, 2009, 3:19 PM
  First page Previous page 1 2 3 4 5 6 7 8 9 10 11 Next page Last page


LEGEND
Hot thread = Hot thread
Post with replies = Post with replies
Single post = Single post
Post moved = Thread moved
Thread locked = The thread is locked
Root post = First post in thread


FORUM RULES
You cannot start new threads
You cannot post replies
 


Feed Button




Search for (options) Privacy Sitemap