Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

Radio seems to function but no sound


  Email This Post



XENOCIDE
Novice

Oct 28, 2009, 9:23 AM

Post #1 of 4 (2294 views)
Radio seems to function but no sound Sign In

Hi-
I have a 2002 VW GTI with a Monsoon stereo system. Well funny that the system is called a Monsoon because that is what hit our area Saturday. I was driving with the passenger window down and a big splash of water entered through when an opposing car went through a puddle. By big splash I mean like a bucket full of water. It soaked the dash pretty good. My radio seemed to work ok at the time but after about 5 minutes the sound went out. I turned it off and on and then the sound was back but the display was messed up. I turned it off and on again and the sound was gone again and the display was still messed up. I have since left it alone. When I turned it on today the display and all functions seem to work ok but still no sound. Any ideas?


Sidom
Veteran / Moderator
Sidom profile image

Oct 28, 2009, 4:28 PM

Post #2 of 4 (2284 views)
Re: Radio seems to function but no sound Sign In

Getting soaked like that isn't good. As with an electronics that gets wet, what I do is try to dry it out as good as possible before powering up and then see if it still works. It's always a gamble. My daughter dropped a cell phone in Merwin Lake (know the place Loren? Wink), she dove in and got it, let it dry for a day (with the help of a hair dryer) & it worked, after eveyone swore it was toast......


XENOCIDE
Novice

Oct 30, 2009, 4:02 AM

Post #3 of 4 (2279 views)
Re: Radio seems to function but no sound Sign In

using a hair dryer to dry it out seemed like a solid idea. After doing so last night I turned the radio on but no luck. It would power on but still no sound. Then this morning to my surprise it wouldn't power on at all! weird. Is there anyway this could be just a blown fuse issue?


Loren Champlain Sr
Veteran / Moderator
Loren Champlain Sr profile image

Oct 30, 2009, 6:27 PM

Post #4 of 4 (2272 views)
Re: Radio seems to function but no sound Sign In

Ah, yes. Merwin Lake. Nice boating area. For those that don't know, it's on the way to Mt. St. Helens. (the volcano).
Loren
SW Washington






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap