Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN







Car Stereo Repair Advice


(1918 posts in 614 threads)
AMSOIL Corporate Website



Sign up here!

  First page Previous page 1 ... 3 4 5 6 7 8 9 10 11 Next page Last page
    Subject Views Replies Last Post
Post with replies   Root post 88' Silverado 1500 pickup stereo issue 1033 1 Apr 20, 2008, 10:21 PM
(DrElectrics)
Post with replies Root post stereo power backward 680 1 Apr 20, 2008, 6:38 PM
(DrElectrics)
Post   Root post bose mach 460 problems 1202 0 Apr 18, 2008, 7:33 PM
Post with replies   Root post 2004 Sentra, Remove radio CD player?? 10218 3 Apr 17, 2008, 9:19 PM
(Guest)
Post with replies Root post 2004 Izuzu rodeo 809 1 Apr 14, 2008, 8:28 PM
(DrElectrics)
Post with replies Root post Sony Xplod Strereo Problem!!! 1154 1 Apr 14, 2008, 8:26 PM
(DrElectrics)
Post with replies   Root post 98 cad,loud pop thru spks. radio on or off 865 1 Apr 8, 2008, 11:10 AM
(Guest)
Post with replies Root post Pioneer Pre 718 1 Apr 8, 2008, 11:08 AM
(Guest)
Post with replies   Root post speakers quit in 02 cavalier 1141 1 Apr 2, 2008, 10:02 PM
(DrElectrics)
Post with replies Root post 2002 SDI Golf Stereo Problems 704 1 Mar 31, 2008, 9:08 PM
(DrElectrics)
Post with replies   Root post 1993 Chev. Silverado Radio Locked or Broken? 1799 2 Mar 30, 2008, 2:35 PM
(Guest)
Post with replies   Root post JVC ejects cd-radio plays fine 1837 2 Mar 26, 2008, 3:40 PM
(Guest)
Post with replies   Root post Help Requested ~ Left side audio stops working while turning. 842 2 Mar 24, 2008, 7:01 PM
(Double J)
Post with replies   Root post rear speakers in GM cars 962 3 Mar 19, 2008, 12:45 PM
(Guest)
Post with replies   Root post 2002 Chevy Silverado radio gets no reception - help 1299 2 Mar 18, 2008, 1:45 AM
(DrElectrics)
Post with replies   Root post 1993 Cadillac Deville stereo 1374 3 Mar 12, 2008, 6:46 PM
(DrElectrics)
Post with replies Root post help please! CD player doesn't play CDs 1794 1 Mar 9, 2008, 9:55 PM
(DrElectrics)
Post with replies Root post Lincoln Town Car 97 Sterio Subwoofer jarring 1373 1 Mar 9, 2008, 9:53 PM
(DrElectrics)
Post with replies   Root post 2006 kia sorrento radio access 1177 1 Mar 2, 2008, 7:40 PM
(Guest)
Post   Root post 1981 cadillac eldo 468 762 0 Feb 28, 2008, 6:21 PM
Post with replies   Root post Amp and Subs 719 1 Feb 28, 2008, 6:05 PM
(tusseltussel)
Post with replies   Root post After market Stereo w/ no faceplate 893 2 Feb 25, 2008, 6:20 PM
(DrElectrics)
Post Moved Root post Moved: 1996 dodge neon running hot - - Feb 25, 2008, 2:40 PM
Post with replies Root post Jeep Wrangler Stereo Problem 1415 1 Feb 18, 2008, 9:52 PM
(DrElectrics)
Post with replies Root post 94 Jeep Infinity radio problem 1156 3 Feb 13, 2008, 9:29 PM
(DrElectrics)
Post with replies   Root post 98 ford ranger radio died 753 1 Feb 8, 2008, 2:04 PM
(Double J)
Post with replies Root post Stereo up and died NEED HELP 900 1 Feb 4, 2008, 6:11 PM
(DrElectrics)
Post with replies Root post 97 Cavalier Z24 Aftermarket 785 3 Feb 4, 2008, 5:20 PM
(DrElectrics)
Post with replies Root post HELP ASAP! 814 1 Feb 4, 2008, 5:19 PM
(DrElectrics)
Post with replies Root post Cd jumps when ran on street potholes and humps 740 1 Feb 4, 2008, 5:09 PM
(DrElectrics)
Post with replies   Root post STEREOS GONE COMPLETLY DEAD! 1393 2 Jan 31, 2008, 11:33 PM
(DrElectrics)
Post with replies   Root post JVC stero is not working, was previously 5526 5 Jan 31, 2008, 11:29 PM
(DrElectrics)
Post with replies   Root post fix stereo mounts? 687 3 Jan 24, 2008, 11:16 PM
(DrElectrics)
Post with replies   Root post batteries and car radio's 705 1 Jan 23, 2008, 10:32 PM
(DrElectrics)
Post with replies Root post got jacked on ebay 872 2 Jan 23, 2008, 10:30 PM
(DrElectrics)
Post with replies   Root post Tape works, but not CD or any buttons? 763 2 Jan 20, 2008, 7:25 PM
(Guest)
Post with replies   Root post 1998 Accord - CD player 'ERR' message 753 1 Jan 17, 2008, 5:12 PM
(DrElectrics)
Post with replies   Root post JL audio amp repair 3319 1 Jan 16, 2008, 6:01 PM
(DrElectrics)
Post with replies   Root post cassette tape stuck in player - olds 88 (1997) 3005 1 Jan 13, 2008, 6:05 PM
(DrElectrics)
Post with replies Root post fixing cigarette lighter 824 1 Jan 13, 2008, 5:55 PM
(DrElectrics)
Post with replies   Root post stereo wiring 1255 4 Jan 10, 2008, 7:52 PM
(mekanek67)
Post with replies   Root post FM Radio Not Working in Jeep Grand Cherokee 3204 2 Jan 8, 2008, 1:14 PM
(Double J)
Post with replies   Root post radio only works when headlights are on 1861 1 Jan 7, 2008, 6:33 PM
(DrElectrics)
Post with replies   Root post 1996 cavalier fuse box 2447 5 Jan 3, 2008, 5:00 PM
(Tom Greenleaf)
Post with replies Root post Radio Wiring Diagram help 3065 2 Dec 26, 2007, 6:47 PM
(way2old)
Post with replies   Root post New Stereo No Sound 1501 4 Dec 26, 2007, 5:07 PM
(Guest)
Post   Root post jensen cd3010x car stereo stuck in default mode 1023 0 Dec 18, 2007, 9:20 PM
Post   Root post bmw code 770 0 Dec 14, 2007, 12:46 PM
Post with replies   Root post static noise from stereo 1110 1 Dec 13, 2007, 9:13 PM
(Guest)
Post with replies   Root post 2000 f 150 radio wiring harness 1698 1 Dec 10, 2007, 9:08 PM
(DrElectrics)
Post with replies   Root post I need the wiring code for a 1986 ford crown vic radio 868 3 Dec 10, 2007, 1:11 AM
(DrElectrics)
Post with replies   Root post 2005 dodge stereo/cd player shuts off 711 1 Dec 3, 2007, 10:43 PM
(DrElectrics)
Post with replies   Root post 04 Nissan Frontier problems 1025 1 Dec 2, 2007, 5:20 PM
(DrElectrics)
Post with replies Root post 90 maxima with bose stereo problems 807 1 Dec 2, 2007, 5:18 PM
(DrElectrics)
Post with replies   Root post BMW radio code 3270 3 Nov 29, 2007, 4:53 PM
(Guest)
Post with replies   Root post 93 Tpaz: car stereo removal/replacement 1040 2 Nov 26, 2007, 4:48 AM
(DrElectrics)
Post with replies   Root post Stero Upgrade 853 1 Nov 24, 2007, 8:35 PM
(DrElectrics)
Post with replies Root post 98 chevy blazer radio anti theft code 3850 3 Nov 23, 2007, 12:31 AM
(Guest)
Post with replies   Root post car starter 726 1 Nov 18, 2007, 9:45 PM
(DrElectrics)
Post with replies Root post 98 neon 772 1 Nov 14, 2007, 1:32 PM
(ihatemycar)
  First page Previous page 1 ... 3 4 5 6 7 8 9 10 11 Next page Last page


LEGEND
Hot thread = Hot thread
Post with replies = Post with replies
Single post = Single post
Post moved = Thread moved
Root post = First post in thread


FORUM RULES
You cannot start new threads
You cannot post replies
 






Latest Forum Post

Hi. Here is a problem that began in mid-April. On that day, the tranny "clunked"...


09 Toyota Camry. 4 cylinder motor w/ approx. 62000miles. Just got it back yester...


I have a 1978 Lincoln Mark V with the factory ac system (460 engine). All the...


My 07 dodge charger 6 cyl. 2.7 has been acting up, basically ever since i got it...


So I've sort of dug myself into a hole. When I first took ownership of the car I...


Just rebuilt the transmission. All other shifts are good. Sometimes 2-3 shift se...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics