Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN







Car Stereo Repair Advice


(1978 posts in 626 threads)
AMSOIL Corporate Website



Sign up here!

  First page Previous page 1 ... 3 4 5 6 7 8 9 10 11 Next page Last page
    Subject Views Replies Last Post
Post with replies Root post Mazda Radio Removal 1617 1 May 28, 2008, 3:27 PM
(DrElectrics)
Post with replies   Root post faceplate led replacement 1565 1 May 28, 2008, 3:23 PM
(DrElectrics)
Post with replies   Root post car audo help 979 1 May 19, 2008, 3:21 PM
(DrElectrics)
Post with replies Root post 95 Civic Radio/Tape Deck Problems 2365 1 May 15, 2008, 4:56 PM
(DrElectrics)
Post with replies   Root post Unlocking 2000 GM Radio 5400 2 May 15, 2008, 7:50 AM
(Guest)
Post with replies   Root post Car Stereo Problems 1397 3 May 14, 2008, 7:47 PM
(DrElectrics)
Post with replies   Root post 98 Tracer (Escort) Dash Mount/Stereo Help 968 3 May 12, 2008, 8:06 PM
(DrElectrics)
Post with replies Root post XTC 4000WD AMP Play way to low 870 1 May 11, 2008, 8:17 PM
(DrElectrics)
Post with replies   Root post help with stereo lcd repair 1759 1 May 8, 2008, 9:34 PM
(DrElectrics)
Post with replies   Root post speaker grilles 828 1 May 8, 2008, 9:33 PM
(DrElectrics)
Post with replies   Root post Merc Villager 2000, no display 1015 3 May 8, 2008, 9:23 PM
(DrElectrics)
Post with replies   Root post Cd player in car only plays cd for 3 minutes 1086 2 Apr 25, 2008, 5:56 AM
(eledora)
Post with replies   Root post 88' Silverado 1500 pickup stereo issue 1146 1 Apr 20, 2008, 7:21 PM
(DrElectrics)
Post with replies Root post stereo power backward 748 1 Apr 20, 2008, 3:38 PM
(DrElectrics)
Post   Root post bose mach 460 problems 1347 0 Apr 18, 2008, 4:33 PM
Post with replies   Root post 2004 Sentra, Remove radio CD player?? 10540 3 Apr 17, 2008, 6:19 PM
(Guest)
Post with replies Root post 2004 Izuzu rodeo 866 1 Apr 14, 2008, 5:28 PM
(DrElectrics)
Post with replies Root post Sony Xplod Strereo Problem!!! 1229 1 Apr 14, 2008, 5:26 PM
(DrElectrics)
Post with replies   Root post 98 cad,loud pop thru spks. radio on or off 918 1 Apr 8, 2008, 8:10 AM
(Guest)
Post with replies Root post Pioneer Pre 786 1 Apr 8, 2008, 8:08 AM
(Guest)
Post with replies   Root post speakers quit in 02 cavalier 1293 1 Apr 2, 2008, 7:02 PM
(DrElectrics)
Post with replies Root post 2002 SDI Golf Stereo Problems 777 1 Mar 31, 2008, 6:08 PM
(DrElectrics)
Post with replies   Root post 1993 Chev. Silverado Radio Locked or Broken? 1919 2 Mar 30, 2008, 11:35 AM
(Guest)
Post with replies   Root post JVC ejects cd-radio plays fine 2020 2 Mar 26, 2008, 12:40 PM
(Guest)
Post with replies   Root post Help Requested ~ Left side audio stops working while turning. 969 2 Mar 24, 2008, 4:01 PM
(Double J)
Post with replies   Root post rear speakers in GM cars 1150 3 Mar 19, 2008, 9:45 AM
(Guest)
Post with replies   Root post 2002 Chevy Silverado radio gets no reception - help 1432 2 Mar 17, 2008, 10:45 PM
(DrElectrics)
Post with replies   Root post 1993 Cadillac Deville stereo 1502 3 Mar 12, 2008, 3:46 PM
(DrElectrics)
Post with replies Root post help please! CD player doesn't play CDs 1937 1 Mar 9, 2008, 6:55 PM
(DrElectrics)
Post with replies Root post Lincoln Town Car 97 Sterio Subwoofer jarring 1444 1 Mar 9, 2008, 6:53 PM
(DrElectrics)
Post with replies   Root post 2006 kia sorrento radio access 1257 1 Mar 2, 2008, 5:40 PM
(Guest)
Post   Root post 1981 cadillac eldo 468 898 0 Feb 28, 2008, 4:21 PM
Post with replies   Root post Amp and Subs 795 1 Feb 28, 2008, 4:05 PM
(tusseltussel)
Post with replies   Root post After market Stereo w/ no faceplate 941 2 Feb 25, 2008, 4:20 PM
(DrElectrics)
Post Moved Root post Moved: 1996 dodge neon running hot - - Feb 25, 2008, 12:40 PM
Post with replies Root post Jeep Wrangler Stereo Problem 1578 1 Feb 18, 2008, 7:52 PM
(DrElectrics)
Post with replies Root post 94 Jeep Infinity radio problem 1282 3 Feb 13, 2008, 7:29 PM
(DrElectrics)
Post with replies   Root post 98 ford ranger radio died 808 1 Feb 8, 2008, 12:04 PM
(Double J)
Post with replies Root post Stereo up and died NEED HELP 1025 1 Feb 4, 2008, 4:11 PM
(DrElectrics)
Post with replies Root post 97 Cavalier Z24 Aftermarket 854 3 Feb 4, 2008, 3:20 PM
(DrElectrics)
Post with replies Root post HELP ASAP! 889 1 Feb 4, 2008, 3:19 PM
(DrElectrics)
Post with replies Root post Cd jumps when ran on street potholes and humps 792 1 Feb 4, 2008, 3:09 PM
(DrElectrics)
Post with replies   Root post STEREOS GONE COMPLETLY DEAD! 1553 2 Jan 31, 2008, 9:33 PM
(DrElectrics)
Post with replies   Root post JVC stero is not working, was previously 6734 5 Jan 31, 2008, 9:29 PM
(DrElectrics)
Post with replies   Root post fix stereo mounts? 778 3 Jan 24, 2008, 9:16 PM
(DrElectrics)
Post with replies   Root post batteries and car radio's 761 1 Jan 23, 2008, 8:32 PM
(DrElectrics)
Post with replies Root post got jacked on ebay 968 2 Jan 23, 2008, 8:30 PM
(DrElectrics)
Post with replies   Root post Tape works, but not CD or any buttons? 820 2 Jan 20, 2008, 5:25 PM
(Guest)
Post with replies   Root post 1998 Accord - CD player 'ERR' message 816 1 Jan 17, 2008, 3:12 PM
(DrElectrics)
Post with replies   Root post JL audio amp repair 3547 1 Jan 16, 2008, 4:01 PM
(DrElectrics)
Post with replies   Root post cassette tape stuck in player - olds 88 (1997) 3156 1 Jan 13, 2008, 4:05 PM
(DrElectrics)
Post with replies Root post fixing cigarette lighter 882 1 Jan 13, 2008, 3:55 PM
(DrElectrics)
Post with replies   Root post stereo wiring 1364 4 Jan 10, 2008, 5:52 PM
(mekanek67)
Post with replies   Root post FM Radio Not Working in Jeep Grand Cherokee 3543 2 Jan 8, 2008, 11:14 AM
(Double J)
Post with replies   Root post radio only works when headlights are on 2029 1 Jan 7, 2008, 4:33 PM
(DrElectrics)
Post with replies   Root post 1996 cavalier fuse box 2643 5 Jan 3, 2008, 3:00 PM
(Tom Greenleaf)
Post with replies Root post Radio Wiring Diagram help 3155 2 Dec 26, 2007, 4:47 PM
(way2old)
Post with replies   Root post New Stereo No Sound 1641 4 Dec 26, 2007, 3:07 PM
(Guest)
Post   Root post jensen cd3010x car stereo stuck in default mode 1114 0 Dec 18, 2007, 7:20 PM
Post   Root post bmw code 841 0 Dec 14, 2007, 10:46 AM
  First page Previous page 1 ... 3 4 5 6 7 8 9 10 11 Next page Last page


LEGEND
Hot thread = Hot thread
Post with replies = Post with replies
Single post = Single post
Post moved = Thread moved
Root post = First post in thread


FORUM RULES
You cannot start new threads
You cannot post replies
 






Latest Forum Post

2004 Corolla S A deer ran into the side of my wife's corolla last fall so i fin...


2001 Chevrolet Camaro z/28 5.7L. 134k Car will not start. I checked relays a...


there is oil in my spark plug tube will that cause it not to start need to know ...


Hello I have a 1985 Dodge mini ram van 2.6 the idle stop solenoid is bad and a...


About a month ago i replace my entire Ac system in my 93 honda accord, hoses, co...


I don't have any experience when it comes to fixing my car, but there is always ...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics