Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

My 98 S-10 won't start after installing another engine.


First page Previous page 1 2 Next page Last page  View All Email This Post



s10strandman
User

Nov 12, 2017, 6:35 PM

Post #1 of 32 (699 views)
My 98 S-10 won't start after installing another engine. Sign In

I replaced my 98 S-10 engine, which is a 2.2L. It turns over but will not start. It has fuel, after changing fuel pump, it has fuel presure at rail, it has spark at each plugs, and I can use starting fluid and it will run until all gone. It just like there's no power to the fuel injectors. The old engine was running, just had bad head. What else should I check?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Nov 12, 2017, 7:00 PM

Post #2 of 32 (692 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

Test for injector pulse using a small bulb called a noid light. If none found, check for power supply at one side of the injector with the key on.

Does the check engine light come on for bulb check when the key is turned on?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



s10strandman
User

Nov 12, 2017, 9:03 PM

Post #3 of 32 (666 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

No check engine light on at all.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Nov 12, 2017, 9:05 PM

Post #4 of 32 (660 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

I was referring to key on, engine off. Do you have a light then?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Nov 12, 2017, 9:10 PM

Post #5 of 32 (656 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

If the check engine light is not coming on for bulb check, then the PCM is not powering up. You need to test all your fuses using a test light with the key on.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



s10strandman
User

Nov 12, 2017, 9:10 PM

Post #6 of 32 (654 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

I'll get the noid light tomorrow to check injectors....all fuses are good just not proper gound or voltage.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Nov 12, 2017, 9:12 PM

Post #7 of 32 (650 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

Not if your check engine light isn't coming on.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



s10strandman
User

Nov 12, 2017, 9:13 PM

Post #8 of 32 (645 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

Ok, I'll check tomorrow

Thanks


s10strandman
User

Nov 13, 2017, 3:51 PM

Post #9 of 32 (615 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

This can't be right....I have a light on both sides of ECMB.20A with the switch off. With the switch on, motor off I have nothing at all at fuse.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Nov 13, 2017, 3:59 PM

Post #10 of 32 (611 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

Something may be consuming all the power. Make sure you have a good supply/connection coming into the fuse.

Double check all your wiring that all grounds were connected and and all wiring has a solid connection.

Make sure you don't have any pinched wiring anywhere.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



s10strandman
User

Nov 13, 2017, 4:08 PM

Post #11 of 32 (607 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

All injector are lighting up ok after testing.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Nov 13, 2017, 4:31 PM

Post #12 of 32 (547 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

What does that mean?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



s10strandman
User

Nov 13, 2017, 4:50 PM

Post #13 of 32 (543 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

When cranking, the noid light come on


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Nov 13, 2017, 4:53 PM

Post #14 of 32 (541 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

I assume you mean it flashes.

Does your check engine light come on for bulb check now?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



s10strandman
User

Nov 13, 2017, 6:03 PM

Post #15 of 32 (535 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

Yes it flashes. I do get a engine light when cranking.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Nov 13, 2017, 6:05 PM

Post #16 of 32 (527 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

OK, so now it's back to fuel pressure then. What is the fuel pressure?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



s10strandman
User

Nov 13, 2017, 6:06 PM

Post #17 of 32 (523 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

40psi


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Nov 13, 2017, 6:10 PM

Post #18 of 32 (489 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

That's too low, especially if that was measured with the engine off. The spec is 41-47.

What brand pump did you install?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



s10strandman
User

Nov 13, 2017, 6:22 PM

Post #19 of 32 (485 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

AFT,1886-1251


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Nov 13, 2017, 6:24 PM

Post #20 of 32 (481 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

?????????



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



s10strandman
User

Nov 13, 2017, 6:38 PM

Post #21 of 32 (477 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

It's an E3943M


s10strandman
User

Nov 13, 2017, 6:40 PM

Post #22 of 32 (473 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

Link deleted................ not allowed


(This post was edited by Hammer Time on Nov 13, 2017, 6:42 PM)


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Nov 13, 2017, 6:43 PM

Post #23 of 32 (465 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

You probably just need a better pump.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



s10strandman
User

Nov 13, 2017, 6:48 PM

Post #24 of 32 (461 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

So everything so far is good to go, but for the fuel pressure being too low?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Nov 13, 2017, 6:50 PM

Post #25 of 32 (447 views)
Re: My 98 S-10 won't start after installing another engine. Sign In

According to you. You are the one doing the testing.

You say it runs when primed so that only leaves injector problems or fuel pressure.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.







First page Previous page 1 2 Next page Last page  View All Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap