Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN











Search Auto Parts

Transmission Problems


(11281 posts in 2396 threads)
AMSOIL Corporate Website



Sign up here!

  First page Previous page 1 2 3 4 5 6 7 8 9 10 ... 40 Next page Last page
    Subject Views Replies Last Post
Post with replies   Root post Ford focus 2009 gearbox 657 2 Oct 28, 2015, 2:07 PM
(Tom Greenleaf)
Post with replies   Root post 96 dodge van Trans issue 863 4 Oct 27, 2015, 4:58 PM
(Discretesignals)
Post with replies Root post Peugeot Expert Van Transmission issue (gears feel stiff - like stirring honey) 2421 3 Oct 25, 2015, 4:48 AM
(Tom Greenleaf)
Post with replies   Root post Clutch/Gearbox issue - not sure 661 1 Oct 22, 2015, 3:58 AM
(Tom Greenleaf)
Post with replies   Root post Honda Accord 2003 Burnt Clutch.. Replace tran? 591 1 Oct 22, 2015, 3:25 AM
(Tom Greenleaf)
Post with replies   Root post I have 2003 ford Taurus the car goes in gear when it's crank except park but want move when I turn the car off it goes in park n I can push the car n park 640 2 Oct 19, 2015, 3:59 PM
(Hammer Time)
Hot thread - Post has replies   Root post Gear shift problem 1024 9 Oct 19, 2015, 1:38 PM
(Discretesignals)
Post with replies   Root post Gearshitfing backlit problem and vehicle vibration 694 2 Oct 16, 2015, 5:24 PM
(Discretesignals)
Post with replies   Root post 2008 Lancer DE Clutch Replacement 672 2 Oct 15, 2015, 12:48 PM
(kev2)
Post with replies   Root post 1992 Geo Prizm gear selector button won.t let you take it out park 535 3 Oct 15, 2015, 6:51 AM
(Hammer Time)
Hot thread - Post has replies   Root post Trans shuttering (slipping in & out of gear) when coming to a Stop 1093 18 Oct 13, 2015, 12:10 PM
(gsferraro)
Post with replies   Root post 1991 Camry TCC 1135 4 Oct 4, 2015, 11:13 AM
(gsferraro)
Hot thread - Post has replies   Root post 1999 GMC Safari 2WD No Reverse 951 11 Sep 29, 2015, 3:26 AM
(Tom Greenleaf)
Post with replies   Root post Can't Identify TH475 Transmission Part- 1986 Chevy P30 454- Please Help! 848 2 Sep 28, 2015, 6:10 PM
(Discretesignals)
Post with replies   Root post no reverse on a 2003 Nissan frontier 4x4 1323 2 Sep 28, 2015, 3:42 AM
(gsferraro)
Post with replies   Root post Where's the transmission filter? Help please 735 3 Sep 23, 2015, 4:23 PM
(gsferraro)
Post with replies   Root post Broken shift cable, $ 400 dollar replacement?! 766 2 Sep 12, 2015, 12:09 PM
(Discretesignals)
Post with replies   Root post Manual Transmission CLK 200 STUCK in reverse 705 1 Sep 7, 2015, 11:00 AM
(gsferraro)
Post with replies   Root post 07 Durango - From dead stop transmission will not initially engage 860 7 Sep 7, 2015, 10:26 AM
(a1handy)
Hot thread - Post has replies   Root post 4l60E shift problem 1270 21 Sep 4, 2015, 2:30 PM
(kev2)
Post with replies   Root post Im an idiot and dropped bolt in transmission 729 1 Aug 27, 2015, 10:30 PM
(Tom Greenleaf)
Post with replies   Root post 1963 Peugeot 404 won't go into gear 946 3 Aug 27, 2015, 7:07 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 46re transmission output shaft 1280 9 Aug 20, 2015, 8:52 AM
(gsferraro)
Post with replies   Root post 2004 Chevy Silverado desiel losing power 858 4 Aug 17, 2015, 7:37 AM
(briteeyez)
Hot thread - Post has replies   Root post Transmission: No Gears 1163 13 Aug 16, 2015, 11:51 AM
(gsferraro)
Hot thread - Post has replies   Root post 1994 chevy s10 1732 11 Aug 12, 2015, 9:19 AM
(Tom Greenleaf)
Post with replies   Root post Automatic problem 935 4 Aug 10, 2015, 2:50 PM
(gsferraro)
Hot thread - Post has replies   Root post Gear Oil in Automatic Transmission 1105 10 Aug 9, 2015, 6:04 AM
(gsferraro)
Hot thread - Post has replies   Root post Transmission has a 1st gear problem 773 5 Aug 8, 2015, 1:47 PM
(gsferraro)
Hot thread - Post has replies   Root post 1999 Eclipse transmission wont engage 950 6 Aug 8, 2015, 12:45 PM
(gsferraro)
Post with replies   Root post 95 buick park ave. trans prob.? 811 5 Aug 6, 2015, 4:28 AM
(Discretesignals)
Post with replies   Root post 07 Altima SE, 3.5, Need Clutch disc or kit? Where can I find? 764 2 Aug 2, 2015, 12:51 PM
(Discretesignals)
Hot thread - Post has replies   Root post 2005 Jeep hard shifting 1377 6 Jul 24, 2015, 11:55 PM
(Tom Greenleaf)
Post with replies   Root post Switched to reverse while driving forward 762 4 Jul 24, 2015, 3:25 PM
(gsferraro)
Post with replies   Root post 98 Blazer Won't Shift Gears 1083 4 Jul 23, 2015, 6:22 AM
(Tom Greenleaf)
Hot thread - Post has replies This thread is locked   Root post Delayed engagement in 45RFE 1698 15 Jul 20, 2015, 6:04 AM
(Hammer Time)
Hot thread - Post has replies   Root post Transmission switches to lower gear on it's own! 2139 37 Jul 14, 2015, 5:51 PM
(gsferraro)
Hot thread - Post has replies   Root post Went through 3 throwout bearings in 1 month/ 2003 Dodge Ram 2500 995 11 Jul 14, 2015, 10:35 AM
(Tom Greenleaf)
Post Root post 700r4 transmission swap 629 0 Jul 11, 2015, 9:49 AM
Post with replies   Root post 2000 chevy s10 4wd want shift 1633 6 Jul 10, 2015, 11:57 AM
(countryboy4life)
Post with replies   Root post No Foward gears 922 3 Jul 9, 2015, 6:28 PM
(gsferraro)
Post with replies   Root post 4l60e no 2-3 upshift on wot or almost wot 1431 7 Jul 9, 2015, 6:08 PM
(gsferraro)
Post with replies Root post 2007 Ram high reving and hard shift down 854 9 Jun 28, 2015, 6:50 PM
(Discretesignals)
Hot thread - Post has replies   Root post 2008 Ford Escape - Automatic 4 Cylinder - Gear Slipping - Gear 2 and 4 Incorrect Ratio - Nearly 200,000 miles. Worth repairing? 915 6 Jun 24, 2015, 3:41 AM
(gsferraro)
Post with replies   Root post 2007 Hyundai Elantra Transmission 1092 4 Jun 18, 2015, 7:51 PM
(frankw3)
Hot thread - Post has replies   Root post Saturn TAAT transmission. 1493 9 Jun 12, 2015, 7:49 AM
(gsferraro)
Hot thread - Post has replies   Root post '98 tracker difficulty with shifting into gears and grinding noise on occ. when attempting reverse 919 9 Jun 11, 2015, 3:07 PM
(ljparsel)
Hot thread - Post has replies   Root post Need help identifying transmission 865 5 Jun 10, 2015, 8:16 AM
(junkychucky)
Post with replies   Root post hydroluic clutch 577 1 Jun 10, 2015, 4:37 AM
(Discretesignals)
Post with replies   Root post transmission leaking 736 1 Jun 5, 2015, 8:41 AM
(Tom Greenleaf)
Post with replies   Root post 06 Chev Avalanche Torque lock-up not working 1013 9 May 28, 2015, 5:54 PM
(gsferraro)
Post with replies This thread is locked   Root post 06 Chev Avalanche Vibration when Accelerating 200,000km 784 1 May 28, 2015, 8:00 AM
(Discretesignals)
Post with replies   Root post shifts so hard into first that it stalls car out? 742 3 May 26, 2015, 3:33 PM
(gsferraro)
Hot thread - Post has replies   Root post 95 JEEP GRAND CHEROKEE REVVING 1509 16 May 17, 2015, 6:40 AM
(gsferraro)
Post with replies   Root post What's this broken part in a 1995 Cavalier? 700 1 May 7, 2015, 5:03 PM
(Discretesignals)
Post with replies   Root post Is it bad 755 3 Apr 29, 2015, 9:19 AM
(gsferraro)
Hot thread - Post has replies   Root post 2006 chevy uplander 102,000 miles trans slips 1393 13 Apr 28, 2015, 4:38 PM
(petet1234)
Post with replies This thread is locked   Root post Transmission problem 1992 GMC C3500 3229 8 Apr 24, 2015, 10:47 PM
(Double J)
Post with replies   Root post Nissan P0745 1629 4 Apr 23, 2015, 4:12 AM
(gsferraro)
Post with replies   Root post 95 Geo Tracker eats clutch cables? 915 3 Apr 22, 2015, 2:23 PM
(Tom Greenleaf)
  First page Previous page 1 2 3 4 5 6 7 8 9 10 ... 40 Next page Last page


LEGEND
Hot thread = Hot thread
Post with replies = Post with replies
Single post = Single post
Thread locked = The thread is locked
Root post = First post in thread


FORUM RULES
You cannot start new threads
You cannot post replies
 


Feed Button




Search for (options) Privacy Sitemap