Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

Chevy S10 4.3 Transmission slipping


  Email This Post



Secondwind
Novice

Apr 4, 2017, 5:02 PM

Post #1 of 10 (441 views)
  post locked   Chevy S10 4.3 Transmission slipping  

Tranny pan was leaking. Removed pan...very tight quarters. At some point while removing the pan I knocked loose the plastic cover on the bottom of one of two small solenoids at the back of the transmission. Snapped it back in place. Replaced gasket. Reinstalled pan. Refilled tranny. Car now operates with normal torque in Reverse, 1st, 2nd, and 3rd, but slips in Drive. Ideas?? Thanks.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Apr 4, 2017, 5:21 PM

Post #2 of 10 (433 views)
  post locked   Re: Chevy S10 4.3 Transmission slipping  

My guess is that problem is more the result of changing the fluid than the solenoid.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Secondwind
Novice

Apr 4, 2017, 6:27 PM

Post #3 of 10 (418 views)
  post locked   Re: Chevy S10 4.3 Transmission slipping  

What can I do about it?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Apr 4, 2017, 6:29 PM

Post #4 of 10 (416 views)
  post locked   Re: Chevy S10 4.3 Transmission slipping  

If I'm right, nothing short of rebuilding it but wait for Gary the trans specialist to come by and see what he says.

Why were you changing it in the first place.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



(This post was edited by Hammer Time on Apr 4, 2017, 6:30 PM)


Secondwind
Novice

Apr 5, 2017, 4:48 AM

Post #5 of 10 (393 views)
  post locked   Re: Chevy S10 4.3 Transmission slipping  

I replaced the trans pan gasket because of consistent leaking that tightening the bolts wouldn't fix.


kev2
Veteran
kev2 profile image

Apr 5, 2017, 5:37 AM

Post #6 of 10 (383 views)
  post locked   Re: Chevy S10 4.3 Transmission slipping  

Help us help you-
what year is this,
Scan for codes - scan even if light is off. post ALL codes.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Apr 5, 2017, 7:23 AM

Post #7 of 10 (380 views)
  post locked   Re: Chevy S10 4.3 Transmission slipping  

Quote ">I replaced the trans pan gasket because of consistent leaking that tightening the bolts wouldn't fix.<"


NO! A leaking pan gasket is rarely the gasket rather the pans of oil or trans are not true frequently caused by incorrect tightening. You check with a straight edge trans pans in particular as overtightening lifts the areas in between the bolts. Steel ones you can hammer back, alloy ones you toss.


Changing fluid alone can make a problem better or worse and you will not know unless you do it and you did. Don't overtighten gaskets that vary. Some require it soon when new then about nothing ever again some are made to be right just once. Alone not the problem, the low fluid level of leaking is or was the cause first other real problems come from that still unknown to me - just a comment on tightening pan gaskets - don't without knowing that's totally all that's wrong,


T



gsferraro
Enthusiast

Apr 5, 2017, 8:48 AM

Post #8 of 10 (375 views)
  post locked   Re: Chevy S10 4.3 Transmission slipping  

Hello,
Just to confirm, the trans slips on take off in the D4 position. On a side note, it is very tight, very common for the solenoid to snap when taking the pan down.Gary How was it working before?


Secondwind
Novice

Apr 5, 2017, 12:15 PM

Post #9 of 10 (358 views)
  post locked   Re: Chevy S10 4.3 Transmission slipping  

It sure is tight. The transmission was operating normally before the first pan removal. Now, success. Problem fixed. One of the two solenoid coils showed open circuit on ohmmeter. Replaced the solenoid with new. Now, all gears work great. No slippage. Now there is no doubt that I damaged it on the first removal of the pan. Thanks for everyone's comments.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Apr 5, 2017, 1:03 PM

Post #10 of 10 (351 views)
  post locked   Re: Chevy S10 4.3 Transmission slipping  

Glad to hear it.

I will close this now as solved.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap

shopify
site analytics