Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN











Search Auto Parts

Transmission Problems


(11297 posts in 2400 threads)
AMSOIL Corporate Website



Sign up here!

  First page Previous page 1 ... 6 7 8 9 10 11 12 13 14 ... 40 Next page Last page
    Subject Views Replies Last Post
Post with replies   Root post 96 Honda Accord Automatic Transmission Slipping and Not Changing Gears!! 1331 1 Mar 3, 2014, 7:53 PM
(Hammer Time)
Post with replies   Root post if linkage is disconnected, can an automatic trans slip out of gear? 1462 5 Mar 3, 2014, 8:44 AM
(Tom Greenleaf)
Post with replies   Root post 89 Isuzu pickup clutch won't go in gear 938 1 Mar 3, 2014, 7:22 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post '99 monte carlo transmission problems 1314 6 Feb 28, 2014, 12:16 PM
(kev2)
Post with replies   Root post 2001 Acura Mdx Tranny Issues 826 1 Feb 28, 2014, 5:35 AM
(Discretesignals)
Post with replies   Root post 03 chevy silverado guages not working 1242 1 Feb 28, 2014, 5:27 AM
(Discretesignals)
Post with replies This thread is locked   Root post Axle Shaft / half shaft removal 1090 6 Feb 27, 2014, 3:29 AM
(Hammer Time)
Post with replies   Root post 04 Explorer Trans issues IMMEDIATELY after oil change 885 3 Feb 24, 2014, 7:55 AM
(Tom Greenleaf)
Post with replies Root post range transmission sensor 905 3 Feb 23, 2014, 3:34 PM
(Discretesignals)
Post with replies This thread is locked   Root post 2003 Lincoln ls solenoids or electrical ? 816 1 Feb 23, 2014, 2:15 PM
(Hammer Time)
Hot thread - Post has replies   Root post Transmission fluid low 1619 8 Feb 23, 2014, 11:31 AM
(Discretesignals)
Post with replies Root post Clutch or Input Shaft Bearing? 867 3 Feb 19, 2014, 1:20 PM
(Hammer Time)
Hot thread - Post has replies   Root post New Clutch Install Problems! 1251 9 Feb 18, 2014, 6:17 PM
(Hammer Time)
Hot thread - Post has replies   Root post 07 Honda CRV tranny vibrates at idle in gear 999 9 Feb 18, 2014, 2:10 PM
(Hammer Time)
Hot thread - Post has replies   Root post 46RE Shift kit 2303 8 Feb 17, 2014, 7:08 AM
(kev2)
Hot thread - Post has replies   Root post snapped bolt off transmission pan twice 1472 9 Feb 16, 2014, 6:02 AM
(Hammer Time)
Post with replies   Root post 03 toyota rav4 p0770 1759 2 Feb 14, 2014, 11:42 AM
(kensoncustom)
Post with replies This thread is locked   Root post Toyota Avalon wont shift into gear 1301 3 Feb 10, 2014, 2:15 PM
(Tom Greenleaf)
Post   Root post Nissan Juke N-Tec Gear Stick came away 795 0 Feb 10, 2014, 7:03 AM
Post with replies   Root post 2010 Malibu won't shift above 2nd 1774 10 Feb 9, 2014, 2:45 PM
(SuzyPooch)
Post with replies   Root post 2004 Jetta acceleration / Tranny problem? Pls help!! 1115 2 Feb 6, 2014, 10:03 AM
(kev2)
Post with replies   Root post 2004 Mazda 3 2.3L automatic - weird problem with 4rd gear 1075 1 Feb 5, 2014, 7:15 AM
(GC)
Hot thread - Post has replies   Root post 93 mitsubishi eclipse | after tightening down bolts on tranny case gear assembly seizes 1904 21 Feb 4, 2014, 4:28 PM
(juntjoo)
Post with replies   Root post 99 cavalier 2.2L 3 speed won't move 1467 4 Feb 3, 2014, 7:02 PM
(Discretesignals)
Post with replies   Root post Honda auto trans slips. Updated. 1256 3 Feb 1, 2014, 3:34 AM
(Hammer Time)
Post with replies Root post 2001 mazda 626 1451 5 Jan 30, 2014, 5:33 AM
(Discretesignals)
Hot thread - Post has replies This thread is locked   Root post 2002 ford taurus ses 3.0 dohc transmission trouble 1664 9 Jan 29, 2014, 5:15 PM
(Hammer Time)
Hot thread - Post has replies   Root post Jerks in low gear, won't stay in gear. 1581 7 Jan 29, 2014, 5:48 AM
(Discretesignals)
Post with replies   Root post '99 Windstar only reverse 893 1 Jan 26, 2014, 7:36 PM
(GC)
Post with replies   Root post Transmission Hard Shifting :( 1300 3 Jan 23, 2014, 6:24 PM
(Discretesignals)
Post   Root post Toyota A340H Transfer Case External Leak 1075 0 Jan 23, 2014, 12:33 PM
Post with replies This thread is locked   Root post 1981 Wagoneer trans. stops working. 530 1 Jan 23, 2014, 3:36 AM
(Hammer Time)
Post with replies   Root post 1981 Wagoneer trans. stops working. 756 1 Jan 22, 2014, 9:08 PM
(Discretesignals)
Post with replies   Root post 2003 Blazer Acceleration/Reverse issues 1270 5 Jan 22, 2014, 7:47 PM
(Discretesignals)
Post with replies   Root post 1994 explorer transmission problem help me 1188 2 Jan 19, 2014, 8:07 AM
(Discretesignals)
Hot thread - Post has replies   Root post 2001 VOLVO S80 2.9 3377 10 Jan 17, 2014, 8:55 AM
(nickwarner)
Post with replies This thread is locked   Root post Transmission replacement / 97 Honda accord 1485 6 Jan 14, 2014, 5:22 AM
(Discretesignals)
Post with replies   Root post 98 4L60E 946 3 Jan 11, 2014, 12:17 PM
(Discretesignals)
Post with replies   Root post Does this amount sound accurate? 929 4 Jan 10, 2014, 11:04 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 1995 Buick Riviera Supercharged 2161 5 Jan 10, 2014, 8:32 AM
(Tom Greenleaf)
Post with replies   Root post P0733 CODE IN 05 FORD EXPLORER 5381 3 Jan 9, 2014, 1:51 PM
(nickwarner)
Hot thread - Post has replies   Root post 2005/3 Suzuki Swift SE-Z looses power while driving 859 6 Jan 7, 2014, 3:24 AM
(Hammer Time)
Hot thread - Post has replies   Root post Transmission no good? 1267 11 Jan 5, 2014, 7:11 PM
(James77)
Hot thread - Post has replies Root post setting up dodge durango rear differential 2590 14 Jan 4, 2014, 12:46 PM
(kensoncustom)
Post with replies   Root post What should I do? 896 2 Jan 4, 2014, 8:54 AM
(nicky3)
Post with replies   Root post 2005 Tahoe shifting trouble 2085 3 Jan 3, 2014, 9:12 AM
(kev2)
Post with replies   Root post transmission??? 1173 2 Dec 31, 2013, 6:58 AM
(kev2)
Post with replies   Root post 87 Isuzu Pup Transmission- Does not shift 1386 4 Dec 29, 2013, 5:43 PM
(Discretesignals)
Post with replies   Root post 2002 gmc envoy 4x4 auto transmission went out over night 180k 1107 2 Dec 26, 2013, 10:54 AM
(Discretesignals)
Post with replies   Root post 2007 eqiunox 2wd trans slipping 930 4 Dec 23, 2013, 3:41 PM
(kev2)
Hot thread - Post has replies   Root post lable on my differential ,whats it mean 777 5 Dec 23, 2013, 2:12 PM
(Tom Greenleaf)
Post with replies   Root post Explorer transmission problem 1789 4 Dec 21, 2013, 9:00 AM
(Discretesignals)
Post with replies This thread is locked   Root post Prelude transmission problem 840 3 Dec 20, 2013, 5:30 PM
(Discretesignals)
Post with replies   Root post manual trani 616 1 Dec 20, 2013, 4:53 PM
(Discretesignals)
Post with replies   Root post 2003 Chrysler Concord XLI 663 1 Dec 19, 2013, 10:11 AM
(Tom Greenleaf)
Hot thread - Post has replies This thread is locked   Root post 86 GMC suburban C2500 kickback cable location unknown 1065 7 Dec 15, 2013, 8:02 PM
(Tom Greenleaf)
Post with replies   Root post TH 350 vs 400 turbo for my ’78 Chevy C10 Scottsdale 2003 3 Dec 15, 2013, 3:24 PM
(amcco220)
Hot thread - Post has replies This thread is locked   Root post 2001 Dodge Caravan Issue 2077 13 Dec 13, 2013, 2:59 AM
(Tom Greenleaf)
Post with replies   Root post 2012 Ford Escape Sluggish transmission 1252 1 Dec 13, 2013, 2:55 AM
(Tom Greenleaf)
Post with replies   Root post Ford Fiesta style 2005 thrust bearng / gearbox 703 1 Dec 8, 2013, 4:50 AM
(Tom Greenleaf)
  First page Previous page 1 ... 6 7 8 9 10 11 12 13 14 ... 40 Next page Last page


LEGEND
Hot thread = Hot thread
Post with replies = Post with replies
Single post = Single post
Thread locked = The thread is locked
Root post = First post in thread


FORUM RULES
You cannot start new threads
You cannot post replies
 


Feed Button




Search for (options) Privacy Sitemap