Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN











Search Auto Parts

Car Troubleshooting


(60402 posts in 13510 threads)
AMSOIL Corporate Website



Sign up here!

  First page Previous page 1 2 3 4 5 6 7 8 9 10 ... 226 Next page Last page
    Subject Views Replies Last Post
Post with replies   Root post Weird stuttering during idle and acceleration - Nissan Xterra 2004 560 2 Jun 28, 2017, 8:24 AM
(Discretesignals)
Post with replies   Root post 2010 Hyundai Sonata, Occasional chirping noise/burning smell. 539 1 Jun 28, 2017, 8:20 AM
(Discretesignals)
Post with replies Root post Car Electronics Trouble (1996 Nissan Pulsar) 397 1 Jun 27, 2017, 5:22 AM
(Hammer Time)
Post with replies Root post 1984 Mazda 323 Familia 1.5 Jolting Profusely While Driving <60km/ph 500 2 Jun 25, 2017, 6:02 PM
(Driftkiwi)
Post with replies   Root post 1999 toyota solara engine died while driving. HELP!! 606 4 Jun 23, 2017, 6:08 AM
(Hammer Time)
Hot thread - Post has replies   Root post Chrysler T&C Intermittent Starting Problems 631 10 Jun 22, 2017, 8:12 PM
(Hammer Time)
Hot thread - Post has replies   Root post '03 Chevy TrailBlazer Runs Rough 631 6 Jun 22, 2017, 7:07 PM
(Discretesignals)
Post with replies   Root post terios daihatsu 543 6 Jun 22, 2017, 6:42 AM
(aryeedem)
Hot thread - Post has replies   Root post Mini Car Keys 1015 6 Jun 22, 2017, 12:58 AM
(aryeedem)
Hot thread - Post has replies This thread is locked   Root post Minivan cranks over/wont start 726 8 Jun 20, 2017, 5:07 PM
(Hammer Time)
Post with replies   Root post More vss questions 627 3 Jun 20, 2017, 7:53 AM
(Hammer Time)
Hot thread - Post has replies This thread is locked   Root post Hot lug nuts, no always, caliper or bearing? 648 10 Jun 19, 2017, 1:23 PM
(Hammer Time)
Hot thread - Post has replies This thread is locked   Root post 2002 Pontiac Aztec no injector pulse 1423 29 Jun 17, 2017, 3:39 PM
(Hammer Time)
Post with replies   Root post over heating 499 4 Jun 15, 2017, 3:48 PM
(Hammer Time)
Hot thread - Post has replies   Root post Not getting gas on take off 566 6 Jun 15, 2017, 11:57 AM
(Sidom)
Hot thread - Post has replies   Root post Coolant gauge needle starts on hot side upon start 565 10 Jun 14, 2017, 3:13 PM
(joezapp)
Post with replies   Root post Car loses all electrical power, then suddenly comes back after a few minutes 589 3 Jun 12, 2017, 4:34 PM
(Hammer Time)
Post with replies   Root post Splash shield trouble 439 2 Jun 12, 2017, 1:06 PM
(Sidom)
Hot thread - Post has replies This thread is locked   Root post Reduced Engine Power - Saturn Vue 2006 Stumped 6886 12 Jun 8, 2017, 12:08 PM
(Tom Greenleaf)
Post with replies Root post Need help figuring this out 496 4 Jun 7, 2017, 11:24 AM
(Discretesignals)
Post with replies   Root post 2005 BMW X3 vibrating/shaking when idle 649 1 Jun 5, 2017, 8:11 PM
(Hammer Time)
Post with replies   Root post 1997 GMC Sierra 1500- Dash Insturment Cluster 541 3 Jun 3, 2017, 10:19 AM
(Hammer Time)
Hot thread - Post has replies   Root post 1993 Ford Explorer Sputter 774 16 Jun 1, 2017, 11:13 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Vss question 560 6 May 31, 2017, 3:27 PM
(Loren Champlain Sr)
Hot thread - Post has replies   Root post 2002 honda accord wont start/hesitant 765 10 May 31, 2017, 3:17 PM
(Loren Champlain Sr)
Hot thread - Post has replies This thread is locked   Root post Car is not working after reverse polarity cable jump start 617 5 May 28, 2017, 4:42 PM
(Hammer Time)
Post with replies   Root post 2012 Chevy Impala Power Seat Issue 517 2 May 28, 2017, 10:15 AM
(Tom Greenleaf)
Post with replies   Root post 2003 Durango-stumped 463 1 May 28, 2017, 8:07 AM
(Hammer Time)
Post with replies   Root post need help - blown head gasket 472 3 May 24, 2017, 7:51 PM
(Hammer Time)
Post with replies   Root post Part Identification help 411 1 May 24, 2017, 7:18 PM
(Hammer Time)
Hot thread - Post has replies   Root post Kia forte drivetrain rattle but where exactly? 627 7 May 24, 2017, 1:40 PM
(Tom Greenleaf)
Hot thread - Post has replies This thread is locked   Root post overheating 2003 Explorer 4.6 L 230000 556 8 May 23, 2017, 3:53 PM
(Hammer Time)
Hot thread - Single post   Root post '99 Mercury Grand Marquis Won't Start (Or Even Jumpstart)! 681 0 May 21, 2017, 8:15 PM
Post with replies This thread is locked   Root post 1994 Acura Legend shuts off at idle. 506 3 May 21, 2017, 5:29 PM
(Hammer Time)
Post with replies   Root post Ford Granada Mk1 will not start 398 1 May 20, 2017, 2:27 PM
(Hammer Time)
Post with replies   Root post cabin filter 445 4 May 20, 2017, 9:56 AM
(dennishazard)
Hot thread - Post has replies   Root post removing oil stains from concrete 615 10 May 19, 2017, 7:55 AM
(AGC)
Post with replies   Root post 2010 Mazda3 weird issues, mechanic says car was fine.... 416 1 May 18, 2017, 7:58 PM
(Hammer Time)
Hot thread - Post has replies This thread is locked   Root post oil or petroleum stains on ground 675 15 May 17, 2017, 11:25 AM
(Hammer Time)
Post with replies   Root post 2009 chevy traverse oil pressure monitor system 541 2 May 16, 2017, 6:59 AM
(ragedrummer82)
Post with replies   Root post Low beam and high beam not working, nor high beam dash indicator 483 1 May 16, 2017, 12:03 AM
(Tom Greenleaf)
Post with replies   Root post Honda whirring sound 484 2 May 15, 2017, 1:28 PM
(Discretesignals)
Post with replies   Root post 93 E350 won't start after radiator hose repair 398 1 May 12, 2017, 5:27 PM
(Hammer Time)
Hot thread - Post has replies   Root post I can't get my check engine light to stay off, showing lean bank 1&2 code... 791 23 May 12, 2017, 5:00 PM
(Hammer Time)
Hot thread - Post has replies   Root post overheating 616 11 May 12, 2017, 12:00 PM
(Hammer Time)
Hot thread - Post has replies   Root post 2007 HHR WONT START AFTER BATTERY DISCONNECTED WHILE DRIVING 559 6 May 11, 2017, 12:43 PM
(Tom Greenleaf)
Post with replies   Root post Ripped tire bead; who to charge? 593 3 May 11, 2017, 9:43 AM
(Discretesignals)
Post with replies   Root post Camshaft sensor 510 2 May 10, 2017, 2:00 PM
(imaginemylife)
Hot thread - Post has replies   Root post Battery drain 09 Altima 632 7 May 9, 2017, 1:36 PM
(Hammer Time)
Post with replies Root post Car won't start 530 1 May 9, 2017, 2:35 AM
(Tom Greenleaf)
Post with replies   Root post Screeching noise when turning right 494 1 May 9, 2017, 2:23 AM
(Tom Greenleaf)
Post with replies   Root post 1997 Camry - Heats too fast, and slight misfires. 516 2 May 8, 2017, 6:34 PM
(MagicEight)
Post with replies   Root post Bad PCM? 485 2 May 8, 2017, 10:12 AM
(jundtman)
Post with replies   Root post Runs fine but dies whwn moving 581 4 May 8, 2017, 9:44 AM
(Discretesignals)
Post with replies   Root post Car seems to be hunting for fuel and revs slightly while idle. 433 1 May 7, 2017, 8:01 AM
(Tom Greenleaf)
Post with replies   Root post Cv boot 506 1 May 7, 2017, 2:10 AM
(Hammer Time)
Post with replies   Root post no oil in oil fillter 501 1 May 6, 2017, 6:24 PM
(Hammer Time)
Post with replies   Root post Chevy cobalt computer problem 761 1 May 6, 2017, 4:21 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Oil leak on 2010 Subaru Outback 2.0 premium 761 5 May 5, 2017, 8:29 PM
(OURDOGS)
Post with replies   Root post ignition 413 1 May 5, 2017, 3:45 PM
(Hammer Time)
  First page Previous page 1 2 3 4 5 6 7 8 9 10 ... 226 Next page Last page


LEGEND
Hot thread = Hot thread
Post with replies = Post with replies
Single post = Single post
Thread locked = The thread is locked
Root post = First post in thread


FORUM RULES
You cannot start new threads
You cannot post replies
 


Feed Button




Search for (options) Privacy Sitemap