Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN











Search Auto Parts

Truck Engine Repair


(859 posts in 149 threads)
AMSOIL Corporate Website



Sign up here!

  First page Previous page 1 2 3 Next page Last page
    Subject Views Replies Last Post
Hot thread - Post has replies   Root post 81 ford 4.9 6 valve problems 2952 17 Aug 20, 2012, 3:01 PM
(heinz57)
Post with replies   Root post 1985 vacum break queston 1247 1 Aug 12, 2012, 11:28 AM
(Tom Greenleaf)
Post with replies   Root post 1970 GM 350 engine with ignition problems, I think?? 4162 8 Jul 15, 2012, 12:35 AM
(rsrandle)
Hot thread - Post has replies   Root post 91 chevy k1500 5.7 tbi stalling 3126 6 Jul 2, 2012, 5:42 PM
(oddball)
Post with replies   Root post Replaced engine, but no spark???? 98 Jimmy 1414 4 Jun 28, 2012, 3:23 AM
(Hammer Time)
Post with replies   Root post head gasket 1999 ford ranger 3043 1 Jun 9, 2012, 7:43 PM
(Hammer Time)
Post with replies   Root post 1997 Chevy silverado 1500, loud engine screech at ignition? 2220 2 Jun 1, 2012, 7:08 PM
(Double J)
Post with replies   Root post 1989 mazda b2600i 2.6 4 cyl loss of performence throttle hesitation 2912 6 May 22, 2012, 2:48 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 1997 GMC Sierra 1500 won't start after overheating 4731 9 May 18, 2012, 6:44 AM
(Tom Greenleaf)
Post with replies   Root post truck turns over will not run 1140 1 May 8, 2012, 7:20 AM
(Hammer Time)
Post with replies   Root post Fuel Injection Problem 1347 1 Apr 26, 2012, 4:19 PM
(Discretesignals)
Hot thread - Post has replies   Root post 98 chevy k1500 5.0 will not start 9561 10 Apr 19, 2012, 11:39 AM
(MattMan)
Hot thread - Post has replies   Root post Chevy 1998 1500 1918 12 Apr 5, 2012, 8:33 AM
(Davecolo)
Post with replies   Root post Slow run down to idle 2.8 '93 s-10 1429 4 Mar 4, 2012, 8:39 PM
(litewerx)
Post with replies   Root post 98 Chevrolet S-10 Will Not Start 1171 1 Feb 17, 2012, 12:21 PM
(Hammer Time)
Post with replies Root post ford f150 4.6 V8 2006 problems 2903 1 Feb 10, 2012, 8:27 PM
(Tom Greenleaf)
Post with replies Root post f150 just does nothing. won't start 1617 1 Feb 2, 2012, 4:18 AM
(Hammer Time)
Hot thread - Post has replies   Root post 2006 Ford F150 4122 28 Dec 8, 2011, 4:23 AM
(Hammer Time)
Hot thread - Post has replies   Root post toyota wont stay runnlng 1549 6 Dec 5, 2011, 7:45 AM
(Hammer Time)
Post with replies   Root post 2006 Dodge Ram 1500 poor gas mileage, shifts poorly 2640 1 Nov 15, 2011, 12:07 AM
(Tom Greenleaf)
Post with replies   Root post 1995 gmc sierra stumbles when accelerating 5491 11 Nov 10, 2011, 1:14 PM
(Tom Greenleaf)
Hot thread - Post has replies   Root post flexplate tooth missing 2475 5 Oct 23, 2011, 7:22 PM
(Discretesignals)
Post with replies   Root post vacuum hose routing 4885 3 Oct 21, 2011, 5:09 PM
(woitw)
Post with replies Root post 94 chev s10 fullbore idle bad throttle? 2439 1 Oct 8, 2011, 4:05 PM
(Discretesignals)
Post   Root post I have an 88 s 10 with the 2.8 mulitport fuel injected v6 runs fine until the motor gets to regular temps , 1266 0 Oct 2, 2011, 9:53 AM
Post with replies   Root post 93 sierra engine swap trouble 1709 3 Sep 30, 2011, 4:35 AM
(Hammer Time)
Post with replies Root post Post deleted by brokenwrench163 2200 5 Sep 30, 2011, 4:34 AM
(Hammer Time)
Post with replies   Root post 2003 chevy silverado 1/2 ton 4x4 not sure of the engine size, I think it is the smaller one they made at that time. 1790 1 Sep 26, 2011, 7:07 PM
(Hammer Time)
Post with replies   Root post vacuum lines 1409 2 Sep 3, 2011, 6:53 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 90 GMC 1500 poor start misses out 1825 14 Aug 18, 2011, 4:48 AM
(Tom Greenleaf)
Post with replies   Root post 94' GMC TBI only cranks after rebuild, sputters but no start 2350 1 Aug 14, 2011, 7:05 PM
(Discretesignals)
Post with replies   Root post Chevy S-10 Engine Looping 1551 1 Jun 9, 2011, 10:51 AM
(Mr.scotty)
Post with replies   Root post 2005 1500 Dodge 4.7 ASD No Ground Signal 2601 3 May 23, 2011, 6:45 PM
(speed)
Post with replies   Root post 1996 Chevrolet Sierra 1500 Pickup Fires - Won't Start 2955 2 Mar 15, 2011, 3:57 AM
(Tom Greenleaf)
Post with replies   Root post 1999 ford f250 7.3l 2333 1 Feb 25, 2011, 3:55 PM
(zmame)
Post with replies   Root post Van won't stay running 2587 2 Feb 12, 2011, 6:08 PM
(Tom Greenleaf)
Post with replies   Root post 91 f150 power loss 2403 2 Jan 21, 2011, 12:43 AM
(melkinny360)
Hot thread - Post has replies Root post 1994 GMC SIERRA wont start 5429 12 Jan 20, 2011, 7:24 PM
(Hammer Time)
Post with replies This thread is locked   Root post 454 with cracked exhaust manifolds 2451 4 Jan 12, 2011, 12:20 PM
(Hammer Time)
Post   Root post tach 1157 0 Jan 11, 2011, 9:13 PM
Post with replies Root post put new plugs and wires in and wont turn over just cranks 1549 2 Nov 11, 2010, 10:50 PM
(Sidom)
Post with replies   Root post GMC 97 wont start 1866 2 Oct 28, 2010, 9:54 AM
(tstaggs)
Post with replies   Root post 89 chevy truck s10 1161 1 Oct 27, 2010, 4:27 PM
(Hammer Time)
Post with replies   Root post 94 chevy C2500 engine rattle 2747 2 Oct 24, 2010, 11:03 AM
(Tom Greenleaf)
Hot thread - Post has replies   Root post Chevy S-10 Valve noise 4071 5 Oct 21, 2010, 2:38 PM
(Hammer Time)
Post with replies   Root post GMC Sierra problems 2538 2 Oct 20, 2010, 6:59 AM
(Tom Greenleaf)
Post with replies   Root post engine misses hesitates or stumbles mitsubishi pickup. 2350 3 Oct 19, 2010, 10:50 AM
(Sidom)
Post with replies   Root post 94 ford ranger timeing belt broke 2642 1 Sep 26, 2010, 6:16 PM
(Hammer Time)
Hot thread - Post has replies   Root post timing chain gasket cover leaking coolant 11314 6 Sep 22, 2010, 8:37 PM
(Tom Greenleaf)
Post with replies   Root post 1995 BLAZER WONT START 2183 1 Sep 22, 2010, 5:16 PM
(Hammer Time)
Hot thread - Post has replies   Root post 89 chevy truck staling 9468 34 Sep 6, 2010, 5:05 PM
(Sidom)
Post with replies Root post Dodge Air Compresser 1347 5 Sep 2, 2010, 6:15 PM
(Tom Greenleaf)
Hot thread - Post has replies   Root post 83 chevy blazer back firing 1499 10 Aug 13, 2010, 8:48 AM
(djbumman)
Post with replies   Root post motor dies in O D when A/C turned on 1045 1 Aug 4, 2010, 7:33 AM
(Tom Greenleaf)
Post with replies Root post Voltage problem 92 ford f150 5.0 1850 1 Jul 30, 2010, 7:30 PM
(Hammer Time)
Post with replies   Root post need help 1110 1 Jul 26, 2010, 1:08 AM
(Tom Greenleaf)
Post with replies Root post Throttle stuck/runs extremly rough 1955 1 Jul 20, 2010, 4:44 PM
(Tom Greenleaf)
Post with replies   Root post a little water on oil dipstick 4811 3 Jul 16, 2010, 5:52 PM
(Loren Champlain Sr)
Post with replies   Root post engine missing out 1549 1 Jul 16, 2010, 5:47 PM
(Loren Champlain Sr)
Post with replies Root post 1992 F150 Antifreeze leak 3619 3 Jul 16, 2010, 4:56 AM
(wes101382)
  First page Previous page 1 2 3 Next page Last page


LEGEND
Hot thread = Hot thread
Post with replies = Post with replies
Single post = Single post
Thread locked = The thread is locked
Root post = First post in thread


FORUM RULES
You cannot start new threads
You cannot post replies
 


Feed Button




Search for (options) Privacy Sitemap

shopify
site analytics