Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

97 chevy no power under acceleration


  Email This Post



jimmy2f
New User

Oct 30, 2006, 1:39 PM

Post #1 of 3 (4429 views)
97 chevy no power under acceleration Sign In

my 97 chevy 4x4 with a 5.7 liter and 135,000 miles. the engine has no power while accelerating. it spits and sputters. the engine idles great.even if i run the rpm up to redline in park it runs great. put it in gear and give it some gas and it sputters out. i was getting engine light for O2 sensors i replaced all four of them. no change. i replaced the fuel pressure regulator. no change. i replaced all plugs wires cap and rotor. no change.

the longer i drive it the worse it gets, like its loading up. to the point that i can only go about 5 mph. i can shut it off and let it cool and it starts all over. i thought it may be the catalytic convertors but it idles to smooth. could the replacement 02 sensors be bad?

the next stop is the shop. i hope somebody can help me. THANKS


way2old
Veteran / Moderator
way2old profile image

Oct 30, 2006, 5:55 PM

Post #2 of 3 (4427 views)
Re: 97 chevy no power under acceleration Sign In

I believe you are correct on the converters. You could drop the exhaust and see if power returns. If it does, replace the converter.



Being way2old is why I need help from younger minds


fordboy
Novice

Mar 22, 2008, 6:51 PM

Post #3 of 3 (4111 views)
Re: 97 chevy no power under acceleration Sign In

maybe you have done this but try giving it a tune up






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap