Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

96 gmc k1500 5.7 4l60e 4x4 HELP!!!!


  Email This Post



Beefolotty24
New User

Oct 14, 2011, 7:18 PM

Post #1 of 3 (2529 views)
post icon 96 gmc k1500 5.7 4l60e 4x4 HELP!!!! Sign In

I have a 96 GMC K1500 5.7L Vortec 4x4 with 4L60e tranny. Its very hard to determine whats wrong i just had motor rebuilt 20000 ago its got the power but its sucking gas and gears 1-2 shift hard 3-4 just glide in together and used to in OD i could go down the road 70mph at 1800rpms now its like 2300rpms and if i am driving down the road when i punch the gas to WOT it wont gear down unless i do it manually. So far I have replaced ECM distributor, cap, rotor, plugs, wires, air filter, fuel filter, fuel pump, and it also will not go into 4x4L it just blinks. I can tell the motor has the power but something little is holding it back and also if i am like backing up out of driveway to tur around when i hit the accelorater and let off it will die............PLEASE HELP!!


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Oct 20, 2011, 3:12 PM

Post #2 of 3 (2480 views)
Re: 96 gmc k1500 5.7 4l60e 4x4 HELP!!!! Sign In

It's OBDII and would have a full code reading. Seems like trans isn't getting info properly when to do what and transmissions are not my specialty,

T



Mr.scotty
Enthusiast
Mr.scotty profile image

Oct 20, 2011, 4:47 PM

Post #3 of 3 (2474 views)
Re: 96 gmc k1500 5.7 4l60e 4x4 HELP!!!! Sign In

The stalling could or could not be related to the transmission.
Have you check the level and condition of the transmission fluid?
For the stalling I would first check real good for vacuum leaks.
Is the check engine light on or any service lights on?
Have you had it scanned for any stored trouble codes?
--------------------------------------------------------

Your only as good as your tools!






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap