Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

Conventional oil to synthetic oil


  Email This Post



Macweb3000
User

Sep 4, 2014, 7:50 AM

Post #1 of 6 (1229 views)
Conventional oil to synthetic oil Sign In

Hello gents! I had a quick question about oil. I use a high mileage conventional oil with my truck and I use 10w-40. Was looking at trying royal purple synthetic but they only make a 10w-30 would that change be acceptable?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Sep 4, 2014, 8:51 AM

Post #2 of 6 (1223 views)
Re: Conventional oil to synthetic oil Sign In

Who knows?

You didn't post any year, make, model or engine size.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Sep 4, 2014, 9:02 AM

Post #3 of 6 (1219 views)
Re: Conventional oil to synthetic oil Sign In

I didn't think any engine suggested use of 10w-40 for decades now. What is this as already asked. Synthetics come with a lot of urban lore but clearly are more capable and all are supposed to be compatible. Range can differ from the ways some test determines the viscosity ratings and should state that it covers the OE specs for what is called for.


IMO it's best property is tolerance to temps, not sludging up and it pours and circulated when cold better and faster than the same rated conventional oil just witnessed by me not some SAE test results.


Any needs to be changed on suggested schedules. I don't buy into that 15,000 mile bull I see out there one bit,


T



Discretesignals
Ultimate Carjunky / Moderator
Discretesignals profile image

Sep 4, 2014, 9:58 AM

Post #4 of 6 (1212 views)
Re: Conventional oil to synthetic oil Sign In

2000 dodge ram 1500 5.2L V8?

If so, did you ever find out what your problem was with it lacking power? 10w-30 would work just fine. The only problem is that if you have a tired, worn out, leaking engine, putting expensive oil in it is a waste of money in my opinion.





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.


Macweb3000
User

Sep 4, 2014, 1:06 PM

Post #5 of 6 (1200 views)
Re: Conventional oil to synthetic oil Sign In

Yes it is the 2000 dodge ram 1500 5.2l V8. And it's not leaking oil that much anymore some old stuff around some seals from some old problems but I recently took of the valve covers and replaces the gaskets and new grommets for the crank case breather and pcv valve. Fuel trim looks good better than I thought, no codes or anything. Does smell a little rich coming out the back and I am getting 10-11 miles to the gallon. Oxygen sensors are fairly new I'm not sure if the cats could be acting up a little still haven't checked them out fully. I do know I'm having some squeaking and knocking sounds from the upper right hand side closest to the passenger head light I believe it's called the leak detector module it's the only thing that clicks and sounds like the squeaking is coming from it. Don't really know if it could cause a lot of problems without throwing any codes. I also did just tune up my ignitions system new coil new ignition lock new rotor and cap same wires but they are still good and I switched from iridium back to copper plus champion spark plugs. Other than that I'm not really sure I was going to check for some vacuum leaks soon but I don't expect to find anything. It's all original equipment 105000 miles on it passed smog with flying colors and it's perfect at idle except when I start it it idles for 3-6 minutes at 850-1100 rpms then goes to 600-650. Not really sure if you guys have any guesses.


Macweb3000
User

Sep 4, 2014, 1:15 PM

Post #6 of 6 (1196 views)
Re: Conventional oil to synthetic oil Sign In

I did forget to mention that it did something weird a few weeks ago but hasn't done anything since I was pulling out of work and made a u turn and as I stepped on he gas coming out of the u turn the rpms raised above 2000 but the truck failed to gain speed. When I noticed what was going on I took my foot off the gas and it seemed to jolt very slightly when it hit 800 rpms and it felt like it engaged again. Has been perfect ever since. The rear diff has a leak I plan on fixing that soon and I did change the tranny oil out a few thousand miles ago but the previous owner never really took good care of the tranny so I'm doing another drain and fill with a magnet clean and new filter for the hell of it cause last time the magnet looked like a slimy silvery grey fungus. Last thing to catch you up on all the symptoms it does have some rather rough engagements from park to reverse, reverse to drive and so forth nothing alarming but a noticeable jolt.






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap

shopify
site analytics