Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN







Search Auto Parts

98 chevy truck wont shift, tach and speedo not working


  Email This Post



radamk
New User

Sep 8, 2009, 9:02 AM

Post #1 of 4 (7245 views)
98 chevy truck wont shift, tach and speedo not working Sign In

I have a 98 chevy k series truck, V6, 1/2 ton 2 wheel drive, automatic transmission with 271000 kms. The speedo and tach does not work, and when you drive the vehicle down the road it is sluggish to start accelerate because it will not shift down to 1st. eventually when you do get going it will drive properly aside from the fact that it will not shift. Sometimes the speedo and tach will work but is very eratic. I have taken the transmission pan off to see if there are any parts and to see how the oil is and there was nothing to find. i have a few codes that have come up that include shifter A and B, shift control module. I have been told to check wire connections which I have yet to try. Also checking the speed sensor on the tailshaft of the transmission was also suggested which I have to try yet.


Loren Champlain Sr
Veteran / Moderator
Loren Champlain Sr profile image

Sep 9, 2009, 12:09 PM

Post #2 of 4 (7213 views)
Re: 98 chevy truck wont shift, tach and speedo not working Sign In

radamk; The transmission shifting depends on the VSS (vehicle speed sensor) input. Take the suggestions you've been given.
Loren
SW Washington


radamk
New User

Sep 18, 2009, 1:20 PM

Post #3 of 4 (7198 views)
Re: 98 chevy truck wont shift, tach and speedo not working Sign In

I replaced the speed sensor which did improve my situation. But it is still eratic where I can drive for a little ways and the tach and speedo wont work right away but when they kick in they work fine but it still does not shift properly but I can shift the gears manually all except overdrive which seems like it is never there lately


JimJ
New User

Dec 6, 2009, 2:06 PM

Post #4 of 4 (7117 views)
Re: 98 chevy truck wont shift, tach and speedo not working Sign In

I have a 97 doing the same thing.I changed the instrument cluster but tach and speedometer still doing same thing.I checked the power fuse on the side panel for PRNodDL lites and looks like low voltage to it.I can turn key on and they lite up but go out when i start up.Like you i have to manually shift but onle have 2nd and Drive.Sometimes it will jerk and tach and speedometer works but still won't shift right....I HOPE someone can give an answer.Could get expensive replacing parts without knowing..Thanks






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap

shopify
site analytics