Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

rear window defroster quit working


  Email This Post



rconti
New User

Dec 14, 2014, 7:25 AM

Post #1 of 4 (1221 views)
rear window defroster quit working Sign In

I have a 2006 chevy impala, rear window defroster quit working, I have changed the relay under the hood, continues to not work.

thanks

Rick


Discretesignals
Ultimate Carjunky / Moderator
Discretesignals profile image

Dec 14, 2014, 7:33 AM

Post #2 of 4 (1209 views)
Re: rear window defroster quit working Sign In

Did you inspect the defrost grid tabs to be sure they haven't came off the grid? Do you have power and ground to the defroster grid at the tabs when you test with a volt meter? Purple wire should have 12+ volts and the black wire should have close to 0 volts with the rear defroster turned on.





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.

(This post was edited by Discretesignals on Dec 14, 2014, 7:35 AM)


rconti
New User

Dec 14, 2014, 7:35 AM

Post #3 of 4 (1205 views)
Re: rear window defroster quit working Sign In

thanks for response, tabs appear to be connected. Will check power and ground. thanks!


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Dec 14, 2014, 11:03 AM

Post #4 of 4 (1197 views)
Re: rear window defroster quit working Sign In

Be gentle with those and grids. I see some folk take a one edge razor to clean off a sticker and wipe out all the grids too! Game over if bad enough as they are much like a decal ON the glass not inside. Should just be power and ground other than that. If you have that and not working with real care you can find the power loss along grids with a test light and have see folks even scrape inside frosted glass and wreck whole defrosters or a few or more rows. They do make kits to fix some issues if so,


T







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap