Main IndexAuto Repair Home Search Posts SEARCH
Who's Online WHO'S
Log in LOG

front end vibrations on a 05 Dodge Neon

car parts image

  Email This Post

New User

Sep 13, 2013, 4:40 PM

Post #1 of 3 (766 views)
front end vibrations on a 05 Dodge Neon Sign In

Hello Friends,

I have a 05 Dodge Neon SE with an automatic transmission and 90,000ish miles.

Lately I have been hearing and feeling vibrations from the front end that seem to lesson after it is driven for a while.

The vibration is heaver when I first start the car than lessons as it warms and stops completely when in reverse.

When stopped at a light, the vibration starts again unless I put it in neutral.

I checked the fluid and it is at the proper level, has a nice red tint and does not smell burnt.

The transmission shifts smoothly in all gears and the car runs well otherwise.

Thnaks in advance for your advice!

Ultimate Carjunky / Moderator
Discretesignals profile image

Sep 13, 2013, 6:18 PM

Post #2 of 3 (754 views)
Re: front end vibrations on a 05 Dodge Neon Sign In

Sounds like the symptoms of a failing engine mount.

Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.

New User

Sep 14, 2013, 5:15 PM

Post #3 of 3 (727 views)
Re: front end vibrations on a 05 Dodge Neon Sign In

You were right on point, I was about to replace the CV shafts but I checked the upper and lower torque struts and both were shot. I replaced them and the worst of the vibration went away! There is another mount under the battery tray that I am checking next, but I think it can wait a little bit.

The whole job took about 30 minutes minus the running around to get the parts and tools. Jack stands, floor jack, 18mm and MM wrenches, MM socket for the splash guard and a star drive is all it took.

Thanks for the advice!

  Email This Post

Feed Button

Search for (options) Privacy Sitemap

site analytics