Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









engine feels like its missing, cant figure it out


  Email This Post



Guest
Anonymous Poster

Dec 31, 2006, 11:51 AM

Post #1 of 5 (1389 views)
Shortcut
engine feels like its missing, cant figure it out Sign In

1999 s10 zr2, feels like motor misses all the time still has good power it use to be worse when it was cold but now its all the time. ive had engine lights (multiple cylinder missfire) comes on and goes off on its own but still misses. ive replaced plugs,wires,control modual,engine temp sensor,crank shaft position sensor,fuel filter, and cleaned fuel injectors, replaced cat conferter and maf sensor. any advice...Pirate


mike o
Anonymous Poster
harleydadcar@yahoo.com

Dec 31, 2006, 10:00 PM

Post #2 of 5 (1383 views)
Shortcut
Re: engine feels like its missing, cant figure it out [In reply to] Sign In

try checking your coil take it to a shop and have it scoped


Bear505
User

Jan 1, 2007, 11:02 AM

Post #3 of 5 (1380 views)
Shortcut
Re: engine feels like its missing, cant figure it out [In reply to] Sign In

Sounds to me like you've done about everything to figure out an engine problem. My parents had an S-10 a little older than yours, and my dad, from accross the country, described a loping, or missing sensation on acceleration, or every once in a while on the freeway. No sputtering from the engine, or backfiring. On my next visit, I serviced the automatic transmission. (filter and fluid) and made sure that the modulator was working properly. It fixed his problem. See what happens.. Might not help... but with everything else you've done, it couldn't hurt.


Guest
Anonymous Poster
trgebhart@fuse.net

Jan 4, 2007, 4:09 PM

Post #4 of 5 (1368 views)
Shortcut
Re: engine feels like its missing, cant figure it out [In reply to] Sign In

it could be control module behind coils make sure you dont have bad knock sensor


Guest
Anonymous Poster

Jan 10, 2007, 7:37 PM

Post #5 of 5 (1346 views)
Shortcut
Re: engine feels like its missing, cant figure it out [In reply to] Sign In





engine feels like its missing, cant figure it out


  Email This Post
 
 






Latest Forum Post

I have a 93 dodge half ton 4wheel drive it will spit and sputter upon accelerati...


Recently my car has been dying overnight and I have been having to jump start it...


2001 Toyota Echo, 4 door, 1.5L, 90,000 miles My toyota echo radiator/air condit...


2001 Cavalier Z24 2.4L Hi Folks, I'm looking for help on flushing old gas ...


 Will a 2001 Isuzu motor fit a 99 yr model Isuzu?


I have a 2011 Ford Escape with a rear gate that only opens part time. It is supp...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics