Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

New battery but still die


  Email This Post



goldenshuttle
New User

Aug 17, 2016, 9:07 AM

Post #1 of 3 (732 views)
post icon New battery but still die Sign In

Naza Atos(Hyundai) 1.1 L - 4 cylender year 2006.
seller told me hard start need new battery. New battery did not solve problem. I started with a charged battery, when I remove the battery head engine still running, means charge is working. Can it be a leak ? how to know which one...thanks


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Aug 17, 2016, 9:45 AM

Post #2 of 3 (727 views)
Re: New battery but still die Sign In

Removing a battery cable from a running engine is one of the dumbest things you could do. It will fry computers in seconds.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



supergunner223
New User

Sep 8, 2016, 10:37 PM

Post #3 of 3 (583 views)
Re: New battery but still die Sign In

could need an alternator or maybe it has a parasitic drain. have it tested for free somewhere like auto zone...if you have a voltage multi meter you can check for parasitic drain. youtube has good videos on how to do this.

and definitely do not disconnect the battery when the car is running anymore.






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap