Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

I Eagle Talon problem


  Email This Post



Keith03
New User

Nov 29, 2012, 8:06 PM

Post #1 of 6 (1425 views)
I Eagle Talon problem Sign In

Hi I have a 1995 Eagle Talon ESI 2.0 non-turbo 5 speed with 165,xxx miles. I have this problem where it will lose all power to it and cut off, but when its cold and I try to start it for the first time it will turn over just fine and drive just fine, but when I turn it off for a while and try to go out and do something it will try to start up but quickly die or it will take about 5-7 times to try and keep it either running or trying to start it. Also when it is driving fine and say about after an hour or so of driving it will begin to bog out and die. I have replaced the plugs and wires, the coil pack, the belt, I have a aftermarket air intake on it, replaced the vacuum hoses, new oil pan. there are days i will have no problem and a lot of the days I have non stop problems with it and it is starting to piss me off. I don't want to sell it i want to figure out the problem and keep the car. If anyone that is a DSM enthusiast please help because I'm just now getting into fixing my own car and I'm in a dead end spot. I thought it was the alternator or starter but some of the mechanics I went to said it was not the problem. I have also thought it was the battery but i took the battery out and put it on a tester and it was just fine as well. I have also fixed every problem that came up on the car reader and i still have the same problems and its just confusing now. Please help i'll give you a cookie


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Nov 30, 2012, 3:44 AM

Post #2 of 6 (1389 views)
Re: I Eagle Talon problem Sign In


In Reply To
I have a aftermarket air intake on it,


^^ Question that^^

Have you checked fuel pressure while it is acting up? Will it hold?

Exhaust restrictions? Worth a check too.
Gotta ask why it needed an oil pan too?

T


Keith03
New User

Nov 30, 2012, 4:40 PM

Post #3 of 6 (1368 views)
Re: I Eagle Talon problem Sign In

I have checked the exhaust it's fine except the tiny tiny leak in the exhaust. I have not checked the fuel pressure not to sure on how to do that. like I said I'm just a newbie at this. the reason for the new oil pan because when I got the the car the oil pan had a bad leak in it.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Nov 30, 2012, 5:25 PM

Post #4 of 6 (1367 views)
Re: I Eagle Talon problem Sign In


Quote
I have checked the exhaust it's fine


Impossible..................... You have no idea how to even test for a restriction.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Keith03
New User

Dec 1, 2012, 10:11 AM

Post #5 of 6 (1347 views)
Re: I Eagle Talon problem Sign In

Your right I don't know but I had my mechanic look at it and he said it was fine so I went with his word


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Dec 1, 2012, 1:21 PM

Post #6 of 6 (1335 views)
Re: I Eagle Talon problem Sign In

I still doubt it was tested properly. It needs to be pressure tested and the vacuum readings analyzed during the failure.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap