Main IndexAuto Repair Home Search Posts SEARCH
Who's Online WHO'S
Log in LOG

Geo Prizm 97 struggles to start

  Email This Post

Anonymous Poster

Jan 1, 2009, 10:28 PM

Post #1 of 2 (724 views)
Geo Prizm 97 struggles to start Sign In

Hi All,

I have a Geo Prizm 97 (almost the same as a Toyota Corolla)

About a month ago the car failed to start. I managed to jump start the car and it was fine for a few days. It then happened again so I took it to a local repair center.

They informed me that the battery and starter motor had failed. They replaced both (I purchased the starter from checkers auto parts as the repair center were charging twice as much for the same part) the repair center installed the new battery and starter.

The same thing happened again yesterday (fails to start) When it was jump started it worked again. I have spoken with a few friends and they have suggested that I get the alternator replaced (as the battery is not holding the charge) and / or the spark plugs / distributor cap.

Any advice would be most appreciated as I don’t want another large bill from the repair center and then I have the same problem a few weeks later again.

When you try to start the car (when it fails) all the lights on the dashboard come on as normal and the engine tries to start, but after several turns it fails.

Please let me know if you need further information.

Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jan 2, 2009, 5:14 AM

Post #2 of 2 (712 views)
Re: Geo Prizm 97 struggles to start [In reply to] Sign In

This has the signs of not charging which is frequently an alternator (charging system) problem. Must rule out a loose belt and test the output of it first. Charge up battery first with a charger before testing.

Note: Shops will "markup" parts they install vs what you see if you buy and install yourself. Somewhat like buying a meal at a restaurant vs a grocery store and cooking yourself....

Long retired now

Geo Prizm 97 struggles to start

  Email This Post

Latest Forum Post

I own a Mitsubishi Eclipse Spyder 2008 and had a brand new battery installed on ...

I have a 86 Ford Bronco with a 302 engine and need a new carb. It is a 2 barrel ...

I have a 1988 Nissan D21 with 124k miles. It's been well taken care of and gener...

car makes a grinding noise when i go in reverse..What could it be?

A?c and heater will not work. The letters "OC" appear on display. What does thi...

I have a '79 Buick with a TH350 non lock-up. It has worked fine after being rebu...

Feed Button

Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap

Search for (options) Privacy

web statistics