Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

96 gmc Sierra


  Email This Post



bigrich1356
New User

Apr 5, 2013, 9:58 AM

Post #1 of 7 (1406 views)
96 gmc Sierra Sign In

I have a 96 gmc sierra 1500 2 wheel drive with a 5.0 vortec engine 160xxx. I bought it last spring with no problems, everything was running good, no check engine light or anything wrong, well the guy neglected to tell me the oil pump was no good and i blew the engine, so i put in a newer engine and now the check engine light is on with trouble codes (P0135, P0140, and P0141) the only o2 sensor i unhooked was the bank 2 sensor 1 b/c the wire runs behind the motor and i didn't want it to get pinched but its the bank one side where the codes are, i checked the wires and they look fine, the truck runs fine, but every once in awhile the check engine light will go off for a day our 2, any idea what might have happened in the week it say while changing out engines that would cause them codes to come up? And what should i do to fix it b/c my inspection is about to run out?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Apr 5, 2013, 3:46 PM

Post #2 of 7 (1356 views)
Re: 96 gmc Sierra Sign In

Have you tried clearing to codes to see if they all come back?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



bigrich1356
New User

Apr 5, 2013, 4:59 PM

Post #3 of 7 (1347 views)
Re: 96 gmc Sierra Sign In

I cleared the codes twice but they come back within 5 miles


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Apr 5, 2013, 5:03 PM

Post #4 of 7 (1343 views)
Re: 96 gmc Sierra Sign In

I would verify that these sensors are plugged in firmly. I doubt you have 2 bad heaters so check all your fuses. If they are OK, test for power and ground at the sensor at the 2 like colored wires.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



bigrich1356
New User

Apr 5, 2013, 5:09 PM

Post #5 of 7 (1338 views)
Re: 96 gmc Sierra Sign In

I unplugged all of then today to check to see other were dirty but they were all good, and i put em back together pretty snug... The only fuse i could find in the book is for the (heated o2) in the engine compartment but that was fine, should there be a fuse anywhere else?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Apr 5, 2013, 5:10 PM

Post #6 of 7 (1334 views)
Re: 96 gmc Sierra Sign In

You should use a test light to test every fuse in the car.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



bigrich1356
New User

Apr 5, 2013, 5:12 PM

Post #7 of 7 (1331 views)
Re: 96 gmc Sierra Sign In

So it could be something stupid that has nothing to do with the o2 sensors?






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap