Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

2014 Traverse AC not working some of the time


  Email This Post



kswick313
User

Sep 14, 2019, 6:02 AM

Post #1 of 5 (144 views)
2014 Traverse AC not working some of the time Sign In

2014 Chevy Traverse where the ac hasn't worked a few times. If I turn the car off for a bit and then restart it works. What could be the issue with this?


(This post was edited by kswick313 on Sep 14, 2019, 6:04 AM)


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Sep 14, 2019, 7:07 AM

Post #2 of 5 (136 views)
Re: 2014 Traverse AC not working some of the time Sign In

What tests are you capable of doing just to begin on this? It would take at least a static pressure and at what temperature could say a lot and again just that pressure when it does work. Just those two note the temp from just low port. For now nothing else, just that,


T



Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Sep 14, 2019, 7:17 AM

Post #3 of 5 (130 views)
Re: 2014 Traverse AC not working some of the time Sign In

Another couple of questions are what was the situation when it shut off? Like, how long had it been running? Did it warm up slowly or suddenly? What was the blower speed when it went off?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



kswick313
User

Sep 14, 2019, 10:03 AM

Post #4 of 5 (116 views)
Re: 2014 Traverse AC not working some of the time Sign In

It will work fine most of the time but then sometimes I start car to leave and everything works but it won't cool. If I turn the car off and wait a minute and start it again then it starts cooling and will be fine. It just started doing this and has done it now a few times. For example, went to work everything was fine, left for lunch and everything works but doesn't start cooling. I shut the car off and waited a minute and restarted and it was cooling and when I left work it was fine.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Sep 14, 2019, 10:25 AM

Post #5 of 5 (107 views)
Re: 2014 Traverse AC not working some of the time Sign In

OK, that info helps. It sounds like either the compressor clutch or the clutch relay is weak.

As the AC clutch engages hundreds of times, it tends to both wear the surface of the plate and weaken the electrical coil magnet so it has a harder time pulling the clutch in. A trick we use to find out which is the next time it is not working, poke the clutch plate with a long stick to see if it engages. Just be careful as it will snap the stick back at you. If it engages, that means the clutch is the issue.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap