Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN






Search Auto Parts

2006 Nissan Murano - "pinging"


  Email This Post



NissanMur
New User

Jan 31, 2013, 12:09 AM

Post #1 of 2 (1893 views)
2006 Nissan Murano - "pinging" Sign In

I purchased a 2006 Nissan Murano (3.5 litre v6) from Japan and had it shipped to my current country of residence (Myanmar). The vehicle has 74k kilometers and is generally a great car. One month into ownership, I noticed a pinging (or knocking) coming from the engine when accelerating. If I cruise evenly and slowly up to the speed limit, there is no pinging.
To begin my remedy of the pinging, I started with adding a 92 octane fuel. The pinging remained. Next, I changed the oil and oil filter. Still pinging. Next, I upgraded to 95 octane fuel (available here in Myanmar). Pinging seemed to become less, but still audible. Just today, I changed some rather burnt spark plugs to new ones. The pinging remains. The mechanic suggested I replace the spark plug caps because of the burning, which I may do.
Question: am I going through this diagnosis correctly? Is there anything I am missing? I need some sound advice and would appreciate any.


(This post was edited by NissanMur on Jan 31, 2013, 12:14 AM)


Discretesignals
Ultimate Carjunky / Moderator
Discretesignals profile image

Jan 31, 2013, 12:24 PM

Post #2 of 2 (1855 views)
Re: 2006 Nissan Murano - "pinging" Sign In

Check engine light on? If so, what trouble code numbers are stored?

Check the operation of the EGR system
Check the operation of the knock sensor
Make sure the correct spark plugs are installed:

NGK PLFR5A-11





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap