Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN




1999 Toyota Corolla CHECK ENGINE light, canister valve?


  Email This Post



rramaiah
New User

Jul 28, 2011, 2:38 PM

Post #1 of 2 (3156 views)
Shortcut
1999 Toyota Corolla CHECK ENGINE light, canister valve? Sign In

I have a 1999 Toyota Corolla with about 75K miles on it. Several weeks ago, the CHECK ENGINE light went on. I took it into a shop immediately. They said that the "canister valve" went bad and it'd cost $400 to replace it. Said it was a common problem with Toyota's and though it would have no effect on driving, I'd fail emissions. I thought it over for about a week, then suddenly the light turns off. Thought I'd dodged the problem, but then a week later, the light turns on again. This time, I was worried because I realized that my inspection sticker had a big 7 on it, meaning it was due at the end of July. I waited another week. The light turned off! I immediately took it to an inspection station and passed. A few more days pass and light turns back on. I honestly don't remember whether the light is on or off right now, but I'd like to know how serious a problem this is or if I should just wait it out. I read somewhere that it might have to do with a loose gas cap, so that's the first thing I tried: I bought a new gas cap. Any other ideas?


samg.
User
samg. profile image

Jul 29, 2011, 5:55 PM

Post #2 of 2 (3133 views)
Shortcut
Re: 1999 Toyota Corolla CHECK ENGINE light, canister valve? [In reply to] Sign In

I can tell you working for gm I've replaced a lot of canisters....sometimes the plugged area in the canister may open and allow it to monitor ok, but you may look into an electrical problem with the circuit the valves and emissions are on.




1999 Toyota Corolla CHECK ENGINE light, canister valve?


  Email This Post
 
 






Latest Forum Post

Hello everyone, hope everyone's doing well. So, my sister got a Hyundai Accent...


What can I do to prevent the transmission fluid from mixing with the radiator fl...


I have a: 2006 Hyundai Tiburon - 2.7L V6 DOHC (Delta) with 240k on the odometer....


Hey first post on here. I got a 2002 Suzuki xl7 4x4 with 157,0xx miles on it. I ...


Hey guys, I have a 98 silverado 1500 5.7 vortec. I just replaced the battery and...


1991 GMC K1500 5.7. Engine runs fine til it warms up then when you apply brakes...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics