Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









1999 Mercury Grand Marquis


  Email This Post



Guest
Anonymous Poster
dsheets2764@sbcglobal.net

Jun 7, 2008, 5:34 PM

Post #1 of 5 (2495 views)
Shortcut
1999 Mercury Grand Marquis Sign In

1999 Mercury Grand Marquis engine is not running properly. Idles and revs fine when not in gear. Hesitates and a little rough idle when in gear. Seems to run slightly worse while AC unit is on. What is the problem? Is this a likely O2 sensor problem, or perhaps a transmission sensor? Any help would be appreciated. Thanks!


way2old
Veteran / Moderator
way2old profile image

Jun 7, 2008, 5:47 PM

Post #2 of 5 (2489 views)
Shortcut
Re: 1999 Mercury Grand Marquis [In reply to] Sign In

What is the mileage? When was the last tune up? When was the fuel filter last changed? We need all the maintenance information you can give us so we will not be asking things that you have already done. Let us know.



Being way2old is why I need help from younger minds


Guest
Anonymous Poster

Jun 8, 2008, 11:52 AM

Post #3 of 5 (2487 views)
Shortcut
Re: 1999 Mercury Grand Marquis [In reply to] Sign In

Mileage = 100495; as to the rest - car was bought used from son of deceased owner. Son was not sure of any maintenance records. Oil has been changed recently. Car is clean and ran great initially. Only recently did this problem develope. Any info and/or advice you can give will be appreciated.


way2old
Veteran / Moderator
way2old profile image

Jun 8, 2008, 1:12 PM

Post #4 of 5 (2486 views)
Shortcut
Re: 1999 Mercury Grand Marquis [In reply to] Sign In

I would start with spark plugs and fuel filter. These are rather inexpensive and easily done yourself. You will need a tool to releadse the lock on trhe fuel filter, but other than that, general tools will finish the rest. Ratchet, short extension, a good 5/8 inch spark plug socket and a 7mm or 1/4 inch socket to remove the coils.



Being way2old is why I need help from younger minds


Guest
Anonymous Poster

Jun 9, 2008, 11:32 AM

Post #5 of 5 (2477 views)
Shortcut
Re: 1999 Mercury Grand Marquis [In reply to] Sign In

Thanks for the info and the help. We'll give it a try. Thanks again. It is appreciated.




1999 Mercury Grand Marquis


  Email This Post
 
 






Latest Forum Post

Hi guys. this thing was parked inside during zero temps. My prestone tester le...


1991 GMC K1500 5.7. Engine runs fine til it warms up then when you apply brakes...


i have a 1970 gto 4speed car that I put a Borg Warner t10 out of a 1980 camero i...


I just purchased a 2008 chrysler 300 a month ago. When I first got the car it ha...


can I put the axels from a 1986 chevy c2500 4wd w a standard transmition on a 19...


Hi. I have never posted here and just created the account. I was coming home fro...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics