Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









1995 ford ranger Fuel pump Relay problem


  Email This Post



Newton114
New User

Dec 27, 2010, 11:46 PM

Post #1 of 3 (13617 views)
Shortcut
post icon 1995 ford ranger Fuel pump Relay problem Sign In

I have a 1995 4 cyl (2.3L) Ford Ranger XLT with roughly about 115k miles on it and what happens is my car will turn over but will not start unless my Check Engine Light is on. But what happens is that I will have to keep the key turn halfway and go into the engine bay and go into my fuse box and hit it a couple of times until I actually hear the fuel pump then start to run. After that my truck runs perfectly fine.

I did try changing my Fuel Pump Relay thinking that would be the problem, but it did not work.

Could it be a open connection in the box? Fuse blown? OR???

It doesn't happen all the time, but enough to get on my nerves :D

Please answer back to me with a solution!!! Thank You!!!!!!!


Sidom
Veteran / Moderator
Sidom profile image

Dec 28, 2010, 1:32 AM

Post #2 of 3 (13612 views)
Shortcut
Re: 1995 ford ranger Fuel pump Relay problem [In reply to] Sign In

If hitting the fuse box gets it's to start, it sounds like you have a bad connection. You'll have to take it apart and inspect it....






__________________________________________________________________________________________



Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Dec 28, 2010, 5:45 AM

Post #3 of 3 (13605 views)
Shortcut
Re: 1995 ford ranger Fuel pump Relay problem [In reply to] Sign In

I would try swapping out the EEC/aka PCM power relay too.






~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.





Advertising


  Email This Post
 
 






Latest Forum Post

A few days ago my driver-side headlight went out, and last night my passenger-si...


I have a weird situation in that my run lights won't work on my utility trailer....


I recently blew an engine-'01 CHEV SILVERADO 5.3L-& had an '02 5.3L transpla...


hi, my engine still runs after i turn the key off then dies after few seconds, w...


My 1995 Nissan Quest starts just fine. When I depress the brake pedal and move t...


I have a 1992 ford ranger 3.0l v6 5 speed. today i ran out of gas and when i got...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy