Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









1995 ford ranger Fuel pump Relay problem


  Email This Post



Newton114
New User

Dec 27, 2010, 11:46 PM

Post #1 of 3 (13150 views)
Shortcut
post icon 1995 ford ranger Fuel pump Relay problem Sign In

I have a 1995 4 cyl (2.3L) Ford Ranger XLT with roughly about 115k miles on it and what happens is my car will turn over but will not start unless my Check Engine Light is on. But what happens is that I will have to keep the key turn halfway and go into the engine bay and go into my fuse box and hit it a couple of times until I actually hear the fuel pump then start to run. After that my truck runs perfectly fine.

I did try changing my Fuel Pump Relay thinking that would be the problem, but it did not work.

Could it be a open connection in the box? Fuse blown? OR???

It doesn't happen all the time, but enough to get on my nerves :D

Please answer back to me with a solution!!! Thank You!!!!!!!


Sidom
Veteran / Moderator
Sidom profile image

Dec 28, 2010, 1:32 AM

Post #2 of 3 (13145 views)
Shortcut
Re: 1995 ford ranger Fuel pump Relay problem [In reply to] Sign In

If hitting the fuse box gets it's to start, it sounds like you have a bad connection. You'll have to take it apart and inspect it....






__________________________________________________________________________________________



Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Dec 28, 2010, 5:45 AM

Post #3 of 3 (13138 views)
Shortcut
Re: 1995 ford ranger Fuel pump Relay problem [In reply to] Sign In

I would try swapping out the EEC/aka PCM power relay too.






~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.





Advertising


  Email This Post
 
 






Latest Forum Post

2008 Nissan Sentra 2.0 CVT 50,000 Miles New to DIY auto repair. I want to repla...


Straight to the point. I have an aftermarket alpine in my 2003 Jeep Liberty Spo...


Hi all, I wanted to check with you how much labor wise could it cost me to repl...


1990 chevrolet c1500 4.6 tbi 110k recently replaced motor w/ a 93 4.6 had a fe...


2004 Toyota Tacoma So my father's truck that he uses for work has recently star...


Mechanic changed serpentine belt on 09 Chevy Cobalt, said there were cracks in i...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy