Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN




Car runs but bucks and hesitates as I push the gas pedal.


  Email This Post



Becky368
New User

Dec 29, 2008, 1:18 PM

Post #1 of 2 (4658 views)
Shortcut
Car runs but bucks and hesitates as I push the gas pedal. Sign In

My car is a Ford Escape 2001. It is a six cyliner 2 wheel drive. I am not sure of the engine size. My car runs and even idols. While idoling or accelerating it kind of bucks. It feels like I give it gas and it hesitates then bucks a little and then accelerates. Somone suggested that it isn't running on all cylinders. The Co2 light has been on in my car for over a year. I have had it in several times they tell me they have no idea why the light is on. They did a computer diagnostic check last year and couldn't tell why the light was on. I even passed an emission test with the light on. So, I don't know if the light has anything to do with the problem. I did notice the problem started when it was snowing and is worse in snow and rain and wet roads. It started as a once and awhile problem two weeks ago and now it happens every time I drive anywhere. What I need to know is what I need to check to try and correct the problem. I am not sure if my car even has spark plugs. Or how I can make the car use all the cylinders. Like I said it idols it won't go over 50 though.


way2old
Veteran / Moderator
way2old profile image

Dec 29, 2008, 1:43 PM

Post #2 of 2 (4652 views)
Shortcut
Re: Car runs but bucks and hesitates as I push the gas pedal. [In reply to] Sign In

My guess is you either have a cylinder misfire oir a partially plugged fuel filter. I would invest in a tune up, including air and fuel filters. You should be able to go to an auto parts store and they will read the codes for you. If it is like a P030X(where X is a number), that tells you you have a cylinder miss. Please post back the EXACT CODE NUMBER that comes on the scan tool. Do not post what they tell you is wrong. Thanks.



Being way2old is why I need help from younger minds




Advertising


  Email This Post
 
 






Latest Forum Post

1990 chevrolet c1500 4.3 tbi 110k recently replaced motor w/ a 93 4.6 had a fe...


I am having a random repeating problem with a 2007 Honda Civic. The fuse that op...


Hi everybody not mechanical at all PLEAE HELP I HAVE A 2000 FORD TAURUS SE,,,B...


2003 Chrysler mini van. 3.3 ltr 133600 mi while driving, engine light came on b...


driver side spark plugs was no problem-3 out and 3 new ones in,now it's time fo...


1998 Chevy 3500,6.5 diesel,automatic trans,4WD,1ton dump truck. Problem:Driving ...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy