Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









5.7 hemi lost all oil pressure


  Email This Post



roughneck
New User

Jan 15, 2011, 8:40 PM

Post #1 of 3 (3327 views)
Shortcut
5.7 hemi lost all oil pressure Sign In

2005 dodge ram with 5.7 hemi lost oil pressure while driving on hwy,motor was making noise. i stopped and shut motor off and checked oil,the oil level was fine.i restarted the motor and oil pressure gauge started coming up and motor noise slowly went away has anyone heard of this happening and what does it mean ?


Loren Champlain Sr
Veteran / Moderator
Loren Champlain Sr profile image

Jan 17, 2011, 6:38 PM

Post #2 of 3 (3296 views)
Shortcut
Re: 5.7 hemi lost all oil pressure [In reply to] Sign In

roughneck; This could be very serious. Don't continue driving until you've gotten to the bottom of the problem. Could be as simple as a faulty oil pump or debris in the oil pan, blocking the pickup screen. (I say, simple, but expensive) Has this vehicle had regular maintenance? Oil and filter changed every 5000 miles?
Oil recommended is 5W30. I use 10W30 synthetic in mine. Have the oil pressure checked (Don't rely on the guage). Have not heard any problems with oil pumps on this engine, but anything is possible.
Loren
SW Washington


roughneck
New User

Jan 17, 2011, 7:25 PM

Post #3 of 3 (3290 views)
Shortcut
Re: 5.7 hemi lost all oil pressure [In reply to] Sign In

Thanks for the reply,and the advice,unfortunately I was out of town at the time and had to drive it on home,didn't have any problem but today the same thing happened again I will be finding the problem soon I will post when I know more.




5.7 hemi lost all oil pressure


  Email This Post
 
 






Latest Forum Post

so i have a 98 lumina 3.1 .. recently i was driving down the road and it stalle...


1986 Itasca Phasar (Same as Winnebago Lesharo or Renault Trafic 2L Turbo Diesel ...


1972 Ford F750. I have no power assist. All vacuum lines to the booster seem OK....


I have been trying to figure this out since last October and have had no luck. ...


SO I have a squealing noise coming from somewhere underneath the hood in my van,...


92 Ford F150. 5.0. I purchased vehicle and AC did not work, tried charging and ...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics