Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









5.7 hemi lost all oil pressure


  Email This Post



roughneck
New User

Jan 15, 2011, 10:40 PM

Post #1 of 3 (2779 views)
Shortcut
5.7 hemi lost all oil pressure Sign In

2005 dodge ram with 5.7 hemi lost oil pressure while driving on hwy,motor was making noise. i stopped and shut motor off and checked oil,the oil level was fine.i restarted the motor and oil pressure gauge started coming up and motor noise slowly went away has anyone heard of this happening and what does it mean ?


Loren Champlain Sr
Veteran / Moderator
Loren Champlain Sr profile image

Jan 17, 2011, 8:38 PM

Post #2 of 3 (2748 views)
Shortcut
Re: 5.7 hemi lost all oil pressure [In reply to] Sign In

roughneck; This could be very serious. Don't continue driving until you've gotten to the bottom of the problem. Could be as simple as a faulty oil pump or debris in the oil pan, blocking the pickup screen. (I say, simple, but expensive) Has this vehicle had regular maintenance? Oil and filter changed every 5000 miles?
Oil recommended is 5W30. I use 10W30 synthetic in mine. Have the oil pressure checked (Don't rely on the guage). Have not heard any problems with oil pumps on this engine, but anything is possible.
Loren
SW Washington


roughneck
New User

Jan 17, 2011, 9:25 PM

Post #3 of 3 (2742 views)
Shortcut
Re: 5.7 hemi lost all oil pressure [In reply to] Sign In

Thanks for the reply,and the advice,unfortunately I was out of town at the time and had to drive it on home,didn't have any problem but today the same thing happened again I will be finding the problem soon I will post when I know more.




Advertising


  Email This Post
 
 






Latest Forum Post

 HotOil warning, from cold start, and won't start, Jeep JK wrangler 2010 un...


1990 chevrolet c1500 4.6 tbi 110k recently replaced motor w/ a 93 4.6 had a fe...


I own a TOYOTA CAMRY LE , the rear driver side passenger side door received a ve...


Hi all, I wanted to check with you how much labor wise could it cost me to repl...


Mechanic changed serpentine belt on 09 Chevy Cobalt, said there were cracks in i...


1992 ford explorer,xlt,4.0,about two weeks ago alternator was over charging so r...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy