Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN




Saturn 2001 o2 sensor error despite replacement


  Email This Post



spiritusmachina
New User

Jul 30, 2012, 1:44 PM

Post #1 of 2 (1162 views)
Shortcut
Saturn 2001 o2 sensor error despite replacement Sign In

I have a 2001 Saturn L300 I bought a couple months ago. I bought it with the check engine light on from o2 sensor and the dealer agreed to replace it (it took a good month or so before this happened, I don't know if that effected anything). Anyway as soon as the sensor was changed the light came back on and then started flashing at me when I accelerate onto the freeway, it didn't do that before. I went and got it scanned and got o2 sensor codes again, with additional EGR valve and cylinder misfire errors. We changed the spark plugs and reset the check engine light but it again came back on. I drove it around a bit and got it scanned again and now it's saying just o2 sensor codes p0056 and p0161. Before I got it scanned I was thinking the EGR valve might need cleaned or replaced, but now as that error is not coming up, nor the misfire, I'm a bit lost as to what to do. Both of those errors refer to circuit issues. Any ideas what to do next? Thanks so much!


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jul 30, 2012, 3:01 PM

Post #2 of 2 (1133 views)
Shortcut
Re: Saturn 2001 o2 sensor error despite replacement [In reply to] Sign In

Those are both heater codes for the Bank2 downsteam sensor and they aren't affecting your driveability in any way.




~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.





Advertising


  Email This Post
 
 






Latest Forum Post

I have an '05 Jeep Liberty. I've learned the hard way that the transmission in t...


My experience as a mechanic is building dragsters and formerly working as a heav...


Randomly one day I went to my car and the door handle was very loose. It just w...


I may have multiple problems. I cannot adjust my heat. Hot air is always bl...


Hi, I have a 95 Oldsmobile Cutlass Supreme. Last year, as winter approached, I ...


 Had starter, alt, battery checked. Car starts great but will go completely...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy