Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









2005 ford escape


  Email This Post



mikearnold1962
New User

Feb 12, 2012, 7:01 PM

Post #1 of 3 (3241 views)
Shortcut
2005 ford escape Sign In

2005 ford escape 3.0 litre 6cly engine.check engine light on.used OBD2 code reader.code PO106 which is manifold absolute pressure/barometric pressure circuit range/performance problem.engine makes constant popping noise which seems to start when engine is warmed up.where do i start checking for this problem.where is the map sensor located on this engine.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Feb 12, 2012, 7:30 PM

Post #2 of 3 (3224 views)
Shortcut
Re: 2005 ford escape [In reply to] Sign In

The code is telling you that there is a problem with the MAP sensor signal. That is a sensor that reads manifold vacuum to determine fuel mixture. You need to examine the sensor, it's vacuum source and related wiring.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Discretesignals
Ultimate Carjunky / Moderator
Discretesignals profile image

Feb 12, 2012, 7:49 PM

Post #3 of 3 (3214 views)
Shortcut
Re: 2005 ford escape [In reply to] Sign In

MAP sensor is located on the firewall near the connectors for the ECU. Where does this popping noise sound like it is coming from? If you have intake backfires, that could cause a problem for the MAP sensor.





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.

(This post was edited by Discretesignals on Feb 12, 2012, 8:06 PM)




2005 ford escape


  Email This Post
 
 






Latest Forum Post

I was driving my 2008 Mazda 6i 2.3 L, home from work today when I noticed that t...


Greets, all - I just picked up a 2001 Mitsubishi Spyder in great condition. Ab...


ok here goes, i know i have a short in my driver side power window switch, the t...


I've never run into nor heard of this problem. I broke in a new stock SBC with ...


In my 2008 Chrysler Sebring, the transmission shift cable has fallen off of the ...


I have a 98 Neon 2.0 5sp. For sometime(4-5 months) it's had a little bit of cre...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics