Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN







Saturn SC2 - Trouble starting/all presets reset every time


  Email This Post



JBouc
New User

May 10, 2012, 2:44 PM

Post #1 of 2 (530 views)
Shortcut
Saturn SC2 - Trouble starting/all presets reset every time Sign In

I have a ’99 Saturn SC2 with about 110,000 miles (not sure of engine size). Two days ago I went to start it an nothing happened. No sound, no engine trying to turn over, absolutely nothing. Even the automatic locks and lights in the car wouldn’t work. On the radio plate while I was trying to start the car some strange symbols came up and something like “CCC” backwards (I think) came up. Tried multiple times and then about 20 minutes it started up perfectly fine for no apparent reason. Since then it’s been starting okay but the clock and radio presets reset every time I start the car. Also, I notice when I’m driving the lights on the radio and dashboard periodically dim (particularly when I hit the brakes). No error warning lights are on and car seems to drive okay (maybe a little jerkier than usual, RPMs revving up and down a bit more than they should…but not sure if that’s related). Any thoughts on what this could be? Is the car safe to drive until I can get to a mechanic?


Hammer Time
Ultimate Carjunky / Moderator


May 10, 2012, 3:11 PM

Post #2 of 2 (505 views)
Shortcut
Re: Saturn SC2 - Trouble starting/all presets reset every time [In reply to] Sign In

You have a bad connection somewhere, probably at the battery or main power distribution center.




~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.





Saturn SC2 - Trouble starting/all presets reset every time


  Email This Post
 
 






Latest Forum Post
     Replaced the original GM R4 compressor , today . ...
The front hub on my 2002 Isuzu Rodeo 4x4 doesn't look anything like the pictures...
Dear all: First post so please be gentle. Please note that I am quite technica...
1996 subaru impreza outback with leak coming in to the rear hatch. I have alrea...
To begin, Engine is at operating temp; no over or under heating issues with engi...
I have a 2001 Isuzu Rodeo and the transmission is slipping into 1st gear. Does i...

Feed Button


Used Car Search
Used Car Price Ranges:
Under $5,000
$20,000
$35,000

$10,000
$25,000
$40,000
$15,000
$30,000
$45,000
Over $45,000
Search used Cars By Manufacturers:
Used Acura
Used Audi
Used BMW
Used Buick
Used Cadillac
Used Chevrolet
Used Chrysler
Used Dodge
Used FIAT
Used Ford
Used GMC

Used Honda
Used Hyundai
Used Infiniti
Used Jaguar
Used Jeep
Used Kia
Used Land Rover
Used Lexus
Used Lincoln
Used Mazda
Used Mercedes-Benz

Used MINI
Used Mitsubishi
Used Nissan
Used Porsche
Used Saab
Used Scion
Used Subaru
Used Suzuki
Used Toyota
Used Volkswagon
Used Volvo
2010 Honda Civic
$15,770
2004 Jeep
$8,991
2012 Mustang
$22,990
1997 Honda Cr-V
$4,490
2010 Toyota Prius
$17,496
2010 BMW 328
$26,980




Automotive Forum Categories
Automotive Repair
Auto Body Repair and Refinishing
AC Auto Repair Help Forum
Automotive Wiring and Electrical

Auto Insurance and Car Financing
Automotive World
Brake Systems
Car Stereo Repair Advice
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair

Steering and Suspension
Tricks of the Trade
General Discussions
Car Shows and Events
The Bargin Bin
Motor Vehicle Inspection
Car Care Tips
Traffic Ticket Help
Car Racing

Gasoline, Motor Oils, Concept Cars
Remote Control Cars and Vehicles
Truck Repair
Truck Repair Advice


Truck Engine Repair
Truck Suspension Repair
Motorcycle Repair
Motorcycle and ATV Repairs

Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Seat Repair
Car Forum Posts - Sitemap


Search for (options)