Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN




Saturn SC2 - Trouble starting/all presets reset every time


  Email This Post



JBouc
New User

May 10, 2012, 2:44 PM

Post #1 of 2 (649 views)
Shortcut
Saturn SC2 - Trouble starting/all presets reset every time Sign In

I have a ’99 Saturn SC2 with about 110,000 miles (not sure of engine size). Two days ago I went to start it an nothing happened. No sound, no engine trying to turn over, absolutely nothing. Even the automatic locks and lights in the car wouldn’t work. On the radio plate while I was trying to start the car some strange symbols came up and something like “CCC” backwards (I think) came up. Tried multiple times and then about 20 minutes it started up perfectly fine for no apparent reason. Since then it’s been starting okay but the clock and radio presets reset every time I start the car. Also, I notice when I’m driving the lights on the radio and dashboard periodically dim (particularly when I hit the brakes). No error warning lights are on and car seems to drive okay (maybe a little jerkier than usual, RPMs revving up and down a bit more than they should…but not sure if that’s related). Any thoughts on what this could be? Is the car safe to drive until I can get to a mechanic?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

May 10, 2012, 3:11 PM

Post #2 of 2 (624 views)
Shortcut
Re: Saturn SC2 - Trouble starting/all presets reset every time [In reply to] Sign In

You have a bad connection somewhere, probably at the battery or main power distribution center.




~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.





Advertising


  Email This Post
 
 






Latest Forum Post

I am having a random repeating problem with a 2007 Honda Civic. The fuse that op...


Hi everybody not mechanical at all PLEAE HELP I HAVE A 2000 FORD TAURUS SE,,,B...


2003 Chrysler mini van. 3.3 ltr 133600 mi while driving, engine light came on b...


driver side spark plugs was no problem-3 out and 3 new ones in,now it's time fo...


1998 Chevy 3500,6.5 diesel,automatic trans,4WD,1ton dump truck. Problem:Driving ...


Hello all. I am going to take my car into the shop to see if they can help me di...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy