Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









PLEASE HELP! 94 Chevy Silverado K1500-no working brake lights!


  Email This Post



katierose
New User

Sep 14, 2010, 8:36 PM

Post #1 of 8 (4157 views)
Shortcut
PLEASE HELP! 94 Chevy Silverado K1500-no working brake lights! Sign In

My boyfriend and I own a 1994 Chevy Silverado K1500. It has a 350 in it with a 5.7 L. Our mileage is in the 187,000 range. We recently got our transmission replaced (by a specialized certified gentleman). All of a sudden, we have no brake lights. We've tried; replacing the relay switch, grounding ungrounded wires, replacing all necessary fuses, and replacing the main brake relay on the brake pedal. When we have running lights, we have no brake lights. Vice Versa. Now, we have no brake lights period. We've tried everything! It's driving us mad! PLEASE HELP!


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Sep 14, 2010, 8:53 PM

Post #2 of 8 (4138 views)
Shortcut
Re: PLEASE HELP! 94 Chevy Silverado K1500-no working brake lights! [In reply to] Sign In

Does the 3rd (high mount) brake light work?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



katierose
New User

Sep 14, 2010, 8:55 PM

Post #3 of 8 (4135 views)
Shortcut
Re: PLEASE HELP! 94 Chevy Silverado K1500-no working brake lights! [In reply to] Sign In

we have no brake lights what-so-ever. ha.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Sep 14, 2010, 9:39 PM

Post #4 of 8 (4130 views)
Shortcut
Re: PLEASE HELP! 94 Chevy Silverado K1500-no working brake lights! [In reply to] Sign In

Make sure your right about that. If so, you probably have a bad brake light switch or fuse to it. You will have to test for power in and out of the switch.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



katierose
New User

Sep 14, 2010, 9:41 PM

Post #5 of 8 (4126 views)
Shortcut
Re: PLEASE HELP! 94 Chevy Silverado K1500-no working brake lights! [In reply to] Sign In

We haven't had the 3rd high mount since we bought the truck. As for the brake light switch, where can we find that?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Sep 14, 2010, 9:43 PM

Post #6 of 8 (4123 views)
Shortcut
Re: PLEASE HELP! 94 Chevy Silverado K1500-no working brake lights! [In reply to] Sign In

At the brake pedal.
If that light has been out all along, then it may not be the switch at fault but you still need to run that test to find out.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



katierose
New User

Sep 14, 2010, 9:47 PM

Post #7 of 8 (4123 views)
Shortcut
Re: PLEASE HELP! 94 Chevy Silverado K1500-no working brake lights! [In reply to] Sign In

We've actually replaced the brake light switch already. is there anything else it couldbe?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Sep 14, 2010, 9:51 PM

Post #8 of 8 (4118 views)
Shortcut
Re: PLEASE HELP! 94 Chevy Silverado K1500-no working brake lights! [In reply to] Sign In

I didn't ask you to replace it. i asked you to test it. I need to know the test results.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.





PLEASE HELP! 94 Chevy Silverado K1500-no working brake lights!


  Email This Post
 
 






Latest Forum Post

I vacuumed the system and it seemed to be holding, but did not last overnight. ...


So I just bought a 2001 Volkswagen GTI and it seems sluggish. and the engine sh...


Okay folks first off I'm new to this forum I have searched and haven't really fo...


1994 Ford Taurus 3.8 L EFI 6 Cyl 205,000 miles I bought the car about 6 months ...


2002 ford windstar 3,8 160000 ok so i just replaced the shift tube assb. and no...


I am an EMT and recently purchased flashing lights to install in my personal veh...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics