Main IndexAuto Repair Home Search Posts SEARCH
Who's Online WHO'S
Log in LOG

99 Mercury Cougar Speedometer not working.

  Email This Post

New User

Mar 19, 2008, 1:08 PM

Post #1 of 3 (3242 views)
  post locked   post icon 99 Mercury Cougar Speedometer not working.  

recently my cougars speedometer has quit working. i checked the fuse, it seemed fine but i changed it with another of the same color anyways. it seemed to have some effect because when i turned the car on the speedometor toped out and then when back down. my gas and digital displays are also OUT such as Miles till empty and the Odometer. does anyone have a trobleshooting guide for me?


New User

Jan 22, 2013, 1:51 PM

Post #2 of 3 (2194 views)
  post locked   Re: 99 Mercury Cougar Speedometer not working. [In reply to]  


There is a sensor on the transmission for the speedometer. From under the vehicle look-up to see a black square block on top of the transmission that has a wire going to it. To remove the sensor you must first remove a pin. There is a lock on the pin. With a small short screw driver pry up on the flat part of the lock and the pin should then pull out horizontally, like a cotter pin. After the pin is removed and the connector is unplugged lift up to pull out sensor. They are about $30 @ Oreilly's. FYI - I got a new sensor from Oreilly's and the sensor did not work, so this may happen but once you get a sensor that works this will solve the speedometer problem.

Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jan 22, 2013, 6:22 PM

Post #3 of 3 (2178 views)
  post locked   Re: 99 Mercury Cougar Speedometer not working. [In reply to]  

Sport this thread is from " Mar 19, 2008, 1:08 PM "

I think if OP hasn't fixed this by now it's moot.

Thread closed by me.............. Tom

99 Mercury Cougar Speedometer not working.

  Email This Post

Latest Forum Post

Does this car have a factory 3.5 mm audio input that I can use for an mp3 player...

Hi everyone is it hard to replace a blower motor on Volvo C70 2007

I have a 86 Ford Bronco with a 302 engine and need a new carb. It is a 2 barrel ...


2002 suzuki xl7, 2.7, 4x4, a/c, a/t, 192,000 miles Wonderful car, we just inheri...

I have a 2010 Chrysler town & country 3.8 with 62000 miles. I am having rear...

Feed Button

Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap

Search for (options) Privacy

web statistics