Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









99 Mercury Cougar Speedometer not working.


  Email This Post



Dreads
New User

Mar 19, 2008, 1:08 PM

Post #1 of 3 (2544 views)
Shortcut
  post locked   post icon 99 Mercury Cougar Speedometer not working.  

recently my cougars speedometer has quit working. i checked the fuse, it seemed fine but i changed it with another of the same color anyways. it seemed to have some effect because when i turned the car on the speedometor toped out and then when back down. my gas and digital displays are also OUT such as Miles till empty and the Odometer. does anyone have a trobleshooting guide for me?

Dreads.


spidy68
New User

Jan 22, 2013, 1:51 PM

Post #2 of 3 (1496 views)
Shortcut
  post locked   Re: 99 Mercury Cougar Speedometer not working. [In reply to]  

Hello,

There is a sensor on the transmission for the speedometer. From under the vehicle look-up to see a black square block on top of the transmission that has a wire going to it. To remove the sensor you must first remove a pin. There is a lock on the pin. With a small short screw driver pry up on the flat part of the lock and the pin should then pull out horizontally, like a cotter pin. After the pin is removed and the connector is unplugged lift up to pull out sensor. They are about $30 @ Oreilly's. FYI - I got a new sensor from Oreilly's and the sensor did not work, so this may happen but once you get a sensor that works this will solve the speedometer problem.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jan 22, 2013, 6:22 PM

Post #3 of 3 (1480 views)
Shortcut
  post locked   Re: 99 Mercury Cougar Speedometer not working. [In reply to]  

Sport this thread is from " Mar 19, 2008, 1:08 PM "

I think if OP hasn't fixed this by now it's moot.

Thread closed by me.............. Tom




Advertising


  Email This Post
 
 






Latest Forum Post

2003 Chrysler mini van. 3.3 ltr 133600 mi while driving, engine light came on b...


driver side spark plugs was no problem-3 out and 3 new ones in,now it's time fo...


1998 Chevy 3500,6.5 diesel,automatic trans,4WD,1ton dump truck. Problem:Driving ...


Hi everybody not mechanical at all PLEAE HELP I HAVE A 2000 FORD TAURUS SE,,,B...


I am having a random repeating problem with a 2007 Honda Civic. The fuse that op...


Hello all. I am going to take my car into the shop to see if they can help me di...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy