Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN







350 tbi injector pulse prob.


First page Previous page 1 2 Next page Last page  View All Email This Post



roger2791
User

Sep 2, 2010, 10:09 PM

Post #1 of 35 (6525 views)
Shortcut
350 tbi injector pulse prob. Sign In

91 chevy silverado 1500 2wd step side 350 tbi lost injector pulse turned truck off and it would not start afterwards.
all fuses good truck will start and run w/starting fulid but dies when you stop spraying.
i can force the pulse on the injector with a test light between the purple w/white stripe wire off of the ing.module and the pos.side post of batt. so i know the injectors are good and its an new module (inside the dis.)


Hammer Time
Ultimate Carjunky / Moderator


Sep 2, 2010, 10:15 PM

Post #2 of 35 (6518 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

Are you losing the power side or the pulsing ground side?




~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



roger2791
User

Sep 2, 2010, 10:23 PM

Post #3 of 35 (6514 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

i get power to the injector but will not pulse


Hammer Time
Ultimate Carjunky / Moderator


Sep 2, 2010, 10:25 PM

Post #4 of 35 (6510 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

Does the check engine light come on for bulb check when the key is first turned on?




~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



roger2791
User

Sep 2, 2010, 10:33 PM

Post #5 of 35 (6506 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

yes light dose come on i also have a code stored. using jumper wire flashes code 12.32


Hammer Time
Ultimate Carjunky / Moderator


Sep 2, 2010, 10:36 PM

Post #6 of 35 (6502 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

That's an unrelated code. You could be looking at a bad ECM here but you need to first verify all the ECM grounds and the wiring to the injectors first.




~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



(This post was edited by Hammer Time on Sep 2, 2010, 10:37 PM)


roger2791
User

Sep 2, 2010, 10:43 PM

Post #7 of 35 (6496 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

where do i get good wiring diag.


(This post was edited by roger2791 on Sep 2, 2010, 10:50 PM)


Sidom
Veteran / Moderator


Sep 2, 2010, 11:20 PM

Post #8 of 35 (6492 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

Hmmmm..... This strange..... You are saying it's passing a "tap test".

I'm assuming you are using a noid light to check for pulse.....

You said the module is new...... The truck died and you just put a new module in it with the same results? or This module was new, already in the truck and it was running but now it died?






__________________________________________________________________________________________



roger2791
User

Sep 3, 2010, 12:07 AM

Post #9 of 35 (6487 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

changed the module after truck died because i could make the injectors fire with test light jumping it between wires coming out of moudule (purple w/ white stripe) and pos. term. of the batt. so silly me i assumed it was a module problem.


(This post was edited by roger2791 on Sep 3, 2010, 12:08 AM)


roger2791
User

Sep 3, 2010, 12:10 AM

Post #10 of 35 (6485 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

but i was told that this means the E.C.M is good. is this also a bad assaumtion?


Sidom
Veteran / Moderator


Sep 3, 2010, 2:30 AM

Post #11 of 35 (6482 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

With you getting a SES, flashing a 12 and passing the tap test it sure looks like its working.... As far as getting 2 modules doing the same thing, that's kinda out there to....

There is a few reasons why the PCM would shut down the pulse......It's late & my mind just aint movin that quick so I'll have to check all the reasons later..... One reason for sure, is WOT or clear flood. If the comp "thinks" you have it floored it'll shut off the pulse. Try disconnecting the TPS & see what that does (besides setting a code..Sly). You said you have a 32. The is just an EGR code & while there is no ref voltage the PCM does ground it.... Just for the hellva it, disconnect the egr solenoid, it should be just to the right of the throttle body....

This is an exploded diagram of the PCM connecter......What is missing on this is just the injector wires going to the injectors & the injector power source.... The PCM use this signal along with some other inputs to determine the pulse width for the injectors (how much gas the engine needs)



Just for the heck of it......triple check all the fuses...........please


Another thought after looking at this diag a bit............. Double check all the connecters in the dist...... It really seems like the module isn't sending a signal out on ckt 430..... I'll have to ponder this some more.........it's late..........







__________________________________________________________________________________________



(This post was edited by Sidom on Sep 3, 2010, 2:35 AM)


roger2791
User

Sep 3, 2010, 3:47 PM

Post #12 of 35 (6466 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

triple chk fuse and they are fine. today have noticed green wire off of the pick up coil going to the ing. module insalation is cracked and wire exsposed but if i had a problem with the pick up coil wouldnt i also have a problem with the spark (no signal to the (ext.) ing. coil resulting in no spark)


(This post was edited by roger2791 on Sep 3, 2010, 3:52 PM)


Sidom
Veteran / Moderator


Sep 3, 2010, 10:52 PM

Post #13 of 35 (6457 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

You know the one thing I didn't think about is there is a ground coming from the PCM to the module. I don't think it's a pickup coil either or it wouldn't run on starting fluid.....

Unfortunately my database is down. but if all the wires are good, new module and it's still not getting a pulse then HT is probably right and you may have a bad PCM........ This is where it would be real nice to have a "known good" tester to pop in real quick.....

IF you can't get a diagram for this.....I'll see if I can bring on from the shop.........






__________________________________________________________________________________________



roger2791
User

Sep 4, 2010, 12:56 AM

Post #14 of 35 (6453 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

you say a pcm? is this the same as ECM i didnt think this truck had a pcm its 91 but then again i dont know every thing or i would not be in this predicument. ha / ha. thanks for all your help its good to know that are still nice folks willing to help another when there down...


(This post was edited by roger2791 on Sep 4, 2010, 1:14 AM)


Sidom
Veteran / Moderator


Sep 4, 2010, 1:23 AM

Post #15 of 35 (6450 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

Yea it's basically the same thing...... PCM, ECM, ECU are all acronyms for the engine computer... Manufacturers all have to use different terms for the same thing.

Like HT said, the powers and grounds have to be verified 1st before pulling the trigger on it. If you had one you could swap, I'd definitely try that, if not I would want to make sure there wasn't a bad wire 1st before buying one..........


I'll see if I can't find some diagrams for you or maybe HT has some he can post....

Just a footnote, GM has a bad habit of listing comp ground circuits as "low reference". It shouldn't be a problem for what you have to do, but when you are tracing ref voltage circuits it can really get confusing & misleading if you aren't aware of it...............






__________________________________________________________________________________________



(This post was edited by Sidom on Sep 4, 2010, 1:27 AM)


roger2791
User

Sep 4, 2010, 2:08 AM

Post #16 of 35 (6443 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

thanx.


Hammer Time
Ultimate Carjunky / Moderator


Sep 4, 2010, 7:57 AM

Post #17 of 35 (6436 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

Make sure this matches because there are some varying versions of this








~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Sidom
Veteran / Moderator


Sep 5, 2010, 2:02 PM

Post #18 of 35 (6421 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

Yea that's what I was thinking of HT.

Roger you can see the 12v & grounds on those pins. While it does run with carb clean it would still be a good idea to make sure there is no power or resistance problems on those and the 5v ref is good as well......

These are the connection you really want to make sure are good. 453 was the ground I forgot about going to the module. While you can get a pulse with the tap test. That means the pcm can generate a pulse, for what ever reason it's not getting a signal to generate a pulse (maybe?)..... These problems are a little tougher to check out with out a scope but not impossible... This is for your module. You can find the corresponding ckt numbers on HT diagram....








__________________________________________________________________________________________



roger2791
User

Sep 5, 2010, 3:31 PM

Post #19 of 35 (6413 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

thanx im checking now and i will get back with the results.. am i to check the pins with the connectors on or off the ecm


(This post was edited by roger2791 on Sep 5, 2010, 4:37 PM)


roger2791
User

Sep 5, 2010, 4:38 PM

Post #20 of 35 (6403 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

am i to check the pins with the connectors on or off the ecm


Sidom
Veteran / Moderator


Sep 5, 2010, 5:32 PM

Post #21 of 35 (6396 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

I would 1st disconnect both ends of the connecters and check them with an ohm meter both for continuity and grounding. The system powers and grounds you can check with the connecters disconnect & KOEO. The signals & PCM grounds you are going to have to check with the connecters hooked up, KOEO & back probed.






__________________________________________________________________________________________



roger2791
User

Sep 5, 2010, 6:30 PM

Post #22 of 35 (6388 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

all is right (12 volts & grounds) exept for b5 there is no ground and when you probe with test light looking for ground you here what sounds like the fuel pump priming the line. and a clicking of a relay switch.


Hammer Time
Ultimate Carjunky / Moderator


Sep 5, 2010, 6:47 PM

Post #23 of 35 (6382 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

The fuel pump trigger should be a Dk green and and white on A1.
B5 is the EST reference signal on most and a speed sensor on one of them.




~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



roger2791
User

Sep 5, 2010, 6:53 PM

Post #24 of 35 (6378 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

 should it have ground (b5)


Hammer Time
Ultimate Carjunky / Moderator


Sep 5, 2010, 6:55 PM

Post #25 of 35 (6375 views)
Shortcut
Re: 350 tbi injector pulse prob. [In reply to] Sign In

No. it's an ignition signal from a module. Don't be sending power down it. You have to be careful what your testing here.




~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.





350 tbi injector pulse prob.


First page Previous page 1 2 Next page Last page  View All Email This Post
 
 






Latest Forum Post
Re: 2000 Buick Century 3.1L 120,000m - I‘m having problems replacing the ...
Actually the only way I could get any pedal at all (and enough pressure to turn...
OK, so I need to reopen this thread and take back my kudos from yesterday, sorry...
i can roll the windown up and down in my car with the key even putting the key i...
Hi, I love my car but have a problem that I've been unable to fix and would lov...
Hi, Ii have problem with my chevy cruze 2011, my car just 37000km. Before 2 week...

Feed Button


Used Car Search
Used Car Price Ranges:
Under $5,000
$20,000
$35,000

$10,000
$25,000
$40,000
$15,000
$30,000
$45,000
Over $45,000
Search used Cars By Manufacturers:
Used Acura
Used Audi
Used BMW
Used Buick
Used Cadillac
Used Chevrolet
Used Chrysler
Used Dodge
Used FIAT
Used Ford
Used GMC

Used Honda
Used Hyundai
Used Infiniti
Used Jaguar
Used Jeep
Used Kia
Used Land Rover
Used Lexus
Used Lincoln
Used Mazda
Used Mercedes-Benz

Used MINI
Used Mitsubishi
Used Nissan
Used Porsche
Used Saab
Used Scion
Used Subaru
Used Suzuki
Used Toyota
Used Volkswagon
Used Volvo
2010 Honda Civic
$15,770
2004 Jeep
$8,991
2012 Mustang
$22,990
1997 Honda Cr-V
$4,490
2010 Toyota Prius
$17,496
2010 BMW 328
$26,980




Automotive Forum Categories
Automotive Repair
Auto Body Repair and Refinishing
AC Auto Repair Help Forum
Automotive Wiring and Electrical

Auto Insurance and Car Financing
Automotive World
Brake Systems
Car Stereo Repair Advice
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair

Steering and Suspension
Tricks of the Trade
General Discussions
Car Shows and Events
The Bargin Bin
Motor Vehicle Inspection
Car Care Tips
Traffic Ticket Help
Car Racing

Gasoline, Motor Oils, Concept Cars
Remote Control Cars and Vehicles
Truck Repair
Truck Repair Advice


Truck Engine Repair
Truck Suspension Repair
Motorcycle Repair
Motorcycle and ATV Repairs

Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Seat Repair
Car Forum Posts - Sitemap


Search for (options) Privacy