Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

ses light on but no codes


  Email This Post



Dallas
Novice

Sep 19, 2022, 3:01 PM

Post #1 of 8 (240 views)
ses light on but no codes Sign In

I have a 1999 Hundai Elantra. It had thrown a Po137 O2 code. Auto zone said that code was why the ses light was on but they at first though it was not throwing any codes too until I asked them why the ses light was on. and a code because the filter was dirty. It would not stay in gear. That is fixed now. The SES light comes on even though no codes have been thrown. I have just bought this car and already had to replace the transmission filter, and both oxygen sensors, thermostat and the Flex pipe. How do I determine what I have to do now. I pilled the O2 sensor and hooked it up to a smoke machine and there are no exhaust leaks now.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Sep 19, 2022, 3:20 PM

Post #2 of 8 (237 views)
Re: ses light on but no codes Sign In


Quote
The SES light comes on even though no codes have been thrown.


Nope, it doesn't work that way. There is a code stored in there. You may need better equipment to read it.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Dallas
Novice

Sep 19, 2022, 3:39 PM

Post #3 of 8 (231 views)
Re: ses light on but no codes Sign In

Autozone has better equipment and they said it had a po137 code and he cleared it. I could not clear anything because my scanner said it had no codes. I replaced the flex pipe which had a flex pipe with a huge exhaust leak but it still is throwing that code and I replaced the o2 sensor too. I am thinking maybe I need to check the O2 sensor to see if the new one is working. what do u recommend


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Sep 19, 2022, 3:43 PM

Post #4 of 8 (227 views)
Re: ses light on but no codes Sign In

Which sensor did you change?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Dallas
Novice

Sep 19, 2022, 3:57 PM

Post #5 of 8 (218 views)
Re: ses light on but no codes Sign In

both upstream and downstream sensors


Dallas
Novice

Sep 19, 2022, 4:01 PM

Post #6 of 8 (216 views)
Re: ses light on but no codes Sign In

he said at first it had set no code. then I said why is the light still on. Then he started doing soimething with his scanner and said he dug around and found the 137 code and then erased itI said I hope it does not come back He said me too


Dallas
Novice

Sep 19, 2022, 4:08 PM

Post #7 of 8 (214 views)
Re: ses light on but no codes Sign In

After I put the new flex pipe exhaust pipe on I test it with my smoke machine and it did not leak anywhere. I then pulled the neg battery cable and let it set a hour and a half to clear the ses light I wanted to make sure the ecm reset. I drove it 6 miles and the light came back on.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Sep 19, 2022, 5:02 PM

Post #8 of 8 (203 views)
Re: ses light on but no codes Sign In

You shouldn't ever pull the battery cable. Not only that is may not clear the code but it also resets all the adaptive memory and can cause you even more problems.

The code was for a downstream sensor and the exhaust leak could definitely be the cause of that code. See if it comes back again before we waste any time looking for a problem.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap