Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









95 chevy s10 blazer vortec


  Email This Post



brock88
New User

Feb 16, 2008, 1:39 PM

Post #1 of 17 (10627 views)
Shortcut
95 chevy s10 blazer vortec Sign In

I have a 95 chevy s10 blazer with vortec. I have been having problems getting it running again. It all started with it not running good. It started and ran but sounded like crap. I could drive 50 miles easily with $10 of gas in the tank now it takes over $25. The oil was 5 quarts over filled. gas had gotten mixed with the oil. smoke is coming out of the exaust that smells like oil. first we replaced the spark plugs and wires and it started and sounded better but the rpms werent right. we then replaced the fuel pressure regulator and after that it wouldnt start. we also replaced the roder and distributor cap. the blazer still wont start. the fuel pump isnt getting any power. when you turn the key over you cant hear it. i was told that it is either the fuel pump is out or it is frozen (i sat out in the cold on an empty tank). my dad thinks that my friend didnt put everything back together when he put the fuel pressure regulator in. What do you think is the problem?
Brock


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Feb 16, 2008, 3:16 PM

Post #2 of 17 (10617 views)
Shortcut
Re: 95 chevy s10 blazer vortec [In reply to] Sign In

The fuel in oil problem was/is probably fuel injection gone nuts. Has that been corrected?

Will it fire with just priming it now to verify if it is lack of fuel right now as you said you heard the fuel pump??

T
_________________________________________
Long retired now


Guest
Anonymous Poster

Feb 16, 2008, 4:48 PM

Post #3 of 17 (10614 views)
Shortcut
Re: 95 chevy s10 blazer vortec [In reply to] Sign In

so how do fix the fuel injection problem? will fuel injection cleaner work?
i have tried turning it over numerous of times. it just wont start. before it at least would start, it just sounded and ran badly. now it wont start.
i dont think it is lack of fuel because its almost like its getting to much fuel(before i put all the new parts in). now its like its not getting any fuel at all. it has half a tank of gas now.
what do i do for priming it? how will that help?
and to answer your question no i dont hear the fuel pump.


Double J
Veteran / Moderator
Double J profile image

Feb 16, 2008, 5:18 PM

Post #4 of 17 (10610 views)
Shortcut
Re: 95 chevy s10 blazer vortec [In reply to] Sign In

<<< Check to see if it has spark ....>>>>>>
The fuel in the oil is a telltale that something injection related went nuts as Tom said...it is my understanding that the fuel regulator is part of the central port fuel injector and is replaced as an assembly...
<<<<<Does it have fuel pressure now?...>>>>>.
There are many things that can cause a no start ...check over his work if it ran before....maybe coincidental..
all electrical connections reconnected? things like that..

The non-repairable Central Multiport Fuel Injection (MFI) assembly consists of a fuel meter body, gasket seal, fuel pressure regulator, fuel injector and six poppet nozzles with fuel tubes. The Central MFI assembly is housed in the lower manifold assembly. Fuel system pressure range is 400-440 kPa (58-64 psi).


(This post was edited by JIM N on Feb 16, 2008, 5:25 PM)


Brent
Anonymous Poster
pinexcone@yahoo.com

Feb 17, 2008, 11:13 PM

Post #5 of 17 (10599 views)
Shortcut
Re: 95 chevy s10 blazer vortec [In reply to] Sign In

this sounds a lot like the problem I had with my Blazer. Does the oil have metal shards in it? You may have to overhaul the engine.


Guest
Anonymous Poster

Feb 18, 2008, 1:45 PM

Post #6 of 17 (10588 views)
Shortcut
Re: 95 chevy s10 blazer vortec [In reply to] Sign In

no. it has no metal shards in it. when i drained the bad oil it was like 2 gallons of oil. the majority of it was gas.
the only problem is the fuel pump. its not getting any power. is there a fuel pump fuse? if so where is it located?


Guest
Anonymous Poster

Feb 19, 2008, 8:56 PM

Post #7 of 17 (10572 views)
Shortcut
Re: 95 chevy s10 blazer vortec [In reply to] Sign In

is there a fuel pump fuse? if so where is it located?


Guest
Anonymous Poster

Feb 24, 2008, 11:39 PM

Post #8 of 17 (10543 views)
Shortcut
Re: 95 chevy s10 blazer vortec [In reply to] Sign In

First I am not a mechanic. But I do have a 95 S-10 Blazer, 4.3L Vortec V6. If you have not got yours going again, here is what happened to mine. At just over 200,000 Miles, it started running bad at low RPMs and produced alot of black smoke out the exhaust, also the check engine light would come on. This went on for a while, then finally it would not start. I took it to a Mechanic I met. He fixed it. I think it was what Jim N was telling you about, the tubes he mentioned were cracked and leaking fuel into the cavity in the intake manifold. (or where ever it is) I think this was all he did besides changing plugs,wires,cap, and rotor. It runs fine now , 265,000 miles.

Your problem sounded close to what I had, if not sorry I wasted your time. Like I said I am not a Mechanic.

Kyle


Guest
Anonymous Poster

Feb 27, 2008, 6:36 PM

Post #9 of 17 (10508 views)
Shortcut
Re: 95 chevy s10 blazer vortec [In reply to] Sign In

that does sound a lot like mine. i still dont know why my fuel pump isnt working. so what was it that you got replaced? is it something i can do myself?


najeerhodeisland
Anonymous Poster
najeebarros@yahoo.com

Mar 23, 2008, 12:06 PM

Post #10 of 17 (10344 views)
Shortcut
Re: 95 chevy s10 blazer vortec [In reply to] Sign In

you seem to have a vast knowledge of the s10. i would love to get some advice from you concerning my start up problems and how to make my 95' s10 blazer something to envy.


loco51
Anonymous Poster
locohoghead@aol.com

Apr 25, 2008, 4:57 PM

Post #11 of 17 (10131 views)
Shortcut
Re: 95 chevy s10 blazer vortec [In reply to] Sign In

I have a 95 s10blazer the fuel pump went out so I replaced it was trying to get to to start and it wasn't getting fuel after the fuel pump repair there is a fuel pump fuse which i never located . But there is also a fuel pump rely in behind the glove box I replaced it and then primed it some more then it caught up and runs fine now.

In Reply To



Guest
Anonymous Poster

Apr 25, 2008, 11:35 PM

Post #12 of 17 (10126 views)
Shortcut
Re: 95 chevy s10 blazer vortec [In reply to] Sign In

Sounds like ya got a couple of probs going on. If you have no power to the fuel pump, then first you are gonna have to fix that & get the pump going. Check power with a volt meter or test light & check the ground circuit also.
After you get it going, if it still has the prob, 1st double check the regulator, that is replacable seperately.
Jim is correct that the assembly (spider) is replaced as a unit , and the pressures are also correct. anything under 50 psi & it won't run.

Those injectors are cr@p & leak all the time. One thing alot of guys miss is the supply & return lines to the spider under the plentum. I had a few crack & leak & those don't come with the spider, they are seperate.

Easy enough to check, pull the plentum & turn the key on & pressurize the system. If either line is leaking.....replace them both and it wouldn't be a bad idea to replace the spider to...... do it now or do it later.........


Guest
Anonymous Poster

Apr 26, 2008, 6:37 PM

Post #13 of 17 (10112 views)
Shortcut
Re: 95 chevy s10 blazer vortec [In reply to] Sign In

I got a new fuel pump put in and we got it to start. There is a grinding sound coming from the starter. I took out the starter and it looks like the teeth might be stripped. It's either that or the fly wheel, but I dont have the tools to get to that. What do you think this is?

When we were able to get it started it ran but not good at all. I could be flooring it and it would only be going 5 miles an hour. If you gave it to much gas it would kill. What would this be caused from? What should I do?


Guest
Anonymous Poster

Apr 27, 2008, 2:38 AM

Post #14 of 17 (10105 views)
Shortcut
Re: 95 chevy s10 blazer vortec [In reply to] Sign In

Gonna have to start with the basics. Check fuel press, vac, spark, etc.

Jim has the fuel press specs for ya up there...mske sure it holds with the key off

vac should be about 18 in. If it drops alot on accel, might be restricted exhaust

spark about 40 kv


stacy
Anonymous Poster
d.scarborough@att.net

Apr 27, 2008, 5:44 PM

Post #15 of 17 (10096 views)
Shortcut
Re: 95 chevy s10 blazer vortec [In reply to] Sign In

[/reply][reply]Sounds like ya got a couple of probs going on. If you have no power to the fuel pump, then first you are gonna have to fix that & get the pump going. Check power with a volt meter or test light & check the ground circuit also.
After you get it going, if it still has the prob, 1st double check the regulator, that is replacable seperately.
Jim is correct that the assembly (spider) is replaced as a unit , and the pressures are also correct. anything under 50 psi & it won't run.

Those injectors are cr@p & leak all the time. One thing alot of guys miss is the supply & return lines to the spider under the plentum. I had a few crack & leak & those don't come with the spider, they are seperate.

Easy enough to check, pull the plentum & turn the key on & pressurize the system. If either line is leaking.....replace them both and it wouldn't be a bad idea to replace the spider to...... do it now or do it later.........[/reply][reply]


Guest
Anonymous Poster

May 15, 2009, 10:10 AM

Post #16 of 17 (7621 views)
Shortcut
Re: 95 chevy s10 blazer vortec [In reply to] Sign In

change your EGR valve


Loren Champlain Sr
Veteran / Moderator
Loren Champlain Sr profile image

May 15, 2009, 8:15 PM

Post #17 of 17 (7615 views)
Shortcut
Re: 95 chevy s10 blazer vortec [In reply to] Sign In

Thanks for your suggestion, but this thread is over a year old. Hopefully, they've got it figured out by now.
Loren
SW Washington




Advertising


  Email This Post
 
 






Latest Forum Post

What is the cheapest fix availible along with estimated repair price and what wo...


hi everyone this is mazda tribute 200, the code is p1131 where should we start t...


Hi,here's the info,hope a few members can help me please Car 1998 Olds intrigue...


Hi anyone: If you haven't left (by car) yet things you should really consid...


Hi There, I have a 92 Toyota Camry / Scepter with 236,635 kms / 147,038 miles. ...


I'm part of a research project at my university where we have two flow meters mo...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy