Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN






Search Auto Parts

Voltage problem 92 ford f150 5.0


  Email This Post



wes101382
User

Jul 30, 2010, 7:22 PM

Post #1 of 2 (2253 views)
post icon Voltage problem 92 ford f150 5.0 Sign In

I have a 92 Ford F150 with the 302 in it. For some reason when i am running the a/c and i come to a stop my voltage bogs down really low and some times even kills the truck. Brand new alternator and brand new battery, i had the alternator tested with a load on it and it tested good. Any suggestions?
Thanks
Wes


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jul 30, 2010, 7:30 PM

Post #2 of 2 (2251 views)
Re: Voltage problem 92 ford f150 5.0 Sign In

That's not unusual at all and is pretty much normal. The alternator is just not spinning fast ennough to keep up with the load being used at that RPM. Your problem may be more of an idle control problem rather than electrical.

You may have a bad IAC ( idle air control) but try cleaning the throttle body first. Remove the intake snorkel, have someone hold the throttle wide open for you and scrub the back side of the throttle plate and surrounding bore with an old tooth brush and some carb cleaner. Be sure to spray some into the small holes next to the throttle plate. That should help stabilize the idle. If it still has a problem, replace the IAC.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap