Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

TRUCK WONT START


  Email This Post



cowboy71584
User

Oct 8, 2009, 3:29 PM

Post #1 of 4 (2063 views)
TRUCK WONT START Sign In

Hey there

I have a 96 ford f-250 4x4 auto 7.3 turbo desial the problem I am haveing is the truck ran fine the stater started to mass up and drag down the batt I put a new starter in and hook the batts up to charge but now the truck wont fire off it truns over and over but never starts what can it this be i am thinking glow plugs are not heating up HELP thanks


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Oct 10, 2009, 7:06 PM

Post #2 of 4 (2042 views)
Re: TRUCK WONT START Sign In

Not a diesel guy but don't most have a light that say "ready" when glow plugs have heated up? The engine near certainly has to be able to turn at a reasonable RPM via good battery power and starter or I don't think these do well for cold starts,

T



cowboy71584
User

Oct 11, 2009, 10:33 AM

Post #3 of 4 (2029 views)
Re: TRUCK WONT START Sign In

Hey there the light goes out and the batts and starter are brand new


Loren Champlain Sr
Veteran / Moderator
Loren Champlain Sr profile image

Oct 25, 2009, 1:44 PM

Post #4 of 4 (1999 views)
Re: TRUCK WONT START Sign In

I know it's been nearly two weeks, but if you are still having starting problems, try cycling the key off when the glow plug light goes off, then turn the key back on, letting the glow plugs try to heat again. The glow plugs can be tested with an ohmmeter. One can short out and 'take out' others.
Loren
SW Washington






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap