Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

94 GM Sierra-Missing/backfiring under load


  Email This Post



Mountaineer
Novice

May 3, 2013, 7:32 AM

Post #1 of 25 (1840 views)
94 GM Sierra-Missing/backfiring under load Sign In

My father has this truck. It has a 4.3 V6 engine with 85k miles on it. It runs good until you put it under a load like towing or pulling a steep grade then the valves start knocking and it misses and backfires until you back off the gas. We've replaced the plugs, wires, and the dist cap and rotor. He had it to the garage and they replaced the catalytic converter and a module in the distributor. We also put on a new muffler and fuel filter. Still the same. Another mechanic looked at it last winter and said it was out of time and set the timing and it ran fine for awhile then started the same thing again. Could it be the crankcase sensor? Help! Thanks.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

May 3, 2013, 7:53 AM

Post #2 of 25 (1823 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

Arggh? This shouldn't knock without something wrong even a '94 model. Have timing looked at again especially if it hasn't been touched at all it should be where it was left and if not WHY?

It may not be able to compensate for load. How steep, how heave a trailer? Maybe, maybe it has excessive carbon build up and compression too high for it to control knock if in fact it's spark knock. Whatever don't let it do that as that's harmful to the engine.

Don't guess on a sensor have you mechanic check this out. Seems you aren't doing the work so let them do what they know how and describe what is happening as you just did,

T



Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

May 3, 2013, 7:53 AM

Post #3 of 25 (1820 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

Sounds like it is going lean. What is the fuel pressure?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Mountaineer
Novice

May 3, 2013, 8:12 AM

Post #4 of 25 (1813 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

Haven't checked the fuel pressure yet. My Dad lives away from me so I haven't been able to work on it myself. He had it to the GM garage and they were pretty much worthless. It does this just pulling a hill on the interstate without a trailer. Can't figure out why it was out of time but when the one mechanic fixed the timing it ran fine for awhile. Just at a loss right now.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

May 3, 2013, 9:53 AM

Post #5 of 25 (1788 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

Can't know your exact logistics to deal with this for your Dad or how far it is. If a GM shop wasn't fruitful it needs another or another person there. This can't stay this way.

What I see is a low mile truck for it's years and maybe (you have to say) a lot of poking around driving. I'm guilty of that and do purposely get out and take a good run as where I am is all slow driving for myself.

So, if you can't be there with stuff to check things out yourself then it (depending on your situation) it needs another look at by another. Who can know?

Haven't taken on anything in ages now. Would when I hear from friends or family but driving 3-4 hours to come to me is a waste and then go back with hopes that something doesn't crop up the delays a repair.

Is it real knock as in ping, knock, pre-ignition and are you sure of that from afar? IDK - Hammer suggested fuel pressure of possible things. It's goofy but you say "Dad" and I think of an older person but that may not be the case. Just between the lines, old vehicle, low miles suggests it isn't going all over the place all the time. I haven't seen a true carbon build up in quite a while or heard of one. Then again locally and family I don't know anyone who only pokes around all the time. Carbon build up should burn off with HWY use by itself - some don't but not many and those need tricks to break it up and blow that out. Probably not the case by guess right now.

You have to scope out the situation of what you can do from afar. We are not right there so that's that......... Tom



Mountaineer
Novice

May 3, 2013, 10:26 AM

Post #6 of 25 (1781 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

My Dad is older and in the past few years putting around town in the truck is about all it's used for. It ran good up until last spring with just a little miss. Plugs, wires, and dist cap fixed that. This past fall was when it started really acting up.

Sorry I can't give more info. I'm afraid the guys at the GM dealer aren't much older than the truck and if they can't have a computer spit out the problem they can't fix. Manager there actually told me to call him if I figured it out! LOL....

I'll try and get more info the next time I'm there. He's not driving it right now.
Thanks.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

May 3, 2013, 11:43 AM

Post #7 of 25 (1776 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

OK - I see the picture better. The GM dealer asked you to search out what's possible! That's nuts - need another place -- that you could probably do. ASE certified helps if you find a place/shop. I hear you with the age thing. I drive not quite exactly yet a 25 year old vehicle and it's older than most people I deal with out there! Laugh - at least I can identify it in a parking lot as it's the only thing that old around!

OK - you may know '94 is OBD I and codes can be had if any. If check engine light is on there's definitely some useful info to be had. Not all places will read codes for OBD I anymore and you can - don't make me go look as I have a thing and book for those retrieve them without tools counting blinks.
From that a # and go from there. I think if CEL is not lit there will be nothing to be found except that it does communicate.

Back some. You said it could back fire when it does this and it shouldn't do that ever of course if all was right. Someone with some sense and grey hair perhaps needs to look at this in person. Even take it for a run and witness it happening if that helps.

I bet you know that when you bring something in to a shop that runs just fine at the time diagnosing it if not more intense is a lost cause. Apparently it will do this if put in the right conditions. That actually helps. Not for your Dad but some tech may even just "brake stand" it and get the knock in place.

Pretty much this 4.3 is a 5.7 (I think) with two cylinder cut off. A known good basic design and anything can do anything. The ones I knew just ran fine with no surprises till they hopelessly rusted out which is the problem here - MA.

You said setting the timing back when worked for a while. There's a clue possible in that so mention that to whoever is checking it out if you get involved.

I quit all this now long ago. There's a thing mentioned called a "Motor Vac" that force feeds strong solvent to clean injectors. That and checking everything about throttle body, vacuum hoses everywhere. If it's not all rusted it should be worth a few bucks to make it right. Might be something simple??

You're a good kid. This is extra tough for us second hand then to web with no vehicle in front of you. Good luck. Let us know what cures itWink

Tom (On edit - if someone gets a code if applicable hit back if they don't know what the # means. I saw my paper book just the other day and tell you what it says for what # if not easier on web in general or others here)



(This post was edited by Tom Greenleaf on May 3, 2013, 11:46 AM)


Mountaineer
Novice

May 4, 2013, 3:50 AM

Post #8 of 25 (1754 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

Thanks for the help. If we get it figured out I'll let you know. Dad's not really in a position to buy a new truck right now and this one has low enough miles and is in good enough shape that I want to get it running right for him. I'm hoping its something simple that we just haven't gotten to yet.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

May 4, 2013, 5:07 AM

Post #9 of 25 (1750 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

If this truck is basically OK keep it. You can do a ton of work vs new. Shoot - didn't look back first if already said but even at low miles the timing chain could be jumping around. Rare to me on this engine but it's nowhere near new either. No clue how but some can jump and jump back on time. That you can test by turning crank bolt one way then the other and see how for you can turn it vs the rotor (think has one) in distributor turns. Also, not sure which ones but a lot of nylon toothed cam gears were used that don't like time never mind miles.

Not the worst to get at or do on a Chev block. You really don't know the real condition till you are looking right at them and by then you are nuts not to toss it. All labor and gasket scraping, parts cheap as things go. If unfamiliar you just go like doing a water pump on this type engine and you are almost done. Just the timing cover and voila, there it is. If it goes there, toss the water pump just for good measure. I like new ones not rebuilt (not always more expensive) but some are an improved design. Pumps are just a metal casting with bearings and seals really. Not these TMK but some the impellers get corroded and plain don't pump well.

Would you be fixing this yourself if you had it in hand or finding your own local better known help? Said already almost all 4.3s I knew and not that many actually ran until body was NG to render the vehicle at large not worth messing with any more. It's a road salt problem where used for ice and snow. Frames, even give out - heck the bridges use steel that gives out too. Some whole states don't allow its use and wish they didn't here either,

T



Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

May 4, 2013, 5:23 AM

Post #10 of 25 (1744 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

Sorry for another post in a row - don't forget fuel pressure test too. In this case even if it tested OK at idle and KOEO I might "brake stand it" to put a load on it to use some more fuel and see if that puts it too low. Since this problem is clearly load dependant it may not have the volume needed. Change filter anyway - fuel isn't as clean with the ethanol used almost everywhere as it could be back when....

T



Mountaineer
Novice

May 10, 2013, 9:06 AM

Post #11 of 25 (1717 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

The fuel filter has been replaced. A friend of mine's dad has been working on it some but I don't think he's checked the fuel pressure. I'll check it the next time I'm in.

If I check the timing and it is out again, what would be the next thing to check? As I said earlier the timing was adjusted in the fall and things seemed fine for awhile. Then it started up again. Surely the timing chain wouldn't stretch and cause this kind of problem? Dad seemed to think this could happen but I didn't think it was likely. I've seen chain tensioners break and broken timing gear teeth and these vehicles were done until parts were replaced.

Again thanks for the help.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

May 10, 2013, 10:55 AM

Post #12 of 25 (1712 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

Do or get your checks done. Timing gears and chain are just straight chain and gears - no tricks. May have said, sorry that some cam gears came with nylon teeth that did or didn't take age, or miles well. Hard part is you aren't sure till looking right at those. They can be pretty dang sloppy with almost no symptoms but do keep valve timing on target.

It's just amusing that setting timing which IMO should last a long time if untouched made a difference for a while and this chain is a possible reason. Said already that I'm not hearing of many on this block with double or more miles and about as old. It's just those can cause backfire if it can jump enough.

Basic as shown here.......

Never saw a replacement with the nylon teeth and would get one made that way if they were available.

I'm just saying rule it out - fairly easy and free really to check what you can without tearing off the front of the engine. Still check fuel pressure and perhaps mist wires and all high voltage items with some slightly salty water to see if anything leaks out. New secondaries or not the spark voltage is stressed when under load vs idle and just seeks the easiest route to ground and may not do it without load on the thing.

Right now I don't think this is some monster problem, just some age on it so rule out as much as possible without spending a fortune on things it probably doesn't need,

T



(This post was edited by Tom Greenleaf on May 11, 2013, 5:45 AM)


Mountaineer
Novice

May 10, 2013, 11:13 AM

Post #13 of 25 (1708 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

Your right. They tensioner we replaced was on a timing belt. I agree it's probably an easy fix we just haven't gotten to yet.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

May 10, 2013, 11:41 AM

Post #14 of 25 (1705 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

Right - nothing fancy IMO. Just getting water pump and stuff out of the way mostly. Again - you can get an idea by turning crank bolt back and forth watching distributor rotor for how much 'play' it has. It's a clue anyway. Some just last forever and some of them don't?? Not expensive stuff just the time and possible work with gasket scraping if in fact it gets done. I'd think about a water pump if I was there as of course it's off anyway and maybe a fan clutch. Quality stuff near always pays off even with this stuff,

T



nickwarner
Veteran / Moderator
nickwarner profile image

May 10, 2013, 6:04 PM

Post #15 of 25 (1697 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In


In Reply To
Your right. They tensioner we replaced was on a timing belt. I agree it's probably an easy fix we just haven't gotten to yet.


You have a 4.3. This is a timing chain engine. If you bought a timing belt tensioner, where did you put it? I could see a new serpentine belt tensioner but there is no timing belt on this motor.


Mountaineer
Novice

May 10, 2013, 10:10 PM

Post #16 of 25 (1692 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

I misspoke. The timing belt tensioner was on a buddy of mines daughters car. A Nissan I think. I helped him replace the tensioner and it was a bear! No room to work.


HT
User

May 11, 2013, 3:28 AM

Post #17 of 25 (1685 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

A 4.3 with 87K doesn't have a bad timing chain. You need to take a hard look at all parts in the secondary ifnition system and make sure the fuel pressure isn't wavering at all under load. Make sure there are no vacuum leaks anywhere.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

May 11, 2013, 5:56 AM

Post #18 of 25 (1679 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

Right HT - I doubt the chain. Different bird but a GM 2.8 @ 15 YO double the miles had a bad one when there but had never jumped. But..... ran much better with new one, - T



HT
User

May 11, 2013, 6:27 AM

Post #19 of 25 (1673 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

I've seen this engine with 250K and still not need a timing chain.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

May 11, 2013, 6:45 AM

Post #20 of 25 (1669 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

Me too, even more miles. Vehicle I found I was going nuts on, given to me and known abused with oil changes etc. Was S-10 (1984, 4X4 worked) - got that @ 14 YO to make a plow truck out of so did everything and needed everything. Cheap parts for those except carb, last one really stunk,

T



HT
User

May 11, 2013, 8:22 AM

Post #21 of 25 (1663 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

That would have been a 2.8. This is a 4.3. It's basically a 350 with the 2 back cylinders cut off.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

May 11, 2013, 9:08 AM

Post #22 of 25 (1657 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

Right. Not my fav engine vs a 4.3 but the purpose for that thing was just run, room for hydraulic pump for plow and did have a strong frame, 700R trans.

Trouble in MA is it was slightly not legal just in that I had to cut off air intake snorkel so make just little room for the pump so lost the warm air pick up off manifold only. After 15 model years then nobody needed to look under hood for state inspection as zero alterations of anything emission related would render it not street legal but was able and got a real sticker.

If that thing was just a yard vehicle would have still done it up.

Back to this 4.3, timing and backfire under load that setting timing once seemed to fix for some time? That is what makes me wonder if nobody touched it why did the issue come back some time later? Coincidence, just can't keep timing or off on a goose chase and it's something else entirely? IDK, just need to check a lot of things IMO if nothing is obvious, - T



Discretesignals
Ultimate Carjunky / Moderator
Discretesignals profile image

May 11, 2013, 12:18 PM

Post #23 of 25 (1648 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

Starting to wonder if this engine has a valve sealing issue under load. Worn valve seats can cause backfiring under engine load when the cylinder pressure is the highest.





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.


Mountaineer
Novice

May 23, 2013, 11:42 AM

Post #24 of 25 (1619 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

Update on my Dads truck. I listed the things that we replaced and what the truck was doing. After the last round of replacing parts it was still bucking under load with the valves chattering. I talked to him last night and they have been driving the truck to move stuff from their camp and he said he's had no problems with it. No backfire or valve knock. What's going on?

I'm going in to visit this weekend and plan to drive it and check a few of the things you all recommended. I guess if it's running ok then I should just leave well enough alone. I'll give an update after I put it through the paces.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

May 23, 2013, 12:47 PM

Post #25 of 25 (1613 views)
Re: 94 GM Sierra-Missing/backfiring under load Sign In

OK - I didn't re-read entire thread but fine to do some harmless checks without changing much of anything. If everything checks and runs perfectly now it isn't going to show a lurking something.

Just maybe some below grade gas, the carbon build up mentioned are all cleared up from use now. If it doesn't do it again in the same manner just forget all but routine maintenance for now??

T







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap

shopify
site analytics