Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









gmc sonoma starting problems...please help!


  Email This Post



n_webb08
New User

Jan 21, 2012, 5:26 PM

Post #1 of 7 (4777 views)
Shortcut
  post locked   gmc sonoma starting problems...please help!  

i have a 2000 gmc sonoma 2.2l automatic. its having problems starting, it will crank but it wont start. sometimes it seems if i have the gas pedal to the floor it helps it start but that doesnt seem to make since seeing if u have the gas pedal to the floor it shuts the fuel injectors off. i replaced the battery but it still doesnt seem to help too much. when i get it started have it running for awhile drive it shut it off then try to start it right back up it will start fine. idk if the cold weather is having anything to do with it. also i have codes for throttle position sensor and o2 sensor not sure if that would have anything to do with it starting. please help me!


(This post was edited by n_webb08 on Jan 21, 2012, 5:34 PM)


re-tired
Veteran / Moderator
re-tired profile image

Jan 22, 2012, 11:31 AM

Post #2 of 7 (4720 views)
Shortcut
  post locked   Re: gmc sonoma starting problems...please help! [In reply to]  

Clear your codes and see which returns. Possable faults could be leaking injector(s) when eng shutoff . Going into clear flood mode would help unflood eng. Or a out of wack temp sensor. If the code for the TPS comes back It needs to be checked with a scanner or dvom meter.


LIFE'S SHORT GO FISH


Discretesignals
Veteran / Moderator
Discretesignals profile image

Jan 22, 2012, 11:35 AM

Post #3 of 7 (4716 views)
Shortcut
  post locked   Re: gmc sonoma starting problems...please help! [In reply to]  

Security light on or flashing when your attempting to start it?





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.


n_webb08
New User

Jan 22, 2012, 8:21 PM

Post #4 of 7 (4696 views)
Shortcut
  post locked   Re: gmc sonoma starting problems...please help! [In reply to]  

no security light comes up when i try to start it. also i should mention that when i keep trying to starting it there is a faint smell of gasoline under the hood so the leaking injectors idea seems like it could be a possiblity. if that was the case what would be causing that....bad o-rings on the fuel injectors maybe?


Discretesignals
Veteran / Moderator
Discretesignals profile image

Jan 22, 2012, 9:35 PM

Post #5 of 7 (4687 views)
Shortcut
  post locked   Re: gmc sonoma starting problems...please help! [In reply to]  

If you had a bad top o-ring, you would see fuel leaking externally from the injector in question. If the bottom o-ring was leaking, you would have a vacuum leak.

Another possibility is a fuel pressure regulator leaking from a ruptured diaphragm allowing raw fuel to enter the intake manifold. Pull the vacuum hose from the regulator and inspect for raw fuel.





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.

(This post was edited by Discretesignals on Jan 22, 2012, 9:36 PM)


toolman0007
User

Mar 21, 2013, 10:58 PM

Post #6 of 7 (3065 views)
Shortcut
  post locked   Re: gmc sonoma starting problems...please help! [In reply to]  

I would check your temp censor and plug end GM's have a issue with corrosion. full flood mode start or hard start cold or hot are common connections with the temp censor it the first in line to tell the system how much fuel to deliver. been down this road


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Mar 21, 2013, 11:03 PM

Post #7 of 7 (3061 views)
Shortcut
  post locked   Re: gmc sonoma starting problems...please help! [In reply to]  

Stop responding to old questions.




~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.





Advertising


  Email This Post
 
 






Latest Forum Post

My question is regarding a problem with an 03 Infiniti G35 with 5 speed automati...


 HotOil warning, from cold start, and won't start, Jeep JK wrangler 2010 un...


 Had starter, alt, battery checked. Car starts great but will go completely...


 will not start unless bumping starter, will not crank in starting position...


What is the cheapest fix availible along with estimated repair price and what wo...


hi everyone this is mazda tribute 200, the code is p1131 where should we start t...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy