Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

Wipers not working right


  Email This Post



confused1
Novice

Mar 9, 2008, 10:24 AM

Post #1 of 7 (2147 views)
Wipers not working right Sign In

I have a 1999 GMC ext.cab truck and my wipers only work on fast speed.When I turn them on nothing till
I reach the fast speed then they work fine but as I go to turn them down to a slower speed or off the wipers just stop where ever they are on the windshield so I have to keep turning the switch till I get the wipers to stop at the bottom of the windshield. What would be causing this to make the wipers only work in fast speed? How would I fix this? Is it the motor or a wiper switch relay (whatever that is) Anybody have any help ?? What should I do? Ok someone told me it could be a GM WIPER MOTOR PULSE BOARD ASSEMBLY where is this and and how do you replace it and it easy to do? Could this be the problem?
Unsure


(This post was edited by confused1 on Mar 9, 2008, 4:07 PM)


Double J
Veteran / Moderator
Double J profile image

Mar 9, 2008, 8:42 PM

Post #2 of 7 (2136 views)
Re: Wipers not working right Sign In

Yes..sounds like thats your problem.... "pulse board"
Its mounted on the front of the wiper motor...black cover....easy to remove and install...

Let us know how you make out...


(This post was edited by JIM N on Mar 9, 2008, 8:45 PM)


confused1
Novice

Mar 9, 2008, 8:49 PM

Post #3 of 7 (2131 views)
Re: Wipers not working right Sign In

Thanks Jim will do.I found one at JC Whitney's around $ 27.00,better than a new motor.Smile


confused1
Novice

Mar 10, 2008, 5:42 PM

Post #4 of 7 (2124 views)
Re: Wipers not working right Sign In

Hi again Jim
I was told there might be a sealing issue after taking the black cover off the wiper motor to change the pulse board. What should I use or is there something else I need to order to seal it back up so water won't get in it? What would you suggest? Help please I've never installed any wiper motors on newer trucks. What do I need to be aware of after removing the cowl cover? Is it really a easy job? I'm just not sure. Thanks Jim


Double J
Veteran / Moderator
Double J profile image

Mar 10, 2008, 6:11 PM

Post #5 of 7 (2119 views)
Re: Wipers not working right Sign In

Honest ...it is an easy job...

Take a look at the wiper motor...you'll see the black cover mounted to it...thats it...disconnect the wiring connector,remove the attaching screws....install in reverse order....

Here is a picture of one.....CRedit to Dan D...for the pic..As Dan said...don't know who DR.Auto Parts is...just a good pix.




(This post was edited by JIM N on Mar 10, 2008, 6:19 PM)


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Mar 10, 2008, 8:32 PM

Post #6 of 7 (2116 views)
Re: Wipers not working right Sign In

Excellent JIM. confused1 - if you feel you need to seal something, consider the liquid electrical tape, brush in cap stuff. Auto stores or home centers too. Handy stuff for all kinds of things - tolerates heat, oils etc.,

T



confused1
Novice

Mar 10, 2008, 11:38 PM

Post #7 of 7 (2110 views)
Re: Wipers not working right Sign In

 Thanks Jim and Tom I'll work on it as soon as I can ,hopefully it'll solve my problem.Smile






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap