Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN






Search Auto Parts

Ford 2008 E-250


  Email This Post



Longhorn Lady
New User

May 23, 2009, 4:02 PM

Post #1 of 2 (1154 views)
Ford 2008 E-250 Sign In

2008 Ford E-250 (not sure of engine size, don't own it, 5.4 maybe??), does have 42,000 miles on it.

Had no brake lights and they took it into the shop and had it fixed 2 weeks ago. It was apparently fixed and working fine. Drove it last night and it worked fine. This morning, it wouldn't start. Using tester, tested all fuses, everything fine. Tried to jump it and nothing. When you turn the key, there is a clicking sound. Couldn't short across the solenoid to start, so replaced the solenoid under the battery. Still just clicks when the key is turned. Shorted across starter and the engine turns over nicely, but won't start. You can hear the fuel pump kick on when it's turning over. Removed starter and had it checked. Checked out fine, but sounded bad, so replaced starter. No improvement, everything still the same.

Is there some sort of safety relay or switch that could be bad that won't allow the vehicle to start? Possibly something with the ignition?? The van belongs to a band playing in our area and they are stranded at the motel and it's Memorial weekend and everything is closed. Any thoughts??


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

May 24, 2009, 1:08 AM

Post #2 of 2 (1135 views)
Re: Ford 2008 E-250 Sign In

Too new for me to have checked one out yet. Seems like either battery connections aren't right or the cables along to starter or where grounded to block. This should still be 100% on warranty - right?
A fault with brake light switch might be causing a drain??
T







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap